Diagonal rod length on delta printer issues.



  • I am pretty sure there must be a error somewhere. Just setup my Rostock Max V2. I don't have a probe so all the calibration was done with an indicator and the least squared calculator on the website. I have to admit that even after leveling and squaring up countless machine tools, this was the worst, by a large margin.

    I have been through it countless times trying to get it correct without changing the arm length, and fiddling with the bed tilt to get it as close as possible. My steps per mm is set to 80.3 as that seemed to produce correct travel distances. Here is my Delta numbers. Seemecnc says 291.06 diagonal rod length. I haven't been anywhere I have a way to measure it in a way where I'd like to share my results, but surely someone would have shared that the mold was so far off by now. New skates, new balls, new springs, square within a piece of paper with a 15" carpenter square.

    • M665 R144.80 L293.40 H367.25 B140.00 X-0.20 Y0.51 Z0.00
      M666 X0.50 Y0.03 Z-0.53 A-.12 B-.38

    I haven't had a chance to print and check the dimensional accuracy yet. But after a lot of thought, there can not be 2 mathematical solutions to get results as good as I'm getting. This has come up before here and elsewhere. Previous thread here

    This is a 1 inch dial indicator, so the divisions are .001". No bed mapping, just calibration.

    https://www.youtube.com/embed/dRv_20ABC_g

    Just wondering since this is driving me crazy.
    Cory



  • I got done with the first test print. It's got 3 60mm raised areas in line with the towers.

    • X=59.79mm
      Y=59.58mm
      Z=59.36mm

    Some could be from under extrusion, some could be fixed with scaling factor. But something isn't square or something. It's an antique square.

    I still can not understand how the rods being programmed incorrectly could produce a bed that probes about .05mm from true. Before I could get not horrible results from the towers to the center of the bed, but crossing over the center to the areas opposite the towers the machine went Z positive quite a bit.

    Thanks
    Cory


  • administrators

    If you know the rod length then we recommend you use 6 or 8 factor calibration, not 7 or 9.

    You can use the built in calibration, just set the Z probe type to 0 in the M558 command.



  • Thanks for the reply. I understand what you are saying, but 1st I can't find how to feed the numbers I gather manually into the calibration command. Or how it works without a probe.

    I ran 6 factor probably 20 times and wasn't able to get anything decent. I switched to 7 factor the bed went to with about .05mm within a iteration or 3. I was probing 10 points the whole time and was reliably .25 mm off with 6 point. Including trying to guess the bed tilt along the way.

    Can you please explain, or point to a how to, on using the built in calibration without a probe?

    What I can not get is that an incorrect rod length could fix any issue, nearly perfectly. Maybe improve, but this close?

    Thanks again
    Cory



  • @clytle374 said in Diagonal rod length on delta printer issues.:

    using the built in calibration without a probe?

    In your config.g where you'd setup the probe, you use P0 as the probe type. Then whenever a probe operation is required a popup dialogue will come up in the DWC asking you to job the nozzle to the bed.

    M558 P0
    G31 X0 Y0 Z0



  • @phaedrux said in Diagonal rod length on delta printer issues.:

    @clytle374 said in Diagonal rod length on delta printer issues.:
    M558 P0
    G31 X0 Y0 Z0

    Thanks for the reply, been crazy at work so just got back to this.

    That probes one point. How do I feed it multiple points and have it run the calibration? I've honestly looked for this a bit, maybe I'm missing something.

    Also, I can't easily get my computer to the printer and use my phone. On the smaller screen I don't get the fine z steps in the machine control tab, or the g31 command. Can this be changed?

    Thanks again
    Cory



  • You mean to probe multiple points to do mesh bed compensation? That would be G29

    https://duet3d.dozuki.com/Wiki/Using_mesh_bed_compensation



  • @clytle374 said in Diagonal rod length on delta printer issues.:

    @phaedrux said in Diagonal rod length on delta printer issues.:

    @clytle374 said in Diagonal rod length on delta printer issues.:
    M558 P0
    G31 X0 Y0 Z0

    Thanks for the reply, been crazy at work so just got back to this.

    That probes one point. How do I feed it multiple points and have it run the calibration? I've honestly looked for this a bit, maybe I'm missing something.

    Also, I can't easily get my computer to the printer and use my phone. On the smaller screen I don't get the fine z steps in the machine control tab, or the g31 command. Can this be changed?

    Thanks again
    Cory

    You need to set up a bed.g file with all your points in it then the calibration routine will move to each point in turn and ask you to jog down and then accept the point it will then move on to the next and so on

    If you don't have a bed.g then you can use DC42's generator to make one for you Bed file generator



  • Thanks again! I've reset my rod length back and running the probing and with 8 factor calibration. Have a few more questions.

    Can the Z steps be changed in the DWC? The phone is only .5mm and on my PC it's .05mm. Phone is unusable, and PC is still a bit course?

    config line it output

    • M665 L291.060:291.060:291.060 R144.059 H359.447 B140.0 X-0.407 Y0.338 Z0.000
    • M666 X0.128 Y0.253 Z-0.381 A0.15 B-0.34

    end of my bed file

    • G30 P15 X0.00 Y-70.00 Z-99999 H0
    • G30 P16 X60.62 Y35.00 Z-99999 H0
    • G30 P17 X-60.62 Y35.00 Z-99999 H0
    • G30 P18 X0 Y0 Z-99999 S8

    Z-probe in config file

    • ; Z-Probe
    • M558 P0 H1 F120 T1800 ; Disable Z probe but set dive height, probe speed and travel speed
    • M557 R125 S20 ; Define mesh grid
    • G31 Z8.55

    My indicator triggers about 8.55mm high. When I run auto calibration it resets my Z height. H367.55 to H359.447 so on the second run my probe is way too high. What am I getting backwards in the config?

    Cory



  • Second update.

    7 factor error was 0.0508
    8 factor error 0.3048mm after multiple iterations

    • Calibrated 8 factors using 19 points, deviation before 8.525 after 0.146
      Deviation before is obviously due to having something wrong with my probe setup and it changing my H number. Deviation after is overly optimistic like the least-squares calibration calculator online calculator I was using before.

    I am borrowing another square to see if my error is there. Still can not comprehend using an incorrect number (and math being done correctly) and getting such good results.

    video

    Cory



  • You can adjust the baby step rate in DWC

    0_1556723874149_80545195-f70b-40dd-b820-e47b7b6c9390-image.png (this is on DWC 2.0.0-RC6)



  • @dougal1957 said in Diagonal rod length on delta printer issues.:

    You can adjust the baby step rate in DWC

    0_1556723874149_80545195-f70b-40dd-b820-e47b7b6c9390-image.png (this is on DWC 2.0.0-RC6)

    That doesn't seem to effect the z steps in machine control or in the probing cycles.



  • So my square is within .1mm as confirmed with and indicator on a CNC milling machine.

    I'm back to what error can be covered up so perfectly by using a wrong number when doing the math.

    Below is a quote by dc42 in the other thread I linked too. Can anyone elaborate?

    • Having the arms go vertical or even beyond when printing close to a tower isn't a problem. What you need to avoid is arms going below about 20 degrees to the horizontal

    Thanks
    Cory



  • i got similarly whacked results when my frame wasn't as straight as humanly possible (i.e. calibration aids suggested absurd rod lengths). After rebuilding the whole thing I mounted a dial indicator instead of nozzle and manually adjusted the delta radius until it was flat.

    if i recall correctly if the center of the bed is low you increase the delta radius (or smooth rod offset or whatever its called in the various firmware). I think it will vary with bedsize but a factor of 4 gets you close quite fast. I.e. your center is 1mm low, add 4 to the radius; split the difference when you overshoot. (or if i'm mistaken, its the other way around, but you'll see)

    after spending days with auto calibration, re-doing the whole thing by hand took an evening, rebuild and all. The wiki highlights the important aspects of the physical build, get that right and the calibration is pretty straight forward by hand.
    https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer



  • Another source of error for me has been not having the belts parallel to the frame, caused by the toothed gears having slipped on the motor spindles. Measure belt-to-frame at each carriage and at the bottom just above the motor spindle, get them the same.



  • @bearer said in Diagonal rod length on delta printer issues.:

    i got similarly whacked results when my frame wasn't as straight as humanly possible (i.e. calibration aids suggested absurd rod lengths). After rebuilding the whole thing I mounted a dial indicator instead of nozzle and manually adjusted the delta radius until it was flat.

    if i recall correctly if the center of the bed is low you increase the delta radius (or smooth rod offset or whatever its called in the various firmware). I think it will vary with bedsize but a factor of 4 gets you close quite fast. I.e. your center is 1mm low, add 4 to the radius; split the difference when you overshoot. (or if i'm mistaken, its the other way around, but you'll see)

    after spending days with auto calibration, re-doing the whole thing by hand took an evening, rebuild and all. The wiki highlights the important aspects of the physical build, get that right and the calibration is pretty straight forward by hand.
    https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer

    I loosened all the bolts and re squared the printer before the last tests. I also checked between the towers with the outside of calipers, really annoyed that I didn't think of that myself. They are within .25mm of being consistent. Didn't have any luck with the way the frame is made getting them any closer, I think one might have a bit of a warp in it.

    Also the subject of changing the radius to get to the head to track center to outwards... This works great, until I get to the area between the towers. Or opposite a tower, however you wish to describe it.

    @robm said in Diagonal rod length on delta printer issues.:

    Another source of error for me has been not having the belts parallel to the frame, caused by the toothed gears having slipped on the motor spindles. Measure belt-to-frame at each carriage and at the bottom just above the motor spindle, get them the same.

    Thanks, I just checked that, no luck there either.

    I'm pretty stumped by this and have to get away from it for a while. Unless anyone else has a better suggestion, I'm planning to decrease the print area size and see if I get better results with the correct arm length.

    Thanks
    Cory



  • Hi,

    My first three printers were mini-deltas kits. I spent hours and hours tweaking them.

    Then I got a Folger Tech FT-5 kit. It worked so much better with so little effort I got rid of the deltas.

    Frederick



  • @fcwilt said in Diagonal rod length on delta printer issues.:

    Hi,

    My first three printers were mini-deltas kits. I spent hours and hours tweaking them.

    Then I got a Folger Tech FT-5 kit. It worked so much better with so little effort I got rid of the deltas.

    Frederick

    Thanks, I guess.

    So after many hours I can not repeat the extremely flat results I had before with the incorrect rod length I posted a video of. I don't know if my attempt to re-square the printer made things worse, or if I was able to compensate better by feel to set the tilt. I get slightly better results with the incorrect rod length than I do with the correct number.

    I rigged up a probe and have ran many tests. Much easier to do, but harder to feel for what is happening than using an indicator.

    I am still of the mindset that if you do the math right with the wrong numbers it is impossible to get the results in the video of my first post. Would be nice to have access to the actual step data, or actual axis position data. Something doesn't add up.

    Cory



  • Correct rod length 291.06
    2_1559950825174_Screenshot_20190607_193736.png

    294.9 rod length
    1_1559950825173_Screenshot_20190607_165629.png

    Messing with the tilt some more.
    0_1559950825173_Screenshot_20190607_084354.png

    Unlike in the video I have a bad high spot by the Y tower no matter what I do. But the regardless more of the bed would be usable.

    Going to try and forget about this for a couple weeks while I'm on vacation
    Cory


  • administrators

    Do the rods bend at all as the effector moves? If so then that will change the effective length of the rods, affecting the geometry.

    I am suspicious of rods with springs between them, because the stretch of the springs, the force they apply to the rods and the direction of that force will depend on the XY position of the effector.