one Z stepper getting very hot, other fine?



  • just turned it on, not printing

    PMM913
    Motor current % of normal - X:100, Y:100, Z:100, E:100

    PMM906
    Motor current (mA) - X:600, Y:600, Z:750, E:1600, idle factor 30%

    started printing, numbers are all the same

    I'm clutching at straws... but is there a chance one stepper isn't dropping back to idle power levels when it's supposed to?



  • @veti said in one Z stepper getting very hot, other fine?:

    @alanknight said in one Z stepper getting very hot, other fine?:

    M584 X0 Y1 Z2:3 E4.5

    E4.5 is wrong you want E4:5

    my bad, I read that wrong, M584 is for z axis only, fixed it, I'll let it cool and set it printing again

    thanks guys 🙂



  • printing now again... it's hot as hell again 😞



  • Does anything show in M122?

    I see you're running a pretty old firmware version. I don't think there were any bugs like this, but you never know. You could try upgrading to 2.02 and seeing if it makes any difference.

    Just to clarify, you fixed the error Veti pointed out, does M906 and M913 report both Z motors now? Just want to verify that your extruder is the one getting 1600 and not the second Z motor.



  • M112 runs an emergency stop?

    M913
    Motor current % of normal - X:100, Y:100, Z:100, E: 100:100

    M906
    Motor current (mA) - X:600, Y:600, Z:750, E:1600:1600, idle factor 30%

    are my extruder and Z axis somehow mixed up? the printer prints fine, just that one z motor getting hot

    (I added a space after E: to avoid the smilie)



  • M112 is emergency stop.

    M122 is diagnostic report.

    Painfully close, I know.



  • sorry my bad

    M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (11 max)
    === Platform ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 1.21 running on Duet WiFi 1.02 or later
    Board ID: 08DGM-956GU-DJMSN-6J9F4-3SD6Q-1VRRG
    Static ram used: 16152
    Dynamic ram used: 100408
    Recycled dynamic ram: 2224
    Stack ram used: 1224 current, 4512 maximum
    Never used ram: 7776
    Last reset 00:14:34 ago, cause: software
    Last software reset at 2019-05-02 22:53, reason: User, spinning module GCodes, available RAM 7776 bytes (slot 0)
    Software reset code 0x0003 HFSR 0x00000000, CFSR 0x00000000, ICSR 0x0441f000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 34.5, current 35.7, max 35.9
    Supply voltage: min 12.3, current 12.7, max 13.1, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2019-05-02 23:08:15
    Slowest main loop (seconds): 0.014124; fastest: 0.000046
    === Move ===
    MaxReps: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.21RC4(08b3)
      WiFi MAC address 5c:cf:7f:76:61:21
      WiFi Vcc 3.31, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 17336
      WiFi IP address 192.168.1.239
      WiFi signal strength -50dBm, reconnections 0, sleep mode modem
      Socket states: 2 0 0 0 0 0 0 0
      === Expansion ===

    should I updates? - do I lose my settings if I do?

    it used to print fine... so I'm assuming I accidentally broke something, but I'm lost



  • updated

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.22
    Web Interface Version: 1.22.6

    I've added a fan to that stepper for tonight, printer is at work, it's 11.30pm, i need to go home! butr also need some things printing asap so I'll leave it going with then fan 🙂

    I'll check back tomorrow, thanks for the help

    Alan 🙂

    EDIT: ran these again before I go

    11:28:37 PMM906
    Motor current (mA) - X:600, Y:600, Z:750, E:1600:0, idle factor 30%
    11:28:30 PMM913
    Motor current % of normal - X:100, Y:100, Z:100, E💯100

    that stepper is still heating up, not sure if it's relevant but it's the one plugged into the driver, not the one plugged into the standard driver

    EDIT3: 40mm fan is screaming but stepper is getting hotter than I expected... I'll hut the printer down, don't want it to overheat while I'm gone



  • @alanknight said in one Z stepper getting very hot, other fine?:

    ; Motor remapping for dual Z
    M584 X0 Y1 Z2:3 E4.5

    So I think this was the root of your problem as Veti pointed out. Part of the problem was the period instead of colon, but there's more to it that just that. The command must come earlier in config.g than where you have it.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M584_Set_drive_mapping

    Order dependence

    M584 must come earlier in config.g than any M350 and M906 commands. If it creates new axes, it must also be earlier than any M92, M201, M203, M208, M350, M566, M574 , M667 and M669 commands.
    Example

    M584 X0 Y1 Z2:3 E4:5:6 ; Driver 0 controls the X motor, 1 controls Y, 2 and 3 control Z motors, 4 5 and 6 control E motors
    VERY IMPORTANT! Assigning a drive using M584 does not remove its old assignment. Therefore, if you assign a drive that defaults to being an extruder drive, you should also assign the extruder drives explicitly as in the above example. Failure to do so may result in unexpected behaviour.

    You need to move your M584 command up above the M350 command. Sorry. I should have caught that sooner.



  • no need to say sorry, you're doing me a favour spending your time helping me, I owe you one 🙂

    edited config file to this...

    M569 P0 S0 ; X Drive 0 goes backwards
    M569 P1 S0 ; Y Drive 1 goes backwards
    M569 P2 S1 ; Z1 Drive 2 goes forwards
    M569 P3 S1 ; Z2 Drive 3 goes forwards
    M569 P4 S0 ; extr Drive 4 goes backwards

    M584 X0 Y1 Z2:3 E4:5 ; Motor remapping for dual Z

    M350 X16 Y16 Z16:16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z2555:2555 E93 ; Set steps per mm
    M566 X900 Y900 Z6:6 E500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z90:90 E3000 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z50:50 E500 ; Set accelerations (mm/s^2)
    M906 X600 Y600 Z750:750 E1600 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X200 Y180 Z200 S0

    and

    AMM906 Motor current (mA) - X:600, Y:600, Z:750, E:1600:1600, idle factor 30%
    AMM913 Motor current % of normal - X:100, Y:100, Z:100, E💯100

    I'll give it a go

    thanks for all the help

    🙂

    EDIT: it's about an hour into a print, all steppers nice and cool, thanks again for the help 🙂



  • Glad that's sorted out.


  • administrators

    What was happening is that when the M906 command was executed, the motor connected to E1 output was configured as an extruder, so it got 1600mA. That's why we say that M584 must come before M906. Similarly for M350.



  • no more hot motors... but I think I've messed something else up, the auto bed leveling doesn't work anymore (or maybe updating firmware broke something?)

    to be fair, I was still fine tuning it, I think my bed has sagged a little in the middle, I'm using a buildtac bed (the magnetic one you can lift the tray off) which might throw it off a little too

    when I try to run auto bed leveling, or mesh grid leveling the Z comes down, hits the bed and doesn't stop till the motors stall

    it doesn't move X/Y at all, here's my config file

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed Jun 13 2018 17:00:33 GMT+0100 (British Summer Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PMy printer ; Set machine name
    M552 S1 ; Enable network
    M587 S"tripe" P"m580umuu" I192.168.1.89 J192.168.1.254 K255.255.255.0 ; Configure access point and IP addresses. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives

    ; Define Drives
    ; Physical Drive connection

    M569 P0 S0 ; X Drive 0 goes backwards
    M569 P1 S0 ; Y Drive 1 goes backwards
    M569 P2 S1 ; Z1 Drive 2 goes forwards
    M569 P3 S1 ; Z2 Drive 3 goes forwards
    M569 P4 S0 ; extr Drive 4 goes backwards

    M584 X0 Y1 Z2:3 E4:5 ; Motor remapping for dual Z

    M350 X16 Y16 Z16:16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z2555:2555 E93 ; Set steps per mm
    M566 X900 Y900 Z6:6 E500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z90:90 E3000 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z50:50 E500 ; Set accelerations (mm/s^2)
    M906 X600 Y600 Z750:750 E1600 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X200 Y200 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low endstops

    ;Z-Probe
    M558 P1 H5 F120 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P400 X40 Y0 Z-4 ; Set Z probe trigger value, offset and trigger height
    M557 X40:160 Y40:160 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S320 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.85 I0 F500 H1 T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S0.5 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0.5 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured


    and bed.g

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed Jun 13 2018 17:00:32 GMT+0100 (British Summer Time)

    M561 ; clear any bed transform
    ; Probe the bed at 5 points
    G30 P0 X30 Y30 H0 Z-99999
    G30 P1 X30 Y185 H0 Z-99999
    G30 P2 X185 Y185 H0 Z-99999
    G30 P3 X185 Y30 H0 Z-99999
    G30 P4 X100 Y100 H0 Z-99999 S


    I'm looking again and again, googling etc. but can't figure it out

    sorry to keep pestering you guys with questions!

    Alan 😮


  • administrators

    @alanknight said in one Z stepper getting very hot, other fine?:

    M558 P1 H5 F120 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P400 X40 Y0 Z-4 ; Set Z probe trigger value, offset and trigger height

    What type of Z probe are you using? The Z-4 parameter in your G31 line says that it triggers when the nozzle is 4mm below the bed, which surely isn't right. See https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe to calibrate the trigger height.



  • IR probe, from the duet3d website

    I'll swap that -4 to a 4, that's probably my mistake!

    I fell on my head 3 years ago, left me with a bit of brain damage, I make silly mistakes like that and then can't see them no matter how much I look

    thanks again for the help, it's printing right now, I'll give it a try when it's finished

    Alan 🙂

    EDIT: it's still printing, watching it print the z probe reads 535 when it's over what it's printing

    I'm thinking that must be the perfect height? - it's reading the high of the last layer it's printing ontop of.... so I can set the z trigger to 535 and z height above nozzle to 0 ?

    EDIT: it's not just a Z problem, X moves too far left and crashes into the end stop too... it ignores the end stop and tires to power through



  • I fixed it...I had z probe offset at 40 when it should have been -40

    had to add some Y offset too

    thanks

    Alan 🙂


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.