FAN0 not working, but the rest work just fine



  • Hi all!

    I'm having problems using the first fan port on my Duet 2 Ethernet.

    Here is my config.g:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Apr 28 2019 11:22:38 GMT+0200 (CEST)
    
    ; General preferences
    G90                                      ; Send absolute coordinates...
    M83                                      ; ...but relative extruder moves
    
    ; Network
    M550 P"Mickes Dunet A6"                  ; Set machine name
    M552 S1                                  ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1                               ; Enable HTTP
    M586 P1 S0                               ; Disable FTP
    M586 P2 S1                               ; Enable Telnet
    
    ; Drives
    M569 P0 S1                               ; Drive 0 goes forwards
    M569 P1 S1                               ; Drive 1 goes forwards
    M569 P2 S0                               ; Drive 2 goes backwards
    M569 P3 S1                               ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1                  ; Configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E100.00      ; Set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00      ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E6000.00  ; Set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X500.00 Y500.00 Z500.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                  ; Set idle timeout
    
    ; Axis Limits
    M208 X-4 Y-14 Z0 S1                      ; Set axis minima
    M208 X210 Y217 Z200 S0                   ; Set axis maxima
    
    ; Endstops
    M574 X1 Y1 Z1 S0                         ; Set active low and disabled endstops
    
    ; Z-Probe
    M558 P0 H5 F120 T6000                    ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X20:200 Y20:200 S40                 ; Define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                         ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S130                             ; Set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S235                             ; Set temperature limit for heater 1 to 235C
    
    ; Fans
    M106 P0 S1 I0 F500 H-1                   ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1                            ; Define tool 0
    G10 P0 X0 Y0 Z0                          ; Set tool 0 axis offsets
    G10 P0 R0 S0                             ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic saving after power loss is not enabled
    
    ; Custom settings are not configured
    
    ; Load overrides
    M501
    
    ; Miscellaneous
    T0                                       ; Select first tool
    
    

    My config-override.g only has heating profiles.

    What am I missing? Is the board broken?

    My current workaround is to use FAN2 instead, and map it in the tool 0 definition;
    M563 P0 D0 H1 F2
    This works fine, but I'd rather connect 12V led rails on FAN2.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.