Need help to config 2-Z Motors and Mesh bed compensation



  • Hi

    i hope you can help me i trying to work 2-Z Motors and Mesh bed compensation. I got strange results from 2-Z Motors and Mesh bed compensation.

    I use the Piezo Orion on my E3D V6
    Cartesian 220x220

    my config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Apr 11 2019 17:51:12 GMT+0200 (Mitteleuropäische Sommerzeit)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"AM8" ; Set machine name
    M552 S1 ; Enable network
    M587 S"WLAN-" P"519647189" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards X
    M569 P1 S0 ; Drive 1 goes forwards Y
    M569 P2 S1 ; Drive 2 goes backwards Z
    M569 P3 S1 ; Drive 3 goes forwards Extruder
    M569 P4 S1 ; Drive 4 2nd Z-motor - Normally used as Extruder 1

    ; Motor Remapping
    M584 X0 Y1 Z2:4 E3 ; two Z motors connected to driver outputs Z and E1

    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    ;M92 X100.00 Y100.00 Z400.00 E101.01 ; Set steps per mm
    M92 X100.00 Y100.00 Z400.00 E100.00 ; Set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E6000.00 ; Set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X500.00 Y500.00 Z500.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M906 X1400.00 Y1400.00 Z1400.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    ;M671 X-15:205:205 Y105:205:15 P2.5 ; für manual bed levelling
    M671 X-20:220 Y0:0 S5.5 ; leadscrews at left and right of X axis für 2 motoren
    M208 X-33 Y-10 Z0 S1 ; Set axis minima
    M208 X220 Y210 Z200 S0 ; Set axis maxima
    ;M208 X-33:220 Y-10:210 ; X carriage moves from -5 to 205, Y bed goes from 0 to 200

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P5 I1 R0.5 H5 F350 ; Set Z probe type to effector and the dive height + speeds
    G31 P500 X0 Y0 Z-0.1 ; Set Z probe trigger value, offset and trigger height
    M557 X10:210 Y10:210 S40 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S130 ; Set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S275 ; Set temperature limit for heater 1 to 275C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool

    and my bed.g

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Mon Apr 29 2019 10:01:00 GMT+0200 (Mitteleuropäische Sommerzeit)
    M561 ; clear any bed transform
    ;G29 ; probe the bed and enable compensation

    G28 ; home
    M401 ; deploy Z probe (omit if using bltouch)
    G30 P0 X10 Y110 Z-99999 ; probe near a leadscrew, half way along Y axis
    G30 P1 X210 Y110 Z-99999 S2 ; probe near a leadscrew and calibrate 2 motors
    M402 ; retract probe (omit if using bltouch)
    G29 ; probe the bed and enable compensation

    0_1557300166001_Mesh bed compensation.jpg

    I hope i got some advise whats going wrong

    Thanks a lot



  • have you ruled out a mechanical issue?

    after you have done the leveling when you move the head to that position is the head far of the bed?



  • @veti said in Need help to config 2-Z Motors and Mesh bed compensation:

    have you ruled out a mechanical issue?
    after you have done the leveling when you move the head to that position is the head far of the bed?

    yes i ruled out the mechanical issues
    i changed the stepper motors the and the Bed and the lead-screws
    after this changes i have made Manual Bed Levelling to make Bed Flat.

    after Mesh the head stays on the last probe point



  • You've definitely got some bad probe points in that mesh. Is the bed less stable on that side? Does it bend down more?



  • Hi

    No it does not bend more.
    The nozzle with piezo orion touch the bed and go up.

    But you see The bed is not flat
    Is the config.g and bed.g ok ?



  • I think you have your Z max speed set too low. The piezo probe needs a higher speed in order to register a solid contact.

    In your M558 for probe setup you have it set to F350, but in your M203 for Z max speed you are limiting it to Z180.

    So change M203 Z400 and try again.



  • thanks Phaedrus

    it seems a lot better but not perfect right ?
    what i can do to make it perfect ?

    sorry my english is bad 😉
    0_1557773167067_Mesh.jpg

    RepRapFirmware height map file v2 generated at 2019-05-13 20:44, mean error 0.018, deviation 0.057
    xmin,xmax,ymin,ymax,radius,xspacing,yspacing,xnum,ynum
    10.00,210.00,10.00,210.00,-1.00,40.00,40.00,6,6
    -0.002, -0.057, -0.090, -0.090, -0.077, -0.023
    0.028, -0.002, -0.047, -0.015, -0.053, -0.023
    0.010, -0.015, -0.038, -0.027, -0.002, 0.005
    0.060, 0.055, 0.045, 0.032, 0.048, 0.050
    0.135, 0.087, 0.068, 0.055, 0.065, 0.110
    0.142, 0.058, 0.045, 0.010, 0.028, 0.065

    this is my config.g what i have now

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Apr 11 2019 17:51:12 GMT+0200 (Mitteleuropäische Sommerzeit)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"AM8" ; Set machine name
    M552 S1 ; Enable network
    M587 S"WLAN-" P"390696406*****" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards X
    M569 P1 S0 ; Drive 1 goes forwards Y
    M569 P2 S1 ; Drive 2 goes backwards Z
    M569 P3 S1 ; Drive 3 goes forwards Extruder
    M569 P4 S1 ; Drive 4 2nd Z-motor - Normally used as Extruder 1

    ; Motor Remapping
    M584 X0 Y1 Z2:4 E3 ; two Z motors connected to driver outputs Z and E1

    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    ;M92 X100.00 Y100.00 Z400.00 E101.01 ; Set steps per mm
    M92 X100.00 Y100.00 Z400.00 E100.00 ; Set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z400.00 E6000.00 ; Set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X1400.00 Y1400.00 Z1400.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    ;M671 X-15:205:205 Y105:205:15 P0.5 ; für manual bed levelling
    M671 X-33:220 Y0:0 S5.5 ; leadscrews at left and right of X axis für 2 motoren
    ;M208 X-33 Y-10 Z0 S1 ; Set axis minima
    M208 X220 Y210 Z200 S0 ; Set axis maxima
    M208 X-33:210 Y-10:210 ; X carriage moves from -5 to 205, Y bed goes from 0 to 200

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    ;M558 P5 I1 R0.4 F300 ; Set Z probe type to effector and the dive height + speeds
    ;M558 P5 I1 R0.4 F300 X0 Y0 Z0
    M558 P5 I1 R0.4 F300 X0 Y0 Z0
    ;M558 P8 I1 R0.6 F300 Z1
    G31 X0 Y0 Z-0.1 P100 ; Set Z probe trigger value, offset and trigger height
    M557 X10:210 Y10:210 S40 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S130 ; Set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S275 ; Set temperature limit for heater 1 to 275C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool



  • I think it is probing perfectly. The heightmap doesn't look too bad. It does look like it's tilted a little lower in the front and higher in the back. You could try mechanically leveling it again to address that, or you could just let mesh compensation do it's thing and correct for the tilt.

    You can use am STL like this to test if things are working correctly.

    0_1557775133875_bedlevel_nozzle_0.4_200x200-0.3-0.8.stl

    If you print it twice, once with mesh enabled, and once with mesh disabled, you can see if it's working as intended.



  • Perfect i will Print tommorow

    And let you know

    Thanks


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.