BLTouch probe not deploying on Home



  • I am sorry as this question has been asked a bunch but I went through the archives and I still haven't figured this out. When I power up, the BLTouch does its self test (two clicks, then turns red). I can home the X and Y, but when I home Z, the BLT doesn't deploy so the print head wants to bury into the bed.

    Here are the relevant sections of my config.g file:

    ; ############################
    ; DRIVES AND LIMITS
    ; ############################
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z400 E95 ; Set steps per mm
    M566 X600 Y600 Z24 E300 ; Set maximum instantaneous speed changes (mm/min) was 1200 you changed it to 600
    M203 X30000 Y30000 Z300 E1500 ; Set maximum speeds (mm/min)
    M201 X300 Y300 Z100 E5000 ; Set accelerations (mm/s^2) was 500 you changed it to 300 for stall guard
    M906 X500 Y500 Z500 E500 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S300 ; Set idle timeout
    M208 X-5 Y-15 Z0 S1 ; Set axis minima M208 X-5.5 Y-10 Z0 S1
    M208 X258.5 Y246 Z260 S0 ; Set axis maxima

    ; ############################
    ; ENDSTOPS AND ZPROBE
    ; ############################

    M574 X1 Y1 S1 ; Set active high endstops
    M574 Z1 S2
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M307 H4 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H2.5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X-45 Y-18 Z2.69 ; Set Z probe trigger value, offset and trigger height
    M557 X5:205 Y5:205 S65 ; Define mesh grid M557 X20:215 Y20:215 S65
    M376 H10 ; Taper off compensation over 10mm of height

    Thanks in advance for any help!
    Pat



  • see
    https://duet3d.dozuki.com/Wiki/BLTouch_Troubleshooting
    go through the list step by step


  • administrators

    @bearcattd said in BLTouch probe not deploying on Home:

    M574 Z1 S2

    This line is wrong, it should be Z0 and no S parameter (because it is irrelevant with Z0). I suspect that your homez.g and homeall.g files are wrong. See https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_Z_using_a_Z_probe.



  • @bearcattd said in BLTouch probe not deploying on Home:

    M558 P9 H2.5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X-45 Y-18 Z2.69 ; Set Z probe trigger value, offset and trigger height

    It would appear that your trigger height is higher than your dive height.? I'm not sure what kind of behaviour that would produce if any. Try changing M558 H2.5 to M558 H5.

    Without seeing your homing files it's hard to say what's going on.

    @dc42 said in BLTouch probe not deploying on Home:

    M574 Z1 S2

    This line is wrong, it should be Z0 and no S parameter

    I think the configurator generates this.

    ; Endstops
    M574 X1 Y1 S1                            ; Set active high endstops
    
    ; Z-Probe
    M574 Z1 S2                               ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1                      ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000                    ; Set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z2.5                      ; Set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20                 ; Define mesh grid
    

    Just checked, and this is what the BLTouch choice generates.


  • administrators

    Thanks, I'll have the configurator fixed. What is in your homez.g and homeall.g?



  • @dc42 said in BLTouch probe not deploying on Home:

    Thanks, I'll have the configurator fixed. What is in your homez.g and homeall.g?

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Jun 01 2019 07:50:39 GMT-0600 (Central Standard Time)
    G91                     ; relative positioning
    G1 Z5 F6000 S2          ; lift Z relative to current position
    G1 S1 X-235 Y-215 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000          ; go back a few mm
    G1 S1 X-235 Y-215 F360  ; move slowly to X and Y axis endstops once more (second pass)
    G90                     ; absolute positioning
    G1 X15 Y15 F6000        ; go to first bed probe point and home Z
    G30                     ; home Z by probing the bed
    
    ; Uncomment the following lines to lift Z after probing
    ;G91                    ; relative positioning
    ;G1 S2 Z5 F100          ; lift Z relative to current position
    ;G90                    ; absolute positioning
    

    That's the default from the configurator for BLTouch.

    I've always used M574 Z1 S2 with the BLTouch and it has worked.
    Based on the gcode wiki description it sounds correct? "S2=z probe"
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M574_Set_endstop_configuration



  • Thanks for all of the advice (as usual)! This forum is an invaluable asset to the Duet and greater 3D printing communities!

    Pat



  • @BearcatTD So it works now? What needed to change?


Log in to reply