Machine "pausing" between perimeters or layer changes



  • Hello, i have a tevo tornado and i am using the duet 2 wifi. I used the config and only modified m566 e to 400 from 120 after seeing many post saying its due to low jerk settings. i do know know anything about jerk so i dont know if 400 is still low on a bowden system.
    i am using s3d and the same exact profile from before but i have checked to use relative extrusion distances based on another similar thread. i am using 100mm/s print speed, averaging around 60.

    this hesitation is causing big blobs on my prints and im not sure if the jerk increase in only the e helped or if it was too small of an increase to notice

    here is my gcode
    https://www.dropbox.com/s/ae0kchyrwwporxk/gcocd.txt?dl=0

    0_1560827432078_config.g



  • Your settings are very conservative. The pausing you see is likely a result of that as it takes time for the filament to retract and Z axis to move when they are moving so slowly. I try to keep the extruder as responsive as possible, this is a bit more difficult with a bowden tube, but it's not impossible.

    M566 X900 Y900 Z12 E400 ; Set maximum instantaneous speed changes (mm/min)

    X and Y jerk look fine. Z jerk is probably a bit low. Try 60. E jerk is also maybe a bit low, especially if you're using pressure advance. Try 1000-2000. Having it set much lower than the X and Y jerk can cause some issues where the lower of the jerk values is applied. That may explain part of the pausing issues.

    M203 X6000 Y6000 Z6000 E1200 ; Set maximum speeds (mm/min)

    Your max speeds for X and Y are capped at 100mm/s so if you're trying to travel faster than that, you won't be able to. You should set the X and Y max speed to a little above what you want your travels speed to be, that way if you use the speed factor slider to increase the print speed, it won't cause your travel speed to exceed the safe torque limit. Maybe 100mm/s is that limit for your printer, and that's fine.

    Your max speed for the extruder is quite low. That would cap your retraction speed to 20mm/s which could lead to very long retraction pauses depending on how much you are retracting, which looking at the S3D settings in your gcode file is 6.5mm. And it looks like S3D is trying to retract at 85mm/s but it can't because you've capped it at 20. I would set the limit quite a bit higher and use the slicer or firmware retraction to set your retraction speed limit.

    M201 X200 Y200 Z100 E250 ; Set accelerations (mm/s^2)

    Your acceleration values are very conservative, and would definitely contribute to the appearance of pausing as the low jerk values require a slow down to a minimum speed, and then the slow acceleration takes a while to get back up again. Maybe try 500 on X and Y, and maybe 400 on Z, and maybe 3000-4000 or more on E.

    It would help to know a bit more about your printer setup.
    What is the extruder?
    Is it geared?
    What is the motor?
    How long is the bowden tube?

    If you haven't tried using pressure advance yet, it may also help quite a bit. It looks like you have wipe and coasting enabled in Simplify. You should turn these off and try pressure advance instead. It will attempt to reduce the pressure in the hotend at the end of a move, so that you won't require as much retraction, this in turn speeds up the transitions between print and travel moves.

    https://duet3d.dozuki.com/Wiki/Pressure_advance



  • Phaedrux, thanks for the reply! I made all the changes you've mentioned besides pressure advance as im saving that for a bit later. I have a tevo tornado with a geared extruder. My bowden tube is around 400mm. I am testing a print right now and my extruder is flying! might have to turn acceleration down on that lol


Log in to reply