Bed autolevel and mesh compensation



  • It is still not clear for me after reading most of the wiki is my way of doing right or not.
    Please take a look.

    I'm running corexy with double Z motors drivers (Z + E1).

    before printing i'm doing:

    • autolevel Z using two endstops
    • calibrate screw using two points with G30 command using bltouch as Z probe
    • enable mesh by G29 S1

    calibration script:

    G29 S2 ; disable mesh compensation

    G90
    G1 Z1 F6000
    G1 X35 Y200 F9000
    M401 ; deploy Z probe (omit if using bltouch)
    G30 P0 X5 Y200 Z-99999 ; probe near a leadscrew, half way along Y axis
    M402
    G1 X400 F9000
    M401
    G30 P1 X370 Y200 Z-99999 S2 ; probe near a leadscrew and calibrate 2 motors
    M402 ; retract probe (omit if using bltouch)

    G29 S1 ; enable mesh compensation



  • The problem I see is that if I do a paper check on nozzle I do see difference above 0.1mm across the bed
    My assumption that mesh have to fix this but it is not



  • At some point you need to re-establish the Z0 point, so perhaps after the leveling of the lead screws you need to add a single G30 probe at the center of the bed before you load the heightmap.



  • Do you mean this command?

    G30 S-2



  • No, I mean just a regular G30.

    @axillent said in Bed autolevel and mesh compensation:

    calibration script:
    G29 S2 ; disable mesh compensation
    G90
    G1 Z1 F6000
    G1 X35 Y200 F9000
    M401 ; deploy Z probe (omit if using bltouch)
    G30 P0 X5 Y200 Z-99999 ; probe near a leadscrew, half way along Y axis
    M402
    G1 X400 F9000
    M401
    G30 P1 X370 Y200 Z-99999 S2 ; probe near a leadscrew and calibrate 2 motors
    M402 ; retract probe (omit if using bltouch)
    G30
    G29 S1 ; enable mesh compensation



  • It would also maybe help to see how you are homing. Can you post your homeall and homez? And perhaps your config.g for good measure?



  • I see, thanks. Will try



  • it is still something is wrong

    why Z is changing if just after homing I run G29 S1?
    I do have G29 S1 in my homing script

    G29 S2 ; disable mesh compensation

    G90
    G1 Z1 F6000
    G1 X35 Y200 F9000
    G30 P0 X5 Y200 Z-99999 ; probe near a leadscrew, half way along Y axis
    G1 X400 F9000
    G30 P1 X370 Y200 Z-99999 S2 ; probe near a leadscrew and calibrate 2 motors

    G1 X205 Y200 Z5 F9000
    G30

    G29 S1 ; enable mesh compensation



  • @axillent said in Bed autolevel and mesh compensation:

    why Z is changing if just after homing I run G29 S1?

    Can you explain what you mean by Z changing?


Log in to reply