Duet 2 wifi printing at 4mm/s '"PLEASE HELP'"



  • This sounds like such a ridiculous problem but I've finally got everything wired and dialed in but printer only prints at 4mm/s.

    Im yousing cura to slice says it will take 10min for test print to print it. sent it to web interface and send to printer and it only prints extremaley slow. and duet web interface says it will take 2 hours and under Machine Status-Speeds-RequestedSpeed-4mm/s & TopSpeed 4mm/s.

    Under Settings-Machine Properties- X/Y configuration is as follows
    Maximum InstantDv Max Speed Acceleration Motor Current
    310 mm 90 mm/s 150 mm/s 3310 mm/s² 1300 mA

    I've tried different models same problem. non print moves are quick and quieter than old driver board. Last night did a firmware upgrade of serveral updates and had no problems at all but problem persists.
    reset & turned on and off dozens of times. nothing works

    any ideas would be greatly apperciated i dont want to go back to old board.



  • @thejs

    did you change the g code flavor from marlin to reprap in cura?



  • No i haven't i will try changing that know !



  • That fixed it immediately but i dont know if i picked the right setting options.

    I added new printer in Cura-Under Machine Settings-GCodeFlavor- I chose RepRapVolumetric out of these options.

    • RepRap(Marlin/Sprinter)
    • RepRap(Volumetric)
    • Ultimaker
    • Griffin
    • Makerbot
    • BitsfromBytes
    • Mach3
    • Repitier
      Start and End GCode boxes i left alone.

    the problem im having now is it goes straight to printing before bed and extruder are up to temp. and extruder doesnt even move. in Duet web interface it says : Attempting to extrude with no tool selected over and over again.

    Thank You so much for your help I would have never thought of that !



  • @thejs said in Duet 2 wifi printing at 4mm/s '"PLEASE HELP'":

    in Duet web interface it says : Attempting to extrude with no tool selected over and over again.

    You are missing the default tool selection in your config.

    try adding this to your config.g

    ; Miscellaneous
    T0 ; Select first tool

    i am not sure that volumetric extrusion is what you want.



  • @thejs said in Duet 2 wifi printing at 4mm/s '"PLEASE HELP'":

    I added new printer in Cura-Under Machine Settings-GCodeFlavor- I chose RepRapVolumetric out of these options.

    • RepRap(Marlin/Sprinter)
    • RepRap(Volumetric)
    • Ultimaker
    • Griffin
    • Makerbot
    • BitsfromBytes
    • Mach3
    • Repitier

    That looks like your Cura version is a bit outdated because newer versions (at least the current 4.2) have a clear distinction between RepRap and Marlin. And if you select RepRap(Volumetric) then you also have to enable volumetric extrusion in RRF via M200.

    Still this won't solve your heating issues. But as @Veti said check if you have a tool selected. If that still does not help please post the contents of your config.g.