Corexy Z offset



  • Hi everyone I am running a corexy with installed a BL Touch probe. The main problem is that I can't adjust the z offset to get the correct z height for printing. Whenever I start printing, the head prints about 3mm above the table in the air, I don't have much experience, I'm just starting, so please help me with that issue.





  • I made already everything, here is my config:

    [code]homez.g
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G90 ;abosulte positioning
    G1 X200mm Y173mm F3000 ;safe home position
    G30 ; Do a single probe to home our Z axis
    G90 ; Make sure we are in absolute mode
    G1 Z10 F6000 ; Rapidly move the Z axis to Z=10.[/code]

    [code]; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Aug 03 2019 03:22:53 GMT+0100 (Brytyjski czas letni)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X205 Y205 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 S1 X205 ; home X axis
    G1 S1 Y205 ; home Y axis[/code]

    [code]; config-override.g file generated in response to M500 at 2019-08-07 19:44
    ; This is a system-generated file - do not edit
    ; Heater model parameters
    M307 H0 A90.0 C700.0 D10.0 S1.00 V0.0 B1
    M307 H1 A548.0 C162.5 D3.6 S1.00 V23.6 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H3 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    G10 L2 P1 X0.00 Y0.00 Z0.00
    G10 L2 P2 X0.00 Y0.00 Z0.00
    G10 L2 P3 X0.00 Y0.00 Z0.00
    G10 L2 P4 X0.00 Y0.00 Z0.00
    G10 L2 P5 X0.00 Y0.00 Z0.00
    G10 L2 P6 X0.00 Y0.00 Z0.00
    G10 L2 P7 X0.00 Y0.00 Z0.00
    G10 L2 P8 X0.00 Y0.00 Z0.00
    G10 L2 P9 X0.00 Y0.00 Z0.00[/code]

    [code]; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Aug 03 2019 03:22:52 GMT+0100 (Brytyjski czas letni)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"My Printer" ; Set machine name
    M552 S1 ; Enable network
    M587 S"ASUS" P"r2" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Physical drive 0 goes backwards
    M569 P1 S0 ; Physical drive 1 goes backwards
    M569 P2 S1 ; Physical drive 2 goes forwards
    M569 P3 S0 ; Physical drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E420.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X200 Y200 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X2 Y2 S0 ; X home to min. Y home to max. Normally Open limit switches.
    M574 Z1 S2 ; Define Z to use Probe. Home to Min
    G31 P25 X0 Y-35 Z1.325 ; Z probe trigger value, offset in relation to nozzle. And trigger height adjustment
    M557 X5:205 Y5:165 S20 ; Define mesh grid

    ; Z-Probe
    M558 P5 H5 F500 T4000 X0 Y0 Z1 ; Set Z probe type/mode 5. H=Dive Height. F=Speed the bed moves

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T613400 B5025 C1.484206e-7 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; BLTouch - Heaters
    M307 H7 A-1 C-1 D-1 ; Disable the 7th Heater to free up PWM channel 5 on the Duex board.

    ; Fans
    M106 P0 S0 I0 F500 H T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured [/code]



  • @chris11 said in Corexy Z offset:

    1.325

    how did you arrive at this offset





  • when you did the calibration. did you verify that the printhead was on the bed when you moved to z=0?



  • Yes when the printhead touched bed I put G92 Z0 and then G1 Z10 and G30 S-1 and I got z offset



  • And I used the code M564 S0 to disable axis limits and that it



  • no one can help me? I found a couple of posts on the forum with the same problem but none of the solutions listed there does not work for me.
    Here is an sample https://forum.duet3d.com/topic/3055/having-trouble-setting-the-z-offset
    and here is second https://reprap.org/forum/read.php?416,762755
    and one more https://forums.matterhackers.com/topic/536/solved-z-offset-not-working
    But the main problem is like mine.



  • @chris11 is it possible that not exact BL Tutch alignment to the print nozzle can cause such height differences?



  • i am still waiting for you to verify that after homing (G28) and going to Z=0 (G0 Z0) that the printhead is not 3mm above the bed.



  • @veti said in Corexy Z offset:

    G0 Z0

    but today I set the BLTouch height more precisely. I did the offset measurement again and got a 0.950 result.
    when I move the hotend to the table from the control panel the z axis shows me 0.00
    but 0.5mm is still missing to zero



  • if you cant get a good result with that. increase the offset and do a first layer test print. increase the z offset until it produces a good enough first layer.



  • any value I would not enter has no effect on the distance between the nozzle and the table, 0.5mm to zero is still missing



  • Your M558 contains X0 Y0 Z1.
    Why did you put them there?
    remove them and try again.



  • how are you editing the config.g btw?



  • I removed it, I did again Z offset 0.951
    still on the main panel Z shows 0.00 but the nozzle is 0.5mm above the table



  • @veti said in Corexy Z offset:

    btw

    from the main panel, settings, and save the changes



  • @chris11

    and if you set the offset to 1.4?



  • also check under settings, machine properties, that the z offset is actually set.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.