Duet WiFi configuration with CURA



  • Hello,
    I´ve just finished switching to the Duet WiFi board but I have a problem with Cura. I downloaded the latest version of Cura and installed the Duet plug-in. The configuration seems to be working because Cura automatically got the right print volume, but as soon as I want to upload anything I get an error "There was a network error: 2 Connection closed".
    I´ve configured Cura with the IP of the printer, which is static in the network and I can access the board with my browser without any problem.

    Thank you for any help
    Denis



  • Did you set a password on the Duet, could be why it cannot connect.
    Also check your network settings and confirm you have a default gateway set on both the Duet and PC/Laptop.

    HTH
    P.



  • @paulhew said in Duet WiFi configuration with CURA:

    confirm you have a default gateway set on both the Duet and PC/Laptop.

    actually you only need a default gateway set if things are on different networks. most home networks are a single class c (/24) network which should only need default gateway to route traffic to the internet.

    and if the browser can reach the duet then there shouldnt be any problems routing traffic, however connection closed suggest the duet did accept the connection but unexpecedly closed it. i know the duet has a limited number of sockets available, are there other clients accessing the duet maybe? multible web clients, telnet, ftp etc?



  • @bearer said in Duet WiFi configuration with CURA:

    actually you only need a default gateway set if things are on different networks. most home networks are a single class c (/24) network which should only need default gateway to route traffic to the internet.

    I appreciate what you are saying, but, best practice is to have a DGW set in all cases, especially if using fixed IP and there is a router available, unless you are directly connected, device to device then only the correct IP range and subnet mask is required. (For my sins, networks are my day job).
    Also its a tick in a box so other possibile issues can be examined.

    @bearer is correct in regards to sockets - have you tried rebooting the Duet to clear the sockets and tried to print again?



  • Asking to confirm a unnecessary setting is still adding noise. You could easily rephrase to checking the routing table, remain correct and tick the same box.

    But again, if he can access it through the browser, that already ticked the box..



  • Thank you for your fast help. I just tried to connect with only my laptop with CURA and the error changed "There was a network error: 99 unable to write". At least I know now that CURA is able to connect. I will now look in the suggestions you made and will report back



  • I checked the network-settings in config.h

    This is what it looks like:
    ; Network
    M550 P"My Printer" ; Set machine name
    M552 S1 ; Enable network
    M587 S"WIFI" P"PASSWORD" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    A bit more about my network: I use a dhcp-server to give my clients the ip addresses. To get a static ip I tell my dhcp-server to give the duet always the same address.


  • administrators

    @_nero_ not specific to this issue but you need to remove M587 from config.g - it can cause issue. its designed to setup the network once - that information is then stored in the Duet's flash memory



  • @_nero_ said in Duet WiFi configuration with CURA:

    The configuration seems to be working because Cura automatically got the right print volume, ...

    Are you referring to this plugin? https://github.com/Kriechi/Cura-DuetRRFPlugin
    I'm the author - and the plugin WILL NOT get or set your print volume in Cura.

    Which version of RepRapFirmware is on your DuetWifi?
    Which version of Cura are you using? I think the plugin is not yet compatible with the latest Cura version (at least I didn't test it yet...)



  • @_nero_ said in Duet WiFi configuration with CURA:

    To get a static ip I tell my dhcp-server to give the duet always the same address

    Technically not what we refer to as a static ip, as the client is still reliant on the DHCP server to obtain the address, although it will be the same reserved address each time; static ip means the ip is put directly into the client configuration.



  • @resam
    I will check tomorrow for the firmware version. I used the plugin that is available in the CURA marketplace. I could be that I got the bed dimensions wrong, because my brother tried a few different thing an therefore he did set the dimensions.

    @bearer
    Tomorrow I have some time to set the ip in the config. I found a how to in the wiki.



  • Good news. It was really just the plug-in in combination with the current CURA version. I now went to CURA 4.0 and everything is fine. Thank you for all your help


Log in to reply