BlTouch not triggering/deploying/led not turning on

  • I have had the duet wifi running with the BlTouch for about 3 months now, I recently redid the wiring (for a cable chain) and the probe no longer is working. I bought a genuine Bltouch from their official website. I turn on my Duet wifi and the LED does not light up or self test. I have tested all the wiring with a multi meter, and they all seem to be working. I am running the Bltouch at 5v off the duet 2 wifi. What am I missing? alt text (There is an extention for the wires, From bltouch to duet Brown=Blue, Red=Red, Orange=green)

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ; generated by RepRapFirmware Configuration Tool v2 on Wed Jul 03 2019 20:24:43 GMT-0500 (Central Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"BenchBot" ; Set machine name
    M552 S1 ; Enable network
    M587 S"ATT-HOMEBASE-4847" P"23192130" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Physical drive 0 goes forwards
    M569 P1 S1 ; Physical drive 1 goes forwards
    M569 P2 S1 ; Physical drive 2 goes forwards
    M569 P3 S1 ; Physical drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E96.2 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X150.00 Y300.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X1500.00 Y800.00 Z800.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    M584 X0:4 ; Configure dual X with X and E1

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X720 Y330 Z400 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ;Z probe
    M307 H3 A-1 C-1 D-1
    M558 P9 H5 F100 T2000
    G31 X0 Y0 Z0 P25

    ; Heaters
    M140 H-1 ; Disable heated bed
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S260 ; Set temperature limit for heater 1 to 260C

    ; Fans
    M106 P0 S0 I0 F500 H T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

  • Another user had the same issue just the other day. Turned out to be a break in the cable when it was bent.
    Does the BL do its self test when powered up?
    Is it 'red' solid or 'red flashing' or no lights on it at all?

  • 90% of the time it's a cabling issue.

    If possible, test the BLTouch connected directly to the board with very short cables to verify it's working at all. Triple check that you're connecting to the right pins.

    Config looks ok provided you're connecting to heater pin 3 on the expansion header.

    If it's not lighting up at all that would indicate the power lead is not connected, or the probe itself is dead.

  • @paulhew No lights at all

  • @phaedrux I just tried the shorter cable thing, It still does not turn on or self test.

  • @3dgoat said in BlTouch not triggering/deploying/led not turning on:

    @phaedrux I just tried the shorter cable thing, It still does not turn on or self test.


    Do you have a Duex2 or Duex5 connected to your Duet WiFi?


  • @fcwilt I do not have the duex connected to my controller

  • Please post a picture of the other connector the BL Touch uses, it is by the panel due connector.
    Also check the tiny connector on the back of the BL, as that has caught me out before. Carefully unplug and plug it back in.


Log in to reply