Last touches...



  • tHi,

    i am finishig configure new Duet... al works but extruder motor.

    in fact... extruder sockets are not working, how i know thetse... its a delta:

    1- Conect the towers motors to extruder shockets E0, and E1, (towers motors works in homing procedure).
    2- Heat nozzle until 200 º
    3- Send by DWC extrude.... the motors not move.... the same motors, in axis, that works in homing.

    What i have in config.g

    ; Drives
    M569 P0 S0                                         ; Drive 0 goes forwards
    M569 P1 S1                                         ; Drive 1 goes forwards
    M569 P2 S1                                         ; Drive 2 goes forwards
    M569 P3 S1                                         ; Drive 3 goes forwards
    M350 X256 Y256 Z256 E128 I0                        ; Configure microstepping     without interpolation
    M92 X1280.00 Y1280.00 Z1280.00 E830.00             ; Set steps per mm
    M566 X1000.00 Y1000.00 Z1000.00 E900.00           ; Set maximum instantaneous speed changes (mm/min)
    M203 X10980.00 Y10980.00 Z10980.00 E3600.00        ; Set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00           ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z1000.00 E800.00 I60        ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 
    
    ; Tools
    
    M563 P0 D0 H1					   ; Define tool 0
    G10 P0 S0 R10					   ; Set tool 0 operating and standby temperatures
    

    Ideas?



  • mmm....

    think its a wiring issue.... when i command extrude, feel the estruder stepper motor vibrate a few...

    Edit: Confirmed, wiring issue


  • Moderator

    It's possibly a wiring issue, but the DWC should report if a phase is not connected. Worth checking for continuity, or resistance, on the motor wire pairs in the connector, though.

    I'd tend to be more conservative with motor settings than you, and ramp up the speed once everything was working correctly. I'd start with microstepping set to 16x with interpolation on all axes, rather than 256x. I can't see anything obviously wrong with your other settings; here's mine for comparison (small delta):

    M350 X16 Y16 Z16 E16 I1                     ; Configure microstepping with interpolation
    M92 X87.49 Y87.49 Z87.49 E419.00            ; Set steps per mm (MXL, 18 tooth)
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00    ; Set maximum instantaneous speed changes (mm/min)
    M203 X15000.00 Y15000.00 Z15000.00 E9000.00 ; Set maximum speeds (mm/min)
    M201 X4000.00 Y4000.00 Z4000.00 E4000.00    ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E1200.00 I30   ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                     ; Set idle timeout
    

    Looking at the above, my extruder max speed is set to 9000mm/min, ie 150mm/s, which I'm pretty sure it can't do! Pushing on extrusion it's unlikely to be able to more than 5mm/s. Yours is similar, so make sure you extrude slowly, ie G1 E10 F60 which is 1mm/s.

    Wrote this, saw you fixed it, sent anyway!

    Ian


Log in to reply