Set Custom Home position



  • Hello,

    I am wanting to set a custom home position on my Ender 3. Currently it is set to the lower left corner, but I want to move it close to the center of the print bed. I've tried following a few guides online and I entered some code into the config.g file but it only made things worse. I am also using a BLTouch with offsets of X -41 and Y -5

    I appreciate any help someone had!

    Pat



  • What you really want is home to physically move to touch the switches, and after home to have X0Y0 near the center of the bed. Correct?

    In the web interface, find the place it lets you edit files in /sys and edit homeall.g

    At the end of the existing file, put commands:

    M206 X-xxx and Y-yyy (where xxx and yyy are about 1/2 of your bed)
    G0 X0Y0 (optional; moves the carriage to the new origin).



  • @Danal Thanks!!

    I'll give it a go!



  • If you do this the 'quick and dirty' way, as @Danal suggests, make sure that any commands or macros run after homing are changed to use your new co-ordinate system, eg mesh compensation (M557).

    I set the origin to the centre of the bed on my cartesian machine by using M208 in config.g, but also means that bed.g and homing macros need to change. It may be easier go through the RRF Configurator to generate new files (or, at least, ones you can reference to change your existing files). The two sections you'll need to look at are General > Printer Geometry, and Compensation. The probe offset will stay the same.

    In Printer Geometry, set X min and max, Y min and max to, for example -110, 110, -110, 110. In Compensation, set X min and max, Y min and max to -95, 95, -95, 95. The generated config.g should then have sensible number in it, as will the bed.g and homing macros.

    My config.g (I only have a 200 x 200mm bed):

    ; Axis Limits
    M208 X-106:114 Y-110:118 Z0:180            ; Set axis limits
    
    ; Z-Probe
    M574 Z1 S2                                 ; Set endstops controlled by probe
    M558 P1 H5 F120 T6000                      ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X20 Y0 Z1.25                      ; Set Z probe trigger value, offset and trigger height
    M557 X-85:85 Y-85:85 P5                    ; Define mesh grid
    

    Ian



  • Home is where the endstop switches are. The origin is the 0,0 point. You set the origin location relative to the home position using the M208 commands to define the minimum and maximum values of the axes.

    See: https://drmrehorst.blogspot.com/2018/07/ummd-better-way-to-set-up-origin-and.html


  • administrators



  • @dc42 Thanks!

    I'm trying to figure out where the 8 and 2 came from? Is it where the bltouch lands or the hotend. I'm really visual so I'm trying to determine how this falls on a square. Hopefully this makes sense. Thanks again!



  • @dc42 So if my X offset (printhead to bltouch) is -41 and Y is -5, how would that work into the numbers in the example? Thanks!


  • administrators

    @BearcatTD said in Set Custom Home position:

    @dc42 So if my X offset (printhead to bltouch) is -41 and Y is -5, how would that work into the numbers in the example? Thanks!

    Assuming you haven't set any tool offsets using G10, just put those values in your G31 X and Y parameters. The bltouch offset doesn't affect the M208 settings you use.



  • @dc42 This is off topic a bit, but if anyone is going to know, it's you. When I input the wifi information (with M587 I think), is there a way to put in a username? I'd like to hook in through my universities main wifi. I have the SSID, Password ,but I have to input the username.

    Thanks much!
    Pat



  • @BearcatTD said in Set Custom Home position:

    @dc42 This is off topic a bit, but if anyone is going to know, it's you. When I input the wifi information (with M587 I think), is there a way to put in a username? I'd like to hook in through my universities main wifi. I have the SSID, Password ,but I have to input the username.

    Thanks much!
    Pat

    MUCH better to start a separate thread.

    Nonetheless, short answer: Your university is using enterprise authentication of one sort or another. The WiFi support in the Duet will not connect to that.

    I'd suggest putting the printer in AP (Access Point) mode.

    As an aside, I'd really strongly suggest NOT putting any 3D printer on a University network!!! Even if it could be made to connect, Uni nets are not the safest place in the world for physical devices THAT DO NOT USE ENCRYPTION when they (optionally) take a password.

    And, again, please move these questions into a separate thread. (Start a new topic).



  • And, for the record, the several suggestions above to use M208 are much better than what I proposed.


Log in to reply