New setup after errase and wifi antenna switch



  • Hello,
    i have switch to an external antenna following this guide:

    https://forum.duet3d.com/topic/2825/converting-the-duet-wifi-to-use-an-external-antenna

    after that, i tried to use M997 S1 but the firmware was not found, so i cleaned the sd card and tried to reinstall everything.
    then used bossa to flash the duet, now i can send M115 and get :

    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.03 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2019-06-13b2<LF>ok<LF>

    back, but i can not use M997 S1:

    M997 S0
    M997: Firmware binary "Duet2CombinedFirmware.bin" not found<LF>ok<LF>
    M997 S1
    M997: File DuetWiFiServer.bin not found<LF>ok<LF>

    using M21:

    M21
    M21: No SD card present<LF>ok<LF>

    Shows no sd card, but I can use it in my pc whis no problem.
    do anyone have a solution?



  • Edit:
    but the SD Card gets detected inside my paneldue


  • administrators

    Check the soldering of the pins at the back of the SD card socket to the PCB. Also check that all the resistors in that area are present. Perhaps you disturbed one of those components when you desoldered the WiFi module.



  • Firmware files need to be in the /sys folder. If you think the SD card isn't being seen, send M122 for the report; SD card section is line 18 to 19. You can also send M503 to get it to read the config.g file, to check SD card is operating correctly.

    See https://duet3d.dozuki.com/Wiki/Firmware_Overview#Section_SD_card_structure to make sure you've set up the SD card file structure correctly.

    Ian



  • M503
    ok<LF>
    M122
    === Diagnostics ===<LF>RepRapFirmware for Duet 2 WiFi/Ethernet version 2.03 running on Duet WiFi 1.02 or later<LF>Board ID: 08DGM-9T6BU-FG3S8-6JKDD-3S86T-KBKVD<LF>Used output buffers: 1 of 24 (2 max)<LF>=== RTOS ===<LF>Static ram: 25680<LF>Dynamic ram: 93208 of which 0 recycled<LF>Exception stack ram used: 312<LF>Never used ram: 11872<LF>Tasks: NETWORK(ready,1876) HEAT(blocked,1236) MAIN(running,4528) IDLE(ready,160)<LF>Owned mutexes:<LF>=== Platform ===<LF>Last reset 00:01:33 ago, cause: power up<LF>Last software reset time unknown, reason: User, spinning module GCodes, available RAM 11872 bytes (slot 1)<LF>Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d<LF>Error status: 0<LF>Free file entries: 10<LF>SD card 0 not detected, interface speed: 30.0MBytes/sec<LF>SD card longest block write time: 0.0ms, max retries 0<LF>MCU temperature: min 28.9, current 31.7, max 32.0<LF>Supply voltage: min 11.9, current 12.0, max 12.0, under voltage events: 0, over voltage events: 0, power good: yes<LF>Driver 0: standstill, SG min/max not available<LF>Driver 1: standstill, SG min/max not available<LF>Driver 2: standstill, SG min/max not available<LF>Driver 3: standstill, SG min/max not available<LF>Driver 4: standstill, SG min/max not available<LF>Date/time: 1970-01-01 00:00:00<LF>Cache data hit count 200831864<LF>Slowest loop: 0.99ms; fastest: 0.08ms<LF>I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0<LF>=== Move ===<LF>Hiccups: 0, FreeDm: 169, MinFreeDm: 169, MaxWait: 0ms<LF>Bed compensation in use: none, comp offset 0.000<LF>=== DDARing ===<LF>Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0<LF>=== Heat ===<LF>Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1<LF>=== GCodes ===<LF>Segments left: 0<LF>Stack records: 0 allocated, 0 in use<LF>Movement lock held by null<LF>http is idle in state(s) 0<LF>telnet is idle in state(s) 0<LF>file is idle in state(s) 0<LF>serial is ready with "M122" in state(s) 0<LF>aux is idle in state(s) 0<LF>daemon is idle in state(s) 0<LF>queue is idle in state(s) 0<LF>autopause is idle in state(s) 0<LF>Code queue is empty.<LF>=== Network ===<LF>Slowest loop: 0.88ms; fastest: 0.00ms<LF>Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)<LF>HTTP sessions: 0 of 8<LF>- WiFi -<LF>Network state is disabled<LF>WiFi module is disabled<LF>Failed messages: pending 2779096485, notready 2779096485, noresp 2779096485<LF>Socket states: 0 0 0 0 0 0 0 0<LF>ok<LF>

    so the board still doesn't sie the sd card but the conifig.g is ok?



  • and yes the SD Card structure is correctly
    sd.PNG



  • It's not seeing the SD card: SD card 0 not detected, interface speed: 30.0MBytes/sec
    You should get the whole of your config.g printed out in response to M503, so it's not seeing that; the 'ok' is just acknowledging the command. Network seems to not be enabled either, which is usually in config.g. I'd say your SD card slot is not working. See @dc42 advice.

    Changing your line ending config in YAT would help! From https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7#s6:

    Setup YAT to use <LF> as the end of line character. Go to "Terminal" Menu -> "Settings" -> "Text Settings" -> "EOL sequence:" set to <LF>

    Ian



  • Stupid Question but where is the SD Card physically in the DUET or the Panel?



  • yes the sd card is in the DUET2WIFI



  • okay, now its:
    M502
    Warning: Macro file config.g not found.
    ok

    so what is the next step to do?
    can I do something before checking the board itself, because it's realy hard to get access to it?



  • M502 tries to run config.g, rather than outputting it like M503. But it still can't find config.g. Your SD card slot is not working. I don't think there's anything more you can do without removing the Duet and inspecting the soldering and components around it, as @dc42 suggested earlier:

    @dc42 said in New setup after errase and wifi antenna switch:

    Check the soldering of the pins at the back of the SD card socket to the PCB. Also check that all the resistors in that area are present. Perhaps you disturbed one of those components when you desoldered the WiFi module.

    Ian



  • WhatsApp Image 2019-10-16 at 18.46.46.jpeg WhatsApp Image 2019-10-16 at 18.46.46 (1).jpeg

    do you see a fail, or do you have a reference picture because I can't find a picture of my board revision?



  • There's clearly a missing SMD at the upper left corner of the SD card holder, R73



  • Unbenannt.PNG

    but it is missing over here as well or am I wrong


  • administrators

    @eduardschlegel said in New setup after errase and wifi antenna switch:

    Unbenannt.PNG

    Check the soldering of the topmost pin in the row of pins on the right hand side of the SD card socket on that photo. You may find it is just resting on top of the PCB pad it should be soldered to. That's the card detect pin.



  • WhatsApp Image 2019-10-17 at 20.00.08.jpeg

    no, it does look good


  • administrators

    I can't tell for sure because that part of the picture is not quite in focus. Thus is the pin I mean:

    f2fe31f2-c2ea-4324-ab4b-6f1689106165-image.png

    This line from the M122 report:

    SD card 0 not detected, interface speed: 30.0MBytes/sec

    indicates that the card detect switch is not working or not connected.


  • administrators

    @Nuramori said in New setup after errase and wifi antenna switch:

    There's clearly a missing SMD at the upper left corner of the SD card holder, R73

    There are DNP components (including R73) on the board. See the schematic:
    https://github.com/T3P3/Duet/blob/master/Duet2/Duet2v1.04/Duet2_1.04c_Schematic.pdf


Log in to reply