Baby Stepping stopped working

  • I have had this problem a while ago, and don't remember what I did to fix it, if anything. (maybe an update?)

    But baby stepping stopped working for me about a month or so ago. I don't remember installing an update just before it stopped working, but I may have... its been a while.
    I press the button, and the PanelDue/Web interface shows the change, but the printer doesn't appear to actually change the Z height. Is there a max distance Baby Stepping can move to? Max of 1mm? (just asking)

    Is anyone else noticing this behavior or is it just me?


  • It maybe working again.. or never stopped... I can't test it out right now as I am printing...
    But is there a max distance baby stepping can move the nozzle? I can keep pushing the button and at least right now, nothing appears to happen. but it may just be outside of this distance if there is a limit.

  • administrators

    @BlueDust said in Baby Stepping stopped working:

    It maybe working again.. or never stopped... I can't test it out right now as I am printing...
    But is there a max distance baby stepping can move the nozzle? I can keep pushing the button and at least right now, nothing appears to happen. but it may just be outside of this distance if there is a limit.

    If you keep babystepping down, you will eventually hit the Z min limit set in your M208 command. For example, if your Z min limit is zero and your first layer height is 0.2mm then the maximum amount you can step down during the first layer will be 0.2mm. If instead you set minimum Z to -1.0mm then you can step down 1.2mm.

  • @dc42
    Thanks That makes more sense now. Will be easier for me to use in the future. And with that knowledge.

    I think my problem wasn't as much baby stepping as Auto Bed Leveling. Auto Bed Leveling no longer makes the bed level. One end is always higher than the rest of the bed, and this happens every time the same way. As such, I think it's working, but having trouble, troubleshooting it. This start after I moved all of the Z screws, but have already remeasured their current location and updated the config.g file. I have to be missing another step I took when I initially setting up auto bed leveling as it was working perfectly without any fuss. It was like magic. And not struggling. (I had to move the screws as the bed/mounts was hitting the stepper motors on the way down).


  • @BlueDust Your post about bed leveling seems very similar to my topic here.

    Is it possible we've both stumbled upon some kind of bug, or are we just missing the same thing? 😀

  • Moderator

    What firmware version are you using?

  • @Phaedrux
    Sorry for the delay. I was out of town for a work trip...

    I recently upgraded from 2.04RC2, where I noticed to also have this problem. I just do not remember if I started having the problem when I first installed it. I know for sure I first noticed it when I moved the two corner Z motors in a few cm (and added their new locations to the config).
    I am just really not sure how to troubleshoot this issue to say it is the config or not.

    Board: Duet Ethernet 1.02 or later + DueX5
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.04RC4 (2019-10-19b1)

    Can I setup auto bed level compensation to a macro to see if it can tell how bad the bed is off? Assuming it is not influenced by auto bed leveling config...


  • Moderator

    @BlueDust said in Baby Stepping stopped working:

    Can I setup auto bed level compensation to a macro to see if it can tell how bad the bed is off?

    Well yes. Everything is a macro, so whatever you use in your bed.g could be copied into a seperate macro and modified and ran that way.

  • @Phaedrux

    I know you have told me everything is a macro before... but I was concerned it would mess with the config for auto bed leveling if I ran that again, after running said macro...

    Thanks. Printing now, but may try to look at doing this tomorrow. Just wish this issue would go away. If I can get a few spare wheels for my carriage apart over the next few days (needs washers), I may swap out the current ones that are starting to show wear. If this has no impact, I am guessing I screwed up the config somewhere when I updated the new Z stepper locations.

    If I screwed up the config, anything I should look at first? (I just went through the config/Z motor locations again before I posted this, and nothing jumped out as wrong - as I would have fixed it)...


  • Moderator

    Well every command is run one after the other and the last command to be run will take precedent. This allows for real time configuration. So whatever is in config.g will get run at startup to initialize the printer, but the configuration can be altered afterwards as new commands are sent.

    So if your macro wanted to test something else, you could include all the relevant commands and then when you're done, you could execute config.g again to return to the original config. Config.g can be called the same as any other macro with M98 Pconfig.g.

    You'd have to post your config.g so we could see how things are setup.

  • @Phaedrux

    I found one very worn out wheel, and after that replaced a few worn out other wheels (not as badly worn out) one at a time after more test prints. It didn't fix the auto bed leveling issue... still higher on one side...

    This is my current config.g. I don't think you need the entire file, but it was the same effort.

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ; generated by RepRapFirmware Configuration Tool on Fri Aug 31 2018 18:58:38 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    M929 S1 ; Logging Enabled
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    ;M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M555 P2 ; Set firmware to work like Marlin, with responses after every command and needed for OctoPrint/Palette2 setup

    M667 S1 ; Select CoreXY mode

    ; Network
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP ENABLED
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    ;M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwords
    M569 P7 S1
    M569 P8 S1
    M569 P9 S1

    M584 X0 Y1 E3 Z9:7:8 ; three Z motors connected to driver outputs 9, 7 and 8
    ;M671 X-50:127:310 Y85:385:85 S5 ; leadscrews at front left, rear middle and front right
    M671 X-50:125:308 Y93:370:93 S5

    ;M350 X256 Y256 Z256 E256 I0 ; Configure microstepping without interpolation
    M350 X256 Y256 Z256 I0 ; Configure microstepping without interpolation
    ;M350 X16 Y16 Z16 I1
    M350 E16 I1 ; Configure microstepping with interpolation

    M92 X2560 Y2560 Z12800 E819.8589

    ;M591 D0 P5 C3 R10:120 E6.0 S0 ; Duet3D laser filament sensor for extruder drive 0 is connected to endstop input 3 (E0), tolerance 40 to 120%, 3mm comparison length
    M591 D0 P3 C3 R85:115 E6.0 L25.17 S0 ; Magnetic Filament Sensor
    ;M591 D0 P3 C3 R95:105 E3.0 L25.38 S1
    M591 D0 ; display filament sensor parameters for extruder drive 0

    M566 X500 Y500 Z12 E1000

    M203 X9000 Y9000 Z1000 E800 ;E600 was old setting ;small extruder stepper motor cannot go over 240, and still may have issues that fast.

    M201 X1000 Y1000 Z250 E2400

    M906 X1200 Y1200 Z1400 E1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ;M572 D0 S0.04 ; Pressure Advance

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X280 Y280 Z280 S0 ; Set axis maxima

    ; Endstops
    ;M574 X1 Y1 S3 ; for stall guard
    M574 X2 Y1 S3

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe - Works for IR and BLTouch Probes

    ;M558 P1 H5 F120 T6000 ; Set Z probe type to unmodulated and the dive height + speeds - IR PROBE
    M558 P5 H5 F500 T4000 X0 Y0 Z1 ; Set Z probe type/mode 5. H=Dive Height. F=Speed the bed moves - BLTouch

    ;G31 P500 X0 Y-20.5 Z3.04 ; Z probe trigger value, offset and trigger height Z1.73 SHOULD BE P500 3.45 - IR PROBE
    G31 P25 X-46 Y9 Z1.927 ; Z probe trigger value, offset in relation to nozzle. And trigger height adjustment - BLTouch

    ;M557 X50:230 Y10:290 S180:280

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    ;M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M305 P1 B4725 C7.060000e-8
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; BLTouch - Heaters
    M307 H7 A-1 C-1 D-1 ; Disable the 7th Heater to free up PWM channel 5 on the Duex board.

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    ;M106 P1 T40 H1
    M106 P2 H100:101:102 T39:40 L0.0 ; Motherboard FAN Turns on at 38C, MAX @ 40C, L0.0 = always run @ low 0% fan

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    M501 ; Enables auto save of config to config-override.g

  • Moderator

    @BlueDust said in Baby Stepping stopped working:

    M558 P5 H5 F500

    One thing that stuck out to me was the dive speed of the BLTouch. 500 is quite high for the BLTouch. For best repeatability try 100.

    Which wheels did you replace?

  • @Phaedrux
    Carriage has 3 wheels. 2 in top and 1on the bottom. The bottom one is the one I am holding. It's harder to see when on the printer but when I got a good look at it I hoped all my problems were solved. Nope. So I replaced the other two on the top just because I could/easy to do. Bed level issue still exists.

    I will try changing the setting you mentioned. Thanks.

  • @Phaedrux
    I just ran a quick first layer few layers test and it appears to, at the very least be better then it was. Its weird if just slowing this down fixed it, (now its sooooo slow.....!) but do have an idea on why I have this problem now, as it was working fine with the settings before I moved the Z screws...

    The BLTouch/needle is able to hit one of my screws when moving along the wall. It bent the plastic needle but wasn't bad as I just had to straighten it out with my hand. That may have let to this issue happening, even though it didn't show until after the Z screws were moved, or it just hit it again, and much worse after the Z screws were moved and I didn't notice as the needle is moving freely this time. I do plan to get another needle but can't imagine paying for shipping for 1 small cheap item if it is still working as is.

    Thanks @Phaedrux!

  • Moderator

    @BlueDust said in Baby Stepping stopped working:

    (now its sooooo slow.....!)

    Yes it's a bit slow. To make homing a little faster I use M558 F in the homeall.g to change the speed of the first probing dive to be fast, and then change it again to be slower for a second dive.

    M558 F400 A1
    M558 F100 A10

    That way it will move to the bed quickly if it's far away, and then probe again more slowly for better accuracy.

    That wheel certainly was chewed up. Over-tensioned?

    That sucks about the BLTouch pin. I've damaged one myself by getting it caught on the edge of the bed. I wasn't able to get it bent back and just replaced the whole unit. The trigger sensitivity of the pin could be out of whack from the collision.

  • @Phaedrux

    I will try to get it to go fast to start playing with the code you shared later today. Thanks.

    I don't know if the wheels are too tight as I stop tightening them when they are no longer loose. But it wouldn't take much to over tighten them. Almost all of the wheels on my printer wear some, but have a better view of them... So I swap them out if needed. Most are still original...

  • @Phaedrux
    Weird thing about it being out of wack is that it's very consistent. Just not level.

  • Moderator

    Did the collision happen to tilt the BLTouch mount?

  • @Phaedrux
    I don't think so. I believe it is the same as it always was because I mounted it with the springs it came with. Depending on how it hits something, it will move and then go back to it's normal position.

  • So... It appears going slower just makes it more accurate, and helps a little bit (that is noticeable) but the issue still persists. I have to stop actual test prints to get my quality back tuned in (since I replaced the wheels, its been off) and just test this bed leveling issue.

Log in to reply