Duet3: Tool change working, then not...?



  • Board: Duet 3 version v0.6 (MB6HC)
    Firmware: RepRapFirmware for Duet 3 v0.6 3.0beta11 (2019-10-13b2) I also tried the Github "first beta" release of RRF 3, same results.
    Duet Web Control 2.0.2

    Symptom/problem description:

    I am building a printer that has toolchangers based on the E3D locking pseudo-standard. CoreXY kinematics. As I built and commissioned the printer, I came to the point of issuing T0 and T1 commands back-back via the DWC console. When the tool changed, the various tfre0.g, tpre0.g, tpost0.g (and equivalent for 1) were properly executed. I had a lot of physical work to do to get the toolchanger working, and did quite a few T0 T1 commands over several evenings. The free/pre/post were always executed.

    Worked out the physical problems... and... suddenly I could do a T0 followed by a T1 or vice versa, and the fre/pre/post files did NOT execute. I simply get a green check poput in DWC that indicate T0 or T1. No error messages in console; none in event log.

    I didn't change anything in the config.g or free/pre/post files, that I can find as a cause. To be clear, I was making changes, but just to things like coordinates in a G1 or G0 command, etc. No files added/removed, no tools added/deleted to config.g, and so forth. As stated above, I've tried both the official beta and the dropbox internal build firmware.

    Summary: Toolchange free/pre/post files were executing and suddenly don't.

    I'm stumped. What can cause those files to not execute?



  • Just figured it out. The documentation says: "... and all axis are homed".

    Z won't home (yet) in my hardware build. I had faked it out (hit the switch with my finger) before. When I rebooted I lost Z home. That's what was blocking it.


Log in to reply