Hotend ramming bed even after auto-calibration/mesh compensation



  • Hello all. Just bought a Duet Maestro for my Anycubic Kossel Linear Plus, as well as a smart effector for leveling and delta auto-calibrate. However, whenever I go to print, the nozzle always collides with and drags on the bed. This happens even after calibrating homed height, z-offset, auto-calibration, and mesh bed compensation. I can't figure out why this keeps happening. Below is my config.g and bed.g if it helps.

    ; Configuration file for Duet Maestro (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.5 on Fri Oct 25 2019 20:00:15 GMT-0400 (Eastern Daylight Time)
    
    ; General preferences
    G90                                         ; send absolute coordinates...
    M83                                         ; ...but relative extruder moves
    M550 P"My Printer"                          ; set printer name
    M665 R135.4 L288 B105 H220.230              ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X1.06 Y-1.14 Z0.08                     ; put your endstop adjustments here, or let auto calibration find them
    
    ; Network
    M551 P"HAHAYOUDON'TGETMYPASSWORD"                           ; set password
    M552 P0.0.0.0 S1                            ; enable network and acquire dynamic address via DHCP
    M586 P0 S1                                  ; enable HTTP
    M586 P1 S0                                  ; disable FTP
    M586 P2 S0                                  ; disable Telnet
    
    ; Drives
    M569 P0 S0                                  
    M569 P1 S0                                  
    M569 P2 S0                                  
    M569 P3 S0                                  
    M584 X0 Y1 Z2 E3                            ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                     ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E96.00             ; set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00    ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00    ; set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E1000 I30            ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                     ; Set idle timeout
    
    ; Axis Limits
    M208 Z0 S1                                  ; set minimum Z
    
    ; Endstops
    M574 X2 Y2 Z2 S1                            ; set active high endstops
    
    ; Z-Probe
    M558 P5 R0.4 H30 F1200 T3000                ; set Z probe type to effector and the dive height + speeds
    G31 P500 X0 Y0 Z2.5                         ; set Z probe trigger value, offset and trigger height
    M557 R85 S20                                ; define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                            ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R2200                 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120                                ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R2200                 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280                                ; set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P0 S1 I0 F500 H1 T45                   ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S0 I0 F500 H-1                      ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    
    ; Tools
    M563 P0 D0 H1 F0                            ; define tool 0
    G10 P0 X0 Y0 Z0                             ; set tool 0 axis offsets
    G10 P0 R0 S0                                ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    M501                                        ; load saved parameters from non-volatile memory
    
    
    ; bed.g
    ; called to perform automatic delta calibration via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.5 on Fri Oct 25 2019 20:00:15 GMT-0400 (Eastern Daylight Time)
    M561 ; clear any bed transform
    G28  ; home all towers
    ; Probe the bed at 6 peripheral and 6 halfway points, and perform 3-factor auto compensation
    ; Before running this, you should have set up your Z-probe trigger height to suit your build, in the G31 command in config.g.
    G30 P0 X0 Y104.9 H0 Z-99999
    G30 P1 X90.85 Y52.45 H0 Z-99999
    G30 P2 X90.85 Y-52.45 H0 Z-99999
    G30 P3 X0 Y-104.9 H0 Z-99999
    G30 P4 X-90.85 Y-52.45 H0 Z-99999
    G30 P5 X-90.85 Y52.45 H0 Z-99999
    G30 P6 X0 Y52.4 H0 Z-99999
    G30 P7 X45.38 Y26.2 H0 Z-99999
    G30 P8 X45.38 Y-26.2 H0 Z-99999
    G30 P9 X0 Y-52.4 H0 Z-99999
    G30 P10 X-45.38 Y-26.2 H0 Z-99999
    G30 P11 X-45.38 Y26.2 H0 Z-99999
    G30 P12 X0 Y0 H0 Z-99999 S3
    ; Use S-1 for measurements only, without calculations. Use S4 for endstop heights and Z-height only. Use S6 for full 6 factors
    ; If your Z probe has significantly different trigger heights depending on XY position, adjust the H parameters in the G30 commands accordingly. The value of each H parameter should be (trigger height at that XY position) - (trigger height at centre of bed)
    


  • Hi,

    Why are you only doing 3 factor calibration?

    We also need to see your config-override file and your homing files.

    Frederick



  • @fcwilt said in Hotend ramming bed even after auto-calibration/mesh compensation:

    Why are you only doing 3 factor calibration?

    unfortunatly that is the default at the moment in the configurator.

    M305 P0 T100000 B4138 R2200 ; set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 R2200 ; set thermistor + ADC parameters for heater 1

    B4138 is the wrong value of the anycubic kossel.
    according to marlin they are ATC Semitec 104GT-2



  • @Veti said in Hotend ramming bed even after auto-calibration/mesh compensation:

    unfortunatly that is the default at the moment in the configurator.

    Sorry but I don't understand. What has the default got to do with what appears in his bed.g file?

    Frederick



  • @fcwilt said in Hotend ramming bed even after auto-calibration/mesh compensation:

    Sorry but I don't understand. What has the default got to do with what appears in his bed.g file?

    if you create a delta configuration in the configurator.
    https://configtool.reprapfirmware.org/
    the default number of calibration factors for the delta is 3. it should be 6

    that why the S3 entry is in his bed.g


  • administrators

    @drakestraid, please change S3 on the final G30 line in bed.g to S6. Then auto calibrate a couple of times or until the reported deviation is low and stable, and save the auto calibration results. Then try printing again.



  • @fcwilt said in Hotend ramming bed even after auto-calibration/mesh compensation:

    We also need to see your config-override file and your homing files.

    Here:

    ; This is a system-generated file - do not edit
    ; Delta parameters
    M665 L288.000 R135.400 H220.390 B105.0 X0.000 Y0.000 Z0.000
    M666 X1.022 Y-1.171 Z0.149 A0.00 B0.00
    ; Heater model parameters
    M307 H0 A90.0 C700.0 D10.0 S1.00 V0.0 B0
    M307 H1 A864.1 C363.4 D5.0 S1.00 V12.8 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    G10 L2 P1 X0.00 Y0.00 Z0.00
    G10 L2 P2 X0.00 Y0.00 Z0.00
    G10 L2 P3 X0.00 Y0.00 Z0.00
    G10 L2 P4 X0.00 Y0.00 Z0.00
    G10 L2 P5 X0.00 Y0.00 Z0.00
    G10 L2 P6 X0.00 Y0.00 Z0.00
    G10 L2 P7 X0.00 Y0.00 Z0.00
    G10 L2 P8 X0.00 Y0.00 Z0.00
    G10 L2 P9 X0.00 Y0.00 Z0.00
    

    @Veti said in Hotend ramming bed even after auto-calibration/mesh compensation:

    M305 P0 T100000 B4138 R2200 ; set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 R2200 ; set thermistor + ADC parameters for heater 1

    B4138 is the wrong value of the anycubic kossel.
    according to marlin they are ATC Semitec 104GT-2

    Not using the crappy screw-mount thermistor that came with my kit, using an e3d cartridge style in a genuine e3d V6. Heating isn't an issue, tested heater and measured with infrared thermometer, was within +/-2 degrees of reported.

    @dc42 said in Hotend ramming bed even after auto-calibration/mesh compensation:

    @drakestraid, please change S3 on the final G30 line in bed.g to S6. Then auto calibrate a couple of times or until the reported deviation is low and stable, and save the auto calibration results. Then try printing again.

    I'll try that and see if it works



  • @dc42 said in Hotend ramming bed even after auto-calibration/mesh compensation:

    @drakestraid, please change S3 on the final G30 line in bed.g to S6. Then auto calibrate a couple of times or until the reported deviation is low and stable, and save the auto calibration results. Then try printing again.

    Nope, just tried that. Ran 5 calibrations, got the deviation within 0.005 of the last one each time, and still dragged on the bed.



  • @drakestraid said in Hotend ramming bed even after auto-calibration/mesh compensation:

    Nope, just tried that. Ran 5 calibrations, got the deviation within 0.005 of the last one each time, and still dragged on the bed.

    You don't by any chance have a Z offset set in your slicer?

    Frederick



  • @drakestraid said in Hotend ramming bed even after auto-calibration/mesh compensation:

    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height

    If you have a smart effector Z2.5 is a lot.

    it should be something very close to 0



  • @Veti said in Hotend ramming bed even after auto-calibration/mesh compensation:

    @drakestraid said in Hotend ramming bed even after auto-calibration/mesh compensation:

    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height

    If you have a smart effector Z2.5 is a lot.

    it should be something very close to 0

    This seemed to do the trick. Thanks!



  • @drakestraid said in Hotend ramming bed even after auto-calibration/mesh compensation:

    This seemed to do the trick. Thanks!

    This is not a value you need to guess at.

    A common approach is to position the nozzle just touching the bed (lots of folks use a piece of paper to provide just a bit of gap) and set that position as Z=0 using G92 Z0.

    You actually just have to set the Z to some known position, it doesn't have to be 0.

    For example, I use a 1mm shim gauge and lower the nozzle till it is just touching and then set Z=1 using G92 Z1.

    However you do it once the Z position is accurately set you then use G30 S-1 which will report the Z position at which your Z probe triggered. You can do this several times if you wish to verify that the reported position is consistent.

    Once you are satisfied that the reported position is good then you enter that value as the Z parameter in the G31 command.

    Frederick


  • administrators

    This is covered at https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer#Section_Measuring_the_trigger_height. The G31 Z value for a Smart Effector is typically about -0.1mm.


Log in to reply