Duet WiFi issues



  • Hi,
    Im trying to set up my Duet WiFi on my printer, I followed the guide on this site and connected it to my network and installed the firmware, Im on version 2.03.

    When I try to home the axes or any other command from the DWC it will follow that command but then disconnects from the WiFi and becomes unresponsive. I can turn it off and back on again and it remains unresponsive until I reset it using the button.

    Another thing it does is when homing the x and y, the x motor begins to move then stops, the y works fine, what could be the reason for this?

    Sorry I am fairly new to all of this and apologise if Ive missed something obvious.

    Thanks.


  • administrators

    @OW93 a few things to test:

    1. When you say "any command" causes wifi disconnect, just motor movement commands or things like turning a heater on and off?

    2. What does the voltage in report?

    3. In you are connected over USB and send a motor movement command for homing (e.g. G28 Y) does the board freeze?

    Please post the result of M122 sent after the board has frozend and been reset, along with your config.g



  • Hi @T3P3Tony,

    Thanks for the help:

    I was having issues connecting back up to the board to get a M122 even with resetting it, I had the LEDs on for 5v and VIN but not 3.3v. I moved the axis away from the Y end stop, then the 3.3v came on and WiFi came on again, would this show my end stop is wired incorrectly? My X axis end stop does not have this problem.

    Even if this is the problem for the WiFi issues, what would be the cause of the X axis motor problems? The X axis moves first so it can't be that the Y end stop causes the motor to stop can it?

    Onto your points, this is where I now stand:

    1. I have now been able to use all three heaters successfully.

    2. The voltage in to the board is exactly 24v, the power supply is the one I have used on my printer before upgrading to a Duet so I know its a good PSU.

    3. No board freezes, again until the Y axis end stop is activated.

    My M122 report came back as:

                                                                                                                                  Bed probe heights: 0.000 0.000 0.000 0.000 0.000
                                  === Heat ===
                                              Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
                                                                                              === GCodes ===
                                                                                                            Segments left: 0
                                                                                                                            Stack records: 1 allocated, 0 in use
                Movement lock held by null
                                          http is idle in state(s) 0
                                                                    telnet is idle in state(s) 0
                                                                                                file is idle in state(s) 0
                                                                                                                          serial is ready with "M122" in state(s) 0
                   aux is idle in state(s) 0
                                            daemon is idle in state(s) 0
                                                                        queue is idle in state(s) 0
                                                                                                   autopause is idle in state(s) 0
                                                                                                                                  Code queue is empty.
      === Network ===
                     Slowest loop: 23.14ms; fastest: 0.00ms
                                                           Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
                                                                                                                                       HTTP sessions: 0 of 8
            - WiFi -
                    Network state is running
                                            WiFi module is connected to access point 
                                                                                     Failed messages: pending 0, notready 0, noresp 0
                                                                                                                                     WiFi firmware version 1.22
               WiFi MAC address ec:fa:bc:2d:df:62
                                                 WiFi Vcc 3.38, reset reason Turned on by main processor
                                                                                                        WiFi flash size 4194304, free heap 29080
                                                                                                                                                WiFi IP address 192.168.1.197
                             WiFi signal strength -59dBm, reconnections 0, sleep mode modem
                                                                                           Socket states: 0 0 0 0 0 0 0 0
                                                                                                                         ok
    

    And my config.g is:
    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.5 on Fri Oct 25 2019 20:28:29 GMT+0100 (BST)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M569 P4 S1 ; physical drive 4 goes forwards
    M584 X0 Y1 Z2 E3:4 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z1280.00 E185.20:185.20 ; set steps per mm
    M566 X900.00 Y900.00 Z18.00 E300.00:300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z300.00 E1500.00:1500.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z100.00 E5000.00:5000.00 ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E1200:1200 ; set motor currents (mA)
    M84 S0 ; Disable motor idle current reduction

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X220 Y220 Z300 S0 ; set axis maxima

    ; Endstops
    M574 X2 Y2 S1 ; set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X45 Y40 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S285 ; set temperature limit for heater 1 to 285C
    M305 P2 T100000 B4725 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 2
    M143 H2 S285 ; set temperature limit for heater 2 to 285C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 S"Left" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"Right" D1 H2 F1 ; define tool 1
    G10 P1 X0 Y0 Z0 ; set tool 1 axis offsets
    G10 P1 R0 S0 ; set initial tool 1 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M911 S21 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss

    Again, thanks for the help.



  • @OW93 said in Duet WiFi issues:

    I moved the axis away from the Y end stop, then the 3.3v came on and WiFi came on again,

    yes
    see
    https://duet3d.dozuki.com/Wiki/How_to_destroy_your_Duet_2
    point Short the endstop supply voltage pin to ground.


  • administrators

    yes as @Veti says it looks like you have your endstops wired incorrectly.

    See

    https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches#Section_Microswitch

    assuming you are using simple switches:

    Connect the switch between GND and STP/IN.



  • Ive sorted out the end stop issue, its strange as the x end stop was correct.

    When I home the y axis now it doesn't go all the way to the y end stop and so is not homing correctly, my x axis is still having the same issue as before, hardly moving at all.

    Also the motors have a hissing noise to them, is this normal? Ive never had fans as quiet as the ones I have now so it could have always been there and been masked by the fan noise, its not extremely loud, just a new noise is all.

    Thanks


  • administrators

    please post your homing files



  • Here are the homing files:

    homez.g homey.g homex.g homedelta.g homeall.g



  • @OW93 said in Duet WiFi issues:

    my x axis is still having the same issue as before, hardly moving at all.

    whats the output of M119 when no entstop is touched?
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M119_Get_Endstop_Status

    Also the motors have a hissing noise to them

    see
    https://duet3d.dozuki.com/Wiki/Reducing_Stand-Still_Noise



  • @Veti,

    The M119 shows:
    Endstops - X: at max stop, Y: at max stop, Z: not stopped, Z probe: not stopped
    ok

    and I guess I was asking does the noise not matter to the printer? Im not too bothered with the noise level as it is in an enclosure and as such the noise is quite quiet anyway, I was more bothered about if it will cause any damage, I think if I can get it up and running first then sort out any fine tuning like that at a later date I would rather do that.



  • you misconfigured your endstops. change the line to
    M574 X2 Y2 S0 ; set active low endstops

    the documentation for the duet is really good and there are pages for every stage of the configuration.
    see this for endstops.
    https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches



  • Thanks for your help, Ive really messed up the end stop part of this install haven't I haha.

    I wanted both axes to home on maximum rather than minimum for cable management reasons.

    The y axis now works perfectly, homes great, but the x axis is now moving in the opposite direction to the end stop, I'll have a look through the link you have sent me to see if anything else needs changing.

    Thanks for both of your help, Im new to the forum and its nice to see a place where everyone is so knowledgeable and helpful.



  • @OW93 said in Duet WiFi issues:

    The y axis now works perfectly, homes great, but the x axis is now moving in the opposite direction to the end stop, I'll have a look through the link you have sent me to see if anything else needs changing.

    its also possible you misconfigured the direction of the x axis in the M569 command


Log in to reply