Z height and fan issues



  • Ive just finished setting up my printer, now I have a couple of problems.

    Ive gone to test the print and the bed positions itself too low (its an Ender 5 so the bed moves down) resulting in the printer trying to print in midair, about 0.4mm high.
    My z probe (bl touch) trigger height is set at 0.19mm and when homing the axis works correctly, upon printing it probes the bed then seems to forget about the offset. Ive looked in the slicer settings and there is no offset added there, is there anything Ive missed? I calibrated the z probe following this guide: https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe#Section_Calibrate_the_Z_probe_trigger_height

    My other issue is that my part cooling fans do not want to work. Ive set them up using PWM mode in the RepRap firmware config tool but when I try to turn them on in the DWC they don't work, again am I missing something obvious?

    Thanks.



  • @OW93 said in Z height and fan issues:

    My other issue is that my part cooling fans do not want to work. Ive set them up using PWM mode in the RepRap firmware config tool but when I try to turn them on in the DWC they don't work, again am I missing something obvious?

    yes posting your config.

    are you on the latest firmware?

    does the fan work in the always on port?



  • @Veti
    My config is:

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.5 on Fri Oct 25 2019 20:28:29 GMT+0100 (BST)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M569 P4 S1 ; physical drive 4 goes forwards
    M584 X0 Y1 Z2 E3:4 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z1280.00 E199.10:199.10 ; set steps per mm
    M566 X900.00 Y900.00 Z18.00 E300.00:300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z300.00 E1500.00:1500.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z100.00 E5000.00:5000.00 ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E1200:1200 ; set motor currents (mA)
    M84 S0 ; Disable motor idle current reduction

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X220 Y220 Z300 S0 ; set axis maxima

    ; Endstops
    M574 Y2 S0 ; set active low and disabled endstops
    M574 X2 S1 ; set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X45 Y40 Z0.19 ; set Z probe trigger value, offset and trigger height
    M557 X25:195 Y25:195 S20 ; define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S285 ; set temperature limit for heater 1 to 285C
    M305 P2 T100000 B4725 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 2
    M143 H2 S285 ; set temperature limit for heater 2 to 285C

    ; Fans
    M106 P0 S0 I0 F255 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F255 H-1 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 S"Left" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"Right" D1 H2 F1 ; define tool 1
    G10 P1 X0 Y0 Z0 ; set tool 1 axis offsets
    G10 P1 R0 S0 ; set initial tool 1 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M911 S21 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss

    I am on 2.03 and the always on fans are not working also, but Im running my heatsink fan from power so do not require them.

    Ive checked that the fan jumper is correct, its on VIN and VFAN. I just want them controlled by g code through my slicer.



  • when you issue
    M106 P0 S1
    or
    M106 P1 S1

    do the fans turn on?



  • @Veti
    No, no movement then.



  • The steps/mm for your z-axis seems like a rather odd number so I wonder if that is the positioning issue for your Z...for a standard leadscrew on an Ender3(I know you have the 5) with a 1.8degree stepper and 16x microstepping is 400.00 and if you were to go to the finer 2mm lead, 2mm pitch leadscrew it then becomes 1600 steps/mm (I have that type of leadscrew on my Taz 6 and BLV corexy printers). Even if you changed to 0.9 degree stepper motor then it would be 800steps/mm.



  • @JamesM
    When I was going through the firmware configurator it was trying to calculate steps per mm for me and came up with that number, I thought it was high but forgot to change it, thanks for that!

    Ive changed it now and the z axis moves a lot slower, as it did with the old setup. I'll try it and report back, may have to be after work now though.



  • @JamesM
    Thats work perfectly thanks, the z is just a little too high now but I think that's just down to needing recalibrating, nowhere near as bad as before.

    Now all I need is my fans and Im all set and ready to print again. They're definitely wired the right way around, I think its just something Ive set wrong in the firmware but I'm only getting started with this sort of thing so I don't know what's wrong yet.

    Thanks.



  • again. please verify that the fan works if you plug it into the always on port. the 2 rightmost ports



  • @Veti
    Hi, it's at the end of my previous post with my config file in, I've tried them in the always on ports too without success, could it possibly be the board?



  • if they dont work on the always on ports, then its your fans, as they should always work if there is power.

    verify the polarity of the fan and try them on an different power source.



  • How about the jumper that supplies voltage to the fans from either the built in source or external??? Make sure it's on the right side of the 3-pins for internal voltage(I'm guessing 24volts with an Ender 5)

    wiring-schematic.jpg



  • @JamesM I've made sure the jumper is in the correct location, it is a 24v PSU yes, and it has 24v fans, that should be ok.

    @Veti I've tested the fans on another PSU and they did work then, not sure what else I could try?



  • check if the 1A fuse is blown.



  • @Veti Ok, I'll do it as soon as I get back, thank you very much



  • @Veti
    You were right, the fuse is blown, Ive ordered some more, don't know why it would have blown though as I've only had 2 fans plugged in at one time.

    @JamesM @Veti
    Ive got the z axis set up nice now and sorted my fan problem out, thank you both!


Log in to reply