Duet 2 Wi-Fi module shuts down after 15 minutes



  • I've been scratching my head for a bit on this one. So after 15 minutes of no activity, the wifi module will turn off, just the module. Doesn't matter if it's just been turned on, or after a print starts, if there is no activity in the Web UI, it'll turn off. Here's the kicker, if I refresh the web page every 10 minutes, the module will stay on and I'm able to connect.

    I've reflashed all the firmware, changed SD card, moved the printer to have better connectivity (-55db), changed routers, tried connecting from different devices, even removed the board entirely and had it powered from USB and it's still the same 15 minutes. I don't get any errors just the browser saying it can't connect. The IP address even drops off my router.

    I have a VM setup on my Unraid server and it's only purpose is to refresh the web page every 10 minutes so I don't have to power cycle the printer every time I want to access it. With that, it works perfectly fine although Obviously this isn't ideal.

    Any ideas? The work around has kept me going, but I want to replace the main board on another printer with a Duet 2 Wi-Fi and I'm afraid I'll have the same issue.


  • administrators

    How strange!

    • What firmware revisions are you running? Use M115 to find the main firmware version, and M122 to find the WiFi firmware version.
    • After it has timed out, if you send M552 from USB/YAT or PanelDue, what is the response?
    • Could it be that your router implements some sort of WiFi device timeout?


  • @dc42

    Firmware is 2.03
    WiFi firmware version: 1.23

    So everything booted up and I got this from M552.
    "WiFi module is connected to access point my ap and ip"

    Then the module led started flashing, I sent M552 again and it said.
    "wifi module is auto-reconnecting"

    After the led stops flashing and turns off, M552 fills the page with
    "WiFi reported error: network scan failed"
    "wifi module is Idle"

    Finally ending with
    "Error retrieving wifi status message: SPI timeout"
    "failed to change WiFi mode (code - 7)

    One final M552 returns
    "wifi module disabled"

    M552 S1 restarts the module, it connects just fine, and then the process starts all over again.


Log in to reply