I have an issue with stepper control on a Duet 2 wifi.



  • I just received my Duet 2 Wifi today and Installed it in a Tronxy X5sa (corexy). Im new to Duet3d and previously had an SKR 1.3 running my tronxy but i wanted the web control that Duet 2 Wifi offers. I wired everything up according to the diagram found on Duet3d and went to test the homing of the axis. For some reason only the X stepper motor turns. If I home X ,Y,z or extrude, the X stepper turns. I triple checked the stepper connections. With the board stepper connectors on top it is wired Z2-E0-X-Y-Z1 and with the jumpers installed in the second Z connector.
    I think there is something seriously wrong with my board if it moves the x when i try to home z.

    heres the software specs and Config file:

    Board: Duet WiFi 1.02 or later
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.0beta12 (2019-11-02b1)
    Duet WiFi Server Version: 1.23

    config.g



  • Contents of Config (didnt know it would require a download)

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.1 on Sun Nov 03 2019 01:18:00 GMT-0500 (Eastern Standard Time)
    
    ; General preferences
    G90                                              ; send absolute coordinates...
    M83                                              ; ...but relative extruder moves
    M550 P"Zeinner"                                  ; set printer name
    
    M667 S1                                          ; select CoreXY mode
    
    ; Network
    M552 S1                                          ; enable network
    M586 P0 S1                                       ; enable HTTP
    M586 P1 S0                                       ; disable FTP
    M586 P2 S0                                       ; disable Telnet
    
    ; Drives
    M569 P0.0 S1                                     ; physical drive 0.0 goes forwards
    M569 P0.1 S1                                     ; physical drive 0.1 goes forwards
    M569 P0.2 S0                                     ; physical drive 0.2 goes backwards
    M569 P0.3 S0                                     ; physical drive 0.3 goes backwards
    M569 P0.4 S0                                     ; physical drive 0.4 goes backwards
    M584 X0.0 Y0.1 Z0.2 E0.3:0.4                     ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1                       ; configure microstepping with interpolation
    M92 X81.36 Y80.42 Z405.00 E379.17:405.00         ; set steps per mm
    M566 X600.00 Y600.00 Z18.00 E120.00:18.00        ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z180.00 E1500.00:180.00 ; set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z100.00 E10000.00:100.00  ; set accelerations (mm/s^2)
    M906 X950 Y950 Z950 E950:950 I30                 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                          ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                 ; set axis minima
    M208 X330 Y330 Z330 S0                           ; set axis maxima
    
    ; Endstops
    M574 X1 S0 P"xstop"                              ; configure active-low endstop for low end on X via pin xstop
    M574 Y1 S0 P"ystop"                              ; configure active-low endstop for low end on Y via pin ystop
    M574 Z1 S2                                       ; configure Z-probe endstop for low end on Z
    
    ; Z-Probe
    M950 S0 C"fan2"                                  ; create servo pin 0 for BLTouch
    M558 P9 C"zprobe.in+zprobe.mod" H10 F120 T6000   ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-39 Y-7 Z2.5                           ; set Z probe trigger value, offset and trigger height
    M557 X15:290 Y30:290 S20                         ; define mesh grid
    
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138   ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                            ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S100                                     ; set temperature limit for heater 0 to 100C
    M307 H0 B0 S1.00                                 ; disable bang-bang mode for the nozzle heater and set PWM limit
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138    ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                             ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280                                     ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00                                 ; disable bang-bang mode for the nozzle heater and set PWM limit
    
    ; Fans
    M950 F0 C"fan0" Q500                             ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                   ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                             ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45                                ; set fan 1 value. Thermostatic control is turned on
    
    ; Tools
    M563 P0 S"extruder" D0 H1 F0                     ; define tool 0
    G10 P0 X0 Y0 Z0                                  ; set tool 0 axis offsets
    G10 P0 R0 S0                                     ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    


  • try rrf2 for a starter



  • @Junkers said in I have an issue with stepper control on a Duet 2 wifi.:

    M667 S1

    this is depricated and i dont know if it works in rrf3. use M669


  • administrators

    @Junkers, please test the X, Y and Z motors individually using G1 H2 moves, as described at https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCoreXYPrinter#Section_Commissioning.

    If you find that only the X motor turns, send M584 without parameters to check that the stepper driver mapping is correct, and M906 without parameters to check that the motor currents are set.



  • If you want your printer to "just work" with your new Duet board, consider installing Duet 2 firmware. I'd suggest R2.04

    Available from:

    https://github.com/dc42/RepRapFirmware/releases

    If you are willing to experiment with a true beta, welcome to V3 of the firmware! Keep us posted...



  • I used rrf3.0 because it was already on the board when i got it. Loaded up rrf2.04 and the machine is homing correctly. I think the online configuration tool for rrf3.0 uses the incorrect pins for the steppers?

    Config for rrf2.04

    ; Drives
    M569 P0 S1                                        ; physical drive 0 goes forwards
    M569 P1 S1                                        ; physical drive 1 goes forwards
    M569 P2 S0                                        ; physical drive 2 goes backwards
    M569 P3 S0                                        ; physical drive 3 goes backwards
    M569 P4 S0                                        ; physical drive 4 goes backwards
    M584 X0 Y1 Z2:4 E3                                ; set drive mapping
    

    Config from rrf3.0

    ; Drives
    M569 P0.0 S1                                     ; physical drive 0.0 goes forwards
    M569 P0.1 S1                                     ; physical drive 0.1 goes forwards
    M569 P0.2 S0                                     ; physical drive 0.2 goes backwards
    M569 P0.3 S0                                     ; physical drive 0.3 goes backwards
    M569 P0.4 S0                                     ; physical drive 0.4 goes backwards
    M584 X0.0 Y0.1 Z0.2 E0.3:0.4
    


  • @Junkers said in I have an issue with stepper control on a Duet 2 wifi.:

    M584 X0 Y1 Z2:4 E3 ; set drive mapping

    M584 X0.0 Y0.1 Z0.2 E0.3:0.4

    those are not equivalent.

    first uses 2 motors for x, second one and has 2 extruders.



  • That is because i posted the config before I changed the mapping. The config tool does not have an option for dual z steppers. so i had to assign a second extruder in the tool then manually map it to z.
    What I noticed is that the tool for rrf2 maps the drives as P0,P1,P2,P3 and P4 but in rrf3 it maps them as P0.0,P0.1,P0.2,P0.3 and P0.4. I wonder if Its incorrect and should be the same as rrf2. I will do some testing when i make sure my board and wiring is 100% on rrf2.04



  • Have you checked whether all motors work if connected on your x-axis?


  • administrators

    @Junkers said in I have an issue with stepper control on a Duet 2 wifi.:

    That is because i posted the config before I changed the mapping. The config tool does not have an option for dual z steppers. so i had to assign a second extruder in the tool then manually map it to z.
    What I noticed is that the tool for rrf2 maps the drives as P0,P1,P2,P3 and P4 but in rrf3 it maps them as P0.0,P0.1,P0.2,P0.3 and P0.4. I wonder if Its incorrect and should be the same as rrf2. I will do some testing when i make sure my board and wiring is 100% on rrf2.04

    RRF3 only recognises the 0.x format for driver numbers when running on a Duet 3. The configuration tool should not generate them when the selected board is a Duet 2. We'll get this fixed.


Log in to reply