Z homing issues



  • I have a CoreXY with a 5v npn probe. The probe triggers when metal is present but it doesn't stop moving. Also in the config tool, it asks about trigger value. Is that volts ohms milliamps? Please help.



  • post the config.

    for trigger value the default should be ok, as npn is normally either 0 or 1000.



  • ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.2 on Tue Nov 05 2019 07:09:30 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"450 Hypercube" ; set printer name

    M667 S1 ; select CoreXY mode

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z100.00 E250.00 ; set accelerations (mm/s^2)
    M906 X925 Y925 Z925 E925 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X450 Y450 Z500 S0 ; set axis maxima



  • @tham40 said in Z homing issues:

    M208 X0 Y0 Z0 S1 ; set axis minima

    there is no probe configuration in your config.

    you need something like this

    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M558 P5 H5 F120 T6000 ; set Z probe type to switch and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height

    and the corresponding homing files like for example
    homeall.g
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-235 Y-215 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-235 Y-215 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 H2 X15 Y15 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed



  • Now I'm getting an error of Z probe already triggered at start of probing move



  • Add I1 parameter to M558 command, but better start with reading these:
    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe and
    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe



  • I had read those a couple times . Adding the I1 worked. Thanks guys.


Log in to reply