Duet2 Wifi Startup Problem



  • Hello,
    using a Duet2 Wifi v 1.03.
    The problem started with a running printer, network enabled but not showing up on network devices and no connection to the DWC. I tried the "Setnetwork" Macro several times, still no success. Then i turned the printer off and on again, from that point on the panel due will show "Connecting" in the upper right corner and nothing else happens.
    Removing the sd card (which is not readable via pc) didn't solve the problem. Then i noticed the Diag led permanently lit. Removing all wiring except power didn't change the always on diag led. Power via USB shows 5V, 3,3V, USB and diag led on.Power via power supply show 5V, 3,3V , VIN and diag led on, when Panel Due shows "Connecting", the E1 Heater, 3,3V and Diag led are flickering. Board won't connect to PC (no Port shown), Reset Button/Erase Button don't seem to work either.

    How do i get the Board up running in normal state ? From a running state to "no connection" with turning the printer off and on again leaves me clueless where to look further...

    Thanks in advance



  • Normally when the DIAG light is on solid it means the firmware has been erased and it's in programming mode..

    You may want to try the firmware update fallback 3 here: https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_Fallback_procedure_Num_3

    I have followed this procedure quite a few times, however I have found that on occasion the RESET button doesn't put it in the correct mode, then I have to just unplug and re-plug usb cable.





  • Tried the Fallback procedure 3 with different cables, USB ports and PC's, Bossa Port won't show up on either PC.
    Erase/Reset buttons seem OK, the board is removed from the printer only connected with the USB cable.
    Looks like DIAG LED turns on the moment the cable is pluged in, like 5V an 3,3V.



  • Still no success connecting to the board. I used a cheap IR Thermometer for measuring temperature on Wifi Module and processor, after a couple of minutes on USB Power the Wifi Module reaches around 50°C and the Processor is at 70°C. The readings might be a little of since both feel "warm" but not to hot to touch it.

    Since i bought the board a year ago directly from duet3d, there is no warranty. Does it make sense to have the board send in for Checkup/repair or is it cheaper to get a new board if i can't get it up running myself? I'm located in Germany and shipping to/from UK won't be that much but having someone looking which Part is faulty is time consuming. Even if it's a cheap IC to replace, the whole process could easily be as expensive as a new board.

    Still curios what happend, to avoid replacement going the same way...



  • @SMahnkopf said in Duet2 Wifi Startup Problem:

    Processor is at 70°C. The readings might be a little of since both feel "warm" but not to hot to touch it.

    if you can touch it, it is likely 50C or less; at 60C you start risking skin burns; so yeah readings are likely quite a bit off (tap water is usually around 50C , but obviously conducts heat better)

    Is there any difference with the SD card removed?



  • All the testing was done with SD Card removed, the original SD can't be read/opend on PC, at first i made an new one which didn't change the "behavior" of the board but was still readable after use in the PC.



  • If you have a multimeter you could try verifying the reset button isn't stuck, and measure the voltage rails.

    Power off, set meter to resistance/continuity and probe the pads on the side of the switch
    ca75e71a-2c1d-4720-903b-af082a4a5d06-image.png



  • Ok,
    tried the Reset Button, not pressed the multimeter shows "open", pressed resistance drops to 0.
    Same with Erase Button (if the pads to measure are the same).
    With both buttons there is a noticable click sound when pressed, board connected to PC the device manager doesn't react on pressing buttons.



  • @SMahnkopf said in Duet2 Wifi Startup Problem:

    tried the Reset Button, not pressed the multimeter shows "open", pressed resistance drops to 0

    Normal function unfortunately, so unless there is a pysical problem in the USB "chain" from computer, to cable, to connector, to CPU on the Duet it sounds like a faulty CPU given everything else above is accurate.

    (Edit: ask around if your friends are JTAG enabled, might be worth trying alternative means of loading the firmware before giving up)


  • administrators

    I'm sorry, it looks like the Duet has developed a fault. Assuming it's a genuine Duet purchased from a Duet3D reseller, I authorize a replacement under warranty.


Log in to reply