Duet wifi 2 with duex 5 won't connect or move motors



  • I am having some issues with a duet wifi 2 combined with a duex 5. I have been through this exact same setup at least a dozen times without issue. Seems that every time I connect the duex 5 board with the 30 pin ribbon and power the lcd goes to connecting state and won't connect. As soon as I remove it, it reads the sd and says idle. Other symptoms I am having is the drivers won't actually turn any of the motors once I get it to idle state. I have all of the connections proper just like the duet documentation. Any troubleshooting steps I can take? Seems the duet is the problem though as I have tried another duex 5 I had on hand with no luck. Going to swap the duet wifi next to see where we went wrong. I have tripple checked all of the connections as well just to make sure I hadn't wired something weird. The bltouch works off of the duex 5 for the startup sequence it does. Here is the diagnostics back from the board as well.

    M122
    === Diagnostics ===<LF>RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) r
    unning on Duet WiFi 1.02 or later<LF>Board ID: 08DGM-917DA-G4MS8-6JKDG-3S46Q-9ST3B<LF>
    Used output buffers: 1 of 20 (10 max)<LF>=== RTOS ===<LF>Static ram: 25524<LF>Dynamic ram
    : 98560 of which 0 recycled<LF>Exception stack ram used: 328<LF>Never used ram: 6660<LF>T
    asks: NETWORK(ready,1880) HEAT(blocked,1232) MAIN(running,3760) IDLE(ready,200)<LF>
    Owned mutexes:<LF>=== Platform ===<LF>Last reset 00:12:47 ago, cause: power up<LF>Last so
    ftware reset time unknown, reason: User, spinning module GCodes, available RAM 6
    628 bytes (slot 3)<LF>Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 IC
    SR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d<LF>Error status: 0<LF>Free
    file entries: 10<LF>SD card 0 detected, interface speed: 20.0MBytes/sec<LF>SD card lo
    ngest block write time: 0.0ms, max retries 0<LF>MCU temperature: min 39.5, current
    39.9, max 40.3<LF>Supply voltage: min 24.1, current 24.2, max 24.2, under voltage e
    vents: 0, over voltage events: 0, power good: yes<LF>Driver 0: ok, SG min/max not a
    vailable<LF>Driver 1: ok, SG min/max not available<LF>Driver 2: ok, SG min/max not ava
    ilable<LF>Driver 3: ok, SG min/max not available<LF>Driver 4: ok, SG min/max not avail
    able<LF>Date/time: 1970-01-01 00:00:00<LF>Cache data hit count 1647212030<LF>Slowest loop
    : 1.13ms; fastest: 0.08ms<LF>I2C nak errors 0, send timeouts 0, receive timeouts 0,
    finishTimeouts 0<LF>=== Move ===<LF>Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 2
    40, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0<LF>Scheduled moves: 0, completed
    moves: 0<LF>Bed compensation in use: none<LF>Bed probe heights: 0.000 0.000 0.000 0.00
    0 0.000<LF>=== Heat ===<LF>Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1<LF>=== GCodes
    ===<LF>Segments left: 0<LF>Stack records: 1 allocated, 0 in use<LF>Movement lock held by
    null<LF>http is idle in state(s) 0<LF>telnet is idle in state(s) 0<LF>file is idle in st
    ate(s) 0<LF>serial is ready with "M122" in state(s) 0<LF>aux is idle in state(s) 0<LF>dae
    mon is idle in state(s) 0<LF>queue is idle in state(s) 0<LF>autopause is idle in state
    (s) 0<LF>Code queue is empty.<LF>=== Network ===<LF>Slowest loop: 0.20ms; fastest: 0.01ms
    <LF>Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)<LF>HT
    TP sessions: 0 of 8<LF>- WiFi -<LF>Network state is starting<LF>WiFi module is disabled<LF>F
    ailed messages: pending 0, notready 0, noresp 0<LF>Socket states: 0 0 0 0 0 0 0 0<LF>o
    k<LF>



  • the duex was not recognized, have you checked a other ribbon cable ?



  • Yes I tried another ribbon and another duex 5. I just swapped the duet wifi 2 and it is all now working as expected. So something wrong with that particular duet wifi 2 board sadly.


Log in to reply