Bedleveling question



  • I have the Probe installed, and it works well. Only thing is the M29 gives an error, it can not reach certain specified points. It just does not do the last row, showing a heatmap with the last row low (blue), while the first 6 rows are High (red).
    I'm not in front of my machine to copy in the error. (ill add that later)

    No matter where i send the nozzle it is always above the bed, as the bed is 235 and my max position X and Y is 227. (TwoTree Sapphire Pro)

    My bed size is 227x227mm. Probe Offset is -47mm. Grid size is 30mm.
    Probe area i defined is: X min 2, X max 227 (this goes fine)
    Y min 40 and Ymax 227 (the nozzle is still above the bed then.)
    But when the probing has to fo the last row, it stops with an error.
    (Unable to reach coordinates specifies, or something like this)

    Should I change the Y max value? right now it is: M557 X2:225 Y40:227 S30

    Thinking about it, 227 (Y max) - 47 (Probe offset) = 180 / 30mm grid = 6 lines? that should work without error? right?

    wkr,
    Martijn


  • Moderator

    @Md3Man The bed levelling uses the limits you have set in M208, and won't let the NOZZLE go outside this area. See

    The X and Y position as it runs the mesh is the position of the probe, so it takes in to account the probe offset. It sounds like it does X okay, but doing Y it wants to probe at 40, 70, 100, 130, 160, 190, 220 mm. However, 227-47=180mm. So it's probably the last two rows it can't do.

    If the nozzle can't move any further, the only way to improve the area probed by the bed is to mount the probe closer to the nozzle.
    Ian



  • @droftarts said in Bedleveling question:

    uns the mesh is the position of the probe, so it takes in to account the probe offset. I

    Thank you for your reply. I checked the heat map and it was the X side that read 2 that was too narrow, i changed it to 5 and the it ran the whole process with out error.

    There is still some message i have to research, about the z offset, the min values read 0.4xx and max 0.7xx average 0.5xx
    The heatmap looks red but all the points align and show minor deviations. Not sure yet how to interpret this error.


  • Moderator

    @Md3Man Ideally, you set the Z datum in the centre of the bed with G30 before running mesh compensation. This should give it a Z=0 reference point to work from. However, if you do a mesh compensation without setting Z=0 before, and run G30 after, the mesh map should be raised or lowered (as necessary) to this point.

    See https://duet3d.dozuki.com/Wiki/Using_mesh_bed_compensation#Section_Establish_a_Z_0_datum_using_the_Z_probe

    Ian


Log in to reply