BL Touch blinking after homing



  • Hi,

    For a custom big 3D printer, we are now using a BL Touch captor. It has been functional with an IR Probe before, but now we're trying to make it print with the BL Touch.

    The behaviour is the following : when powering up, the BL Touch deploys / retracts twice.
    First, the BL Touch does not deploy when the homing starts.
    Then, when we are homing, the BL Touch is stopping the bed correctly but then it doesnt retract and it starts blinking after like 1 or 2 seconds and the homing is not taken into account.
    When we try to home triggering the BL Touch with the finger, it works correctly.

    We think that it's the extended contact between the BL Touch and the bed that may be occasionning this but we don't get how to fix it. (we activated the second part in the homez gcode and the bed doesnt move at all after the triggering).

    Our config.g is the following :

    ; Configuration file for Duet WiFi (firmware version 2.05.1)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Wed Feb 12 2020 10:52:29 GMT+0100 (Central European Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"La grosse Pauline" ; set printer name

    ; Network
    M551 P"1234" ; set password
    ;M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives

    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S0 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M569 P4 S1 ; physical drive 4 goes forwards
    M569 P5 S1 ; physical drive 5 goes forwards
    M569 P6 S1 ; physical drive 6 goes forwards
    M569 P7 S0 ; Change direction of Z motor
    M569 P8 S0 ; physical drive 8 goes forwards
    M569 P9 S0 ; Change direction of one motor

    M584 X0 Y1 Z2 E3 ; set drive mapping
    M584 X0:9 ; Two X motors on driver 0(default) and 9 of duex
    M584 Z2:7:8 ; Set 4 motors on Z
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X88.89 Y88.89 Z1600.00 E420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z1200 E800 I0 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X200 Y160 Z0 S1 ; set axis minima
    M208 X600 Y620 Z700 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y2 S1 ; set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; set endstops controlled by probe
    M307 H7 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T3000 X0 Y0 Z1; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y52 Z0.0 ; set Z probe trigger value, offset and trigger height
    M557 X250:550 Y210:580 S75 ; define mesh grid

    ; Heaters
    M140 H-1 ; disable heated bed
    M305 P1 T100000 B4725 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T50 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"test" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    And the homingz.g is like this :

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Wed Feb 12 2020 12:21:15 GMT+0100 (Central European Standard Time)
    G91 ; relative positioning
    G1 H2 Z5 F3000 ; lift Z relative to current position
    G1 H1 Z705 F1800 ; move Z up until the endstop is triggered
    G92 Z0 ; set Z position to axis maximum (you may want to adjust this)

    Uncomment the following lines to lift Z after probing
    G91 ; relative positioning
    G1 Z5 F50 ; lift Z relative to current position
    G90 ; absolute positioning

    Thank you very much for any help you could give to us 😞 It's quite urgent unfortunately

    Have a nice day

    LouisB


  • Moderator

    @Louis-B said in BL Touch blinking after homing:

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Wed Feb 12 2020 12:21:15 GMT+0100 (Central European Standard Time)
    G91 ; relative positioning
    G1 H2 Z5 F3000 ; lift Z relative to current position
    G1 H1 Z705 F1800 ; move Z up until the endstop is triggered
    G92 Z0 ; set Z position to axis maximum (you may want to adjust this)
    Uncomment the following lines to lift Z after probing
    G91 ; relative positioning
    G1 Z5 F50 ; lift Z relative to current position
    G90 ; absolute positioning

    You need to use a G30 command to home with the probe.

    G1 H1 Z705 F1800 ; move Z up until the endstop is triggered is for endstop homing. Replace it with a G1 XY move to position the probe at the center of the bed, and then a G30 to use the probe.

    M558 P9 H5 F120 T3000 X0 Y0 Z1; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y52 Z0.0 ; set Z probe trigger value, offset and trigger height
    

    Remove the X0 Y0 Z1 from M558 It's no longer used.

    Change G31 P500 to G31 P25. Also measure your X Y Z offsets.

    Use this to test and calibrate the probe: https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe



  • @Phaedrux Thank you so much for your instructions. It worked perfectly with some other adjustments. We still have some issues for the mesh bed because our bed is very uneven. Even when doing an average for the trigger height, there are still some places where the probe is not triggered so we're trying to fix this.

    Thank you anyway ! 🙂


Log in to reply