Stepper Motor x and y Duet 2 Wifi



  • Hallo, ich habe das problem das an den anschlüssen für den x und y motor nix passier und ich nur fehlermeldungen bekomme, schliesse ich die motoren an e0 und e1 an funktionieren sie. Aber habe Fehlermeldungen
    ich baue den BLV mgn cube.

    Hello, I have the problem that nothing happens at the connections for the x and y motor and I only get error messages, I connect the motors to e0 and e1 and they work.
    but i have error messages
    I build the BLV mgn cube.


  • Moderator

    @sven Please post your config.g, the motor specification, send M115 to the Duet and post reply, and post the exact error message you get.

    Ian





  • where can i find config.g


  • Moderator

    @sven You can go to the console and copy/paste text to post, rather than send pictures.
    You are on firmware 2.03. Ideally, update to the latest 2.05.1 https://github.com/dc42/RepRapFirmware/releases/tag/2.05.1
    Firmware update instructions: https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware

    Ian



  • i found it.


  • Moderator

    @sven said in Stepper Motor x and y Duet 2 Wifi:

    where can i find config.g

    Go to Settings > System editor (Einstellungen > ???) and select config.g. Copy and paste into your reply. Enclose in 'code' tag, which is </> in the formatting menu above your message.

    Ian



  • ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Tue Oct 09 2018 13:27:56 GMT+0300

    ; General preferences
    M80 ; Turns on the ATX power supply
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 PBLV mgn Cube ; Set machine name
    M552 S1 ; Enable network
    M587 S"your_wifi_name" P"your_password" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards blv: its was S1
    M569 P1 S0 ; Drive 1 goes backwards blv: its was S1
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes backwards WAS 0
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X200 Y200 Z400 E405.18 ; Set steps per mm for Bondtech.
    M566 X600 Y600 Z24 E300 ; Set maximum instantaneous speed changes (Jerk) (mm/min)
    M203 X20000 Y20000 Z600 E2000 ; Set maximum speeds (mm/min)
    M201 X3000 Y3000 Z100 E5000 ; Set accelerations (mm/s^2)
    M906 X1600 Y1600 Z1600 E1600 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Pressure advance
    ; M572 D0 S0.05 ; disabled Pressure advance

    ; Axis Limits
    M208 X-23 Y0 Z0 S1 ; Set axis minima
    M208 X320 Y321 Z350 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 S1 ; Set active high endstops edit: Y endstop is high(max).

    ; Filament sensor
    M591 D0 P1 C3 S1 ; Set Filament sensor Simple type (High) for extruder drive 0, connected to endstop input 3 (E0)

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H1 A372.3 C109.6 D4.6 B0 ; Set PID for hotend values
    M307 H0 A99.1 C453.2 D2.2 B0 ; Set PID for heated bed values
    M558 P1 H5 F200 T9000 I0 R0.5 ; Set Z probe type mini ir sensor
    G31 P500 X-2 Y-16.4 Z1.043 ; Set Z probe trigger value, offset and trigger height
    M557 X30:270 Y30:270 S80 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S100 ; Set temperature limit for heater 0 to 100C
    M305 P1 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S260 ; Set temperature limit for heater 1 to 260C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T35 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T35 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S21 R22 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured
    M564 H0 ; Let the Jog buttons work blv: added to allow jog buttons



  • one People on Facebook say
    i had the same problem, but by double checking the wiring as showed on the duet website i solved the problem.
    where can i find this?
    my english is so bad and it is very havy for me. 😞


  • Moderator

    @sven Wiring diagram is here: https://duet3d.dozuki.com/Wiki/Duet_Wiring_Diagrams

    If the same motors work on E0 and E1, I don't think it is wiring.

    Is this your config.g, or has someone sent you this? What error do you see when you try to move X and Y motors? 'Axis not homed'?

    Ian



  • this is from me from "Go to Settings > System editor (Einstellungen > ???) and select config.g" what you say, i do this



  • i have a Video but i can not send it to this Forum



  • i send it to YouTube
    you can hear the steppermotors
    the Name from the Video is Mgn cube fehler
    my Name Sven westendorf
    https://youtu.be/gr2YccU4tqw



  • This post is deleted!


  • @droftarts this is what i have but so the steppermotors not run on the plugs for y or x, on e0 and e1 run the same steppermotors.



  • Hello, has nobody got an idea or is the board broken? The motors on the other contacts only go to drive 1 and drive 0. Why?
    It is new and it was the first time I tried to start to see if the motors were working. the mgn cube is still in the works but i can't get any further. there are no endstops and no fan. can it be because of it?


  • Moderator

    @sven DO NOT USE THE MACROS ON THE SD CARD FOR TESTING YOUR MACHINE! Follow the commissioning advice here: https://duet3d.dozuki.com/Wiki/Step_by_step_guide#Section_Commissioning_tests

    I can see in your video you are running the '04-Test_motors' macro from the SD card. This is for testing the Duet at the factory, not for testing your machine. It sets the motor current very high, as well as trying to move the axes at high speed, and for 2 metres! In the test rig at the factory, it is just a motor, not connected. The 'motor phase disconnected' message is because it cannot move your X and Y axes so fast. Also, the stepper motor current is set to 2A, and is not reset to 1.6A (which your motors are set to), so your motors may get hot. Reset the Duet and don't use these macros.

    For those interested, this is '04-Test-motors':

    ; Motor Test Routine for Duet WiFi and Ethernet June 2018
    
    ;Start logging
    M929 P"test4log.txt" S1
    
    ; Test motors
    ;----setup motors for test----
    M906 X2000 Y2000 Z2000 E2000:2000 I100 ;set all motors to 2A with no idle current reduction
    
    ;The printer dimensions are deliberately set very high to allow a lot of moves during testing
    M665 R10000 L20000 B10000 H10000		; set delta radius, diagonal rod length, printable radius and homed height
    M350 X16 Y16 Z16 E16:16 I0			; Set 16x microstepping with NO interpolation
    M92 X80 Y80 Z80	E80:80				; Set axis steps/mm for 1.8deg motor even though test rig has 0.9s
    M906 X2000 Y2000 Z2000 E2000:2000 I100 		; Set all motors to 2A with no idle current reduction
    M201 X10000 Y10000 Z10000 E10000		; Acceleration limits (mm/s^2)
    M203 X100000 Y100000 Z100000 E100000		; Maximum speeds (mm/min)
    
    ; Test motors
    
    M117 PRESS ALL THREE ENDSTOPS TO END HOMING
    G91						; use relative positioning
    G1 S1 X3200 Y3200 Z3200 F9000			; move XYZ motors, stopping when endstops are triggered
    ;----end homing lines----
    
    M117 TEST Z
    G91
    G92 X0 Y0 Z0
    ;M201 Z1000
    G1 S2 Z2000 F50000
    G1 S2 Z-2000 F50000
    G1 S2 Z2000 F50000
    G1 S2 Z-2000 F50000
    G1 S2 Z2000 F50000
    G1 S2 Z-2000 F50000
    G1 S2 Z2000 F50000
    G1 S2 Z-2000 F50000
    
    M117 TEST Y
    G91
    G92 X0 Y0 Z0
    ;M201 Y1000
    G1 S2 Y2000 F50000
    G1 S2 Y-2000 F50000
    G1 S2 Y2000 F50000
    G1 S2 Y-2000 F50000
    G1 S2 Y2000 F50000
    G1 S2 Y-2000 F50000
    G1 S2 Y2000 F50000
    G1 S2 Y-2000 F50000
    
    M117 TEST X
    G91
    G92 X0 Y0 Z0
    ;M201 X1000
    G1 S2 X2000 F50000
    G1 S2 X-2000 F50000
    G1 S2 X2000 F50000
    G1 S2 X-2000 F50000
    G1 S2 X2000 F50000
    G1 S2 X-2000 F50000
    G1 S2 X2000 F50000
    G1 S2 X-2000 F50000
    
    ; Test E0 mapped to X
    M117 TEST E0
    M584 X3
    G91
    G92 X0 Y0 Z0
    ;M201 X1000
    G1 S2 X2000 F50000
    G1 S2 X-2000 F50000
    G1 S2 X2000 F50000
    G1 S2 X-2000 F50000
    G1 S2 X2000 F50000
    G1 S2 X-2000 F50000
    G1 S2 X2000 F50000
    G1 S2 X-2000 F50000
    M584 X0 Y1 Z2 E3:4
    
    ; Test E1 mapped to Y
    M117 TEST E1
    M584 Y4
    G91
    G92 X0 Y0 Z0
    ;M201 Y1000
    G1 S2 Y2000 F50000
    G1 S2 Y-2000 F50000
    G1 S2 Y2000 F50000
    G1 S2 Y-2000 F50000
    G1 S2 Y2000 F50000
    G1 S2 Y-2000 F50000
    G1 S2 Y2000 F50000
    G1 S2 Y-2000 F50000
    M584 X0 Y1 Z2 E3:4
    
    M84 ; disable motors
    M117 END OF TEST - POWER OFF BEFORE OPENING LID!; send message to DWC
    

    Ian



  • @droftarts said in Stepper Motor x and y Duet 2 Wifi:

    your motors

    okay i will test this. how can i reset the Duet an how can i test?
    Thank you i will Response later.


  • Moderator

    @sven If you want to test motor movement with no endstops, you need to send a command that will allow you to move the motor without homing, or give the axis a position. I find the second one easiest. First, reset the printer (turn off power, turn on, or send M999, or press 'Emergency Stop' top right in DWC) so you use the motor settings in config.g. Then move the X and Y axis by hand to the centre of the bed. Then send:
    G92 X150 Y150 Z 50 ; set position
    Then use the buttons in DWC, eg X+10, Y+10, Z+10 to move each axis.

    As you have a CoreXY, you MUST read this to get the movement correct: https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCoreXYPrinter

    Ian



  • I did everything so nothing happens. only z is move. in x and y is no move, z works fine.


  • Moderator

    @sven Any error message? Does the X and Y position reported in DWC change?

    Ian



  • No if i press + or - any in the web interface it do Nothing happens. only in z is Motion
    Werkzeuglüfter

    0 %
    Lüfter 0
    0 %
    ×
    Error: over temperature shutdown reported by driver(s) 1

    0 %
    Lüfter 0

    0 %

    ×
    Error: over temperature shutdown reported by driver(s) 1



  • what fan it mean. fan 0? if i put a fan on the board it works???
    please i Need help, i am a newbee and want to build this Printer.
    Thank you!


  • administrators

    @sven said in Stepper Motor x and y Duet 2 Wifi:

    No if i press + or - any in the web interface it do Nothing happens. only in z is Motion
    Werkzeuglüfter

    0 %
    Lüfter 0
    0 %
    ×
    Error: over temperature shutdown reported by driver(s) 1

    0 %
    Lüfter 0

    0 %

    ×
    Error: over temperature shutdown reported by driver(s) 1

    Sounds like the wiring of the X and Y motors may not be correct. Identify which pairs of wires are phase pairts on your motor, and make sure you connect one phase pair to the 2 pins at one end of the 4-pin motor connector on the Duet, and the other phase pair to the 2 pins at the other end.



  • @dc42 said in Stepper Motor x and y Duet 2 Wifi:

    Sounds like the wiring of the X and Y motors may not be correct. Identify which pairs of wires are phase pairts on your motor, and make sure you connect one phase pair to the 2 pins at one end of the 4-pin motor connector on the Duet, and the other phase pair to the 2 pins at the other end.

    Hello,
    but why the same Steppermotors run on drive 3 (e0) or drive 4 (e1)
    only on drive 0(x) and Drive 1 (Y) they do not run.
    no other Motors, the same they not work on x and Y. The plug is only move from port to port.
    I have test it, the pairs are Black and Green, Blue and Red. I have crimp the wire new. if there is not a bad crimp.
    But i will do this and test it later one more time.


Log in to reply