New duet 2 configuration HELP!



  • I received a new Duet 2 WiFi and I am impressed. However, I just can't seem to get it to work right. It is replacing a broke Melzi board that had Repetier firmware on it. None of the axis want to go the the full length of the bed and none of the end stops are recognized. The motor hits the end stop and keeps buzzing. Don't know what other information is needed.


  • Moderator

    https://forum.duet3d.com/topic/5909/guide-for-posting-requests-for-help

    We could use some more details.

    Have you used the web configurator to generate your config files?
    https://configtool.reprapfirmware.org/Start

    The axis length is defined in the configurator. If it's not going far enough, you might not have defined the right size, or maybe the steps per mm is wrong, so that it's not moving the right amount.

    Endstops are only active during a homing move, not during normal operation. If it's hitting the ends of travel and still going, that would indicate that it's not been properly homed or the axis length isn't correct, or the steps per mm isn't right.



  • Thanks for your help. I managed to get the other board working and I am in the middle of printing something but as soon as I can I will experiment with what you said and keep you posted. WoW get fast replies on this forum. I like the board and beginning to really like this community.



  • @Phaedrux thanks for the help. I raised the current for the motors and they go full travel now. Now when they hit the end stop they knock down the 5 volt supply and the wifi stops working and I have to manually move the axis away from the stops and the wifi reconnects. That's what I'm working on now. Have to put my electronics knowledge to work.



  • @Newbie said in New duet 2 configuration HELP!:

    Now when they hit the end stop they knock down the 5 volt supply

    sounds like a wiring problem, pictures?



  • @Phaedrux Hi, I raised the current for the motors and they go full travel now. Found out that the wiring for endstops on Duet are wired different. They are all working correctly now. I don't have automatic leveling. I level my bed the manual way then when I begin to print zaxis is approx 5 mm too high.


  • Moderator

    @Newbie said in New duet 2 configuration HELP!:

    zaxis is approx 5 mm too high.

    Are you sure the Z steps per mm is correct?

    When you jog 10mm, does it actually move 10mm?


Log in to reply