Strange artifacts on X with moons stepper motor 1,8 degree



  • Hello dear duetter's! Iv'e recently upgraded my Ender 3 Pro with a Duet Wifi board. Yesterday i decided i wanted to try some new stepper motors and these "zitz" or whatever you want to call them appeared! the motor is on the X axis and is a moon's 1.8 degree 1A motor. When i print a XYZ cube it seems to be fine. Just when there is movment with both X and Y this appears. thanks!

    IMG_4378.JPG
    IMG_4379.JPG

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Thu Feb 27 2020 21:32:24 GMT-1200 (GMT−12:00)
    
    ; General preferences
    G90                                     ; send absolute coordinates...
    M83                                     ; ...but relative extruder moves
    M550 P"My Printer"                      ; set printer name
    
    ; Network
    M552 S1                                 ; enable network
    M586 P0 S1                              ; enable HTTP
    M586 P1 S0                              ; disable FTP
    M586 P2 S0                              ; disable Telnet
    
    ; Drives
    M569 P0 S1                              ; physical drive 0 goes backwards
    M569 P1 S0                              ; physical drive 1 goes backwards
    M569 P2 S1                              ; physical drive 2 goes forwards
    M569 P3 S1                              ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                        ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E392.00       ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00     ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00     ; set accelerations (mm/s^2)
    M906 X1000 Y725 Z725 E940 I30            ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                 ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y-30 Z0 S1                      ; set axis minima
    M208 X220 Y220 Z250 S0                  ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 S1                           ; set active high endstops
    M574 Z1 S2                              ; set endstops controlled by probe
    
    ; Z-Probe
    M307 H3 A-1 C-1 D-1                     ; disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000                   ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-39 Y0 Z1.398               ; set Z probe trigger value, offset and trigger height
    M557 X15:180 Y2:195 S60                 ; define mesh grid
    
    ; Heaters
    M305 P0 T100000 B4138 R4700             ; set thermistor + ADC parameters for heater 0
    M143 H0 S120                            ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700             ; set thermistor + ADC parameters for heater 1
    M143 H1 S280                            ; set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                  ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45               ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1 F0                        ; define tool 0
    G10 P0 X0 Y0 Z0                         ; set tool 0 axis offsets
    G10 P0 R0 S0                            ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    
    


  • @Bungo First thing I would do is reduce the motor current on the X the recommendation is to run 70-80% of specified currents. you should never run them at there max ratings.



  • I tried with 75% and nothing changed;(


  • Moderator

    Loose grub screw? Belt tension different?

    If you swap back to the other motor does it go away?



  • @Phaedrux Hey! no i checked that! havnt tried with old motor but if i scale the benchy up it dissapears ;S


Log in to reply