Print stalls with equal extrusion values

  • Hey,

    to be honest I'm new to the duet Board, but got most of my quite unique ideas / needs up and running.

    To make it a little easier to understand the why and what a short introduction to myself:
    I did develop a chocolate 3D-Printer and plan on selling it in the near future. Obviously things are quite different when working with a syringe like mechanism instead of filament. Therefore I have a quite big filament diameter combined with a gear ratio of about 1:2.5 in the extruder. This results in really small E values within the G-Code.
    So far my printers were based on repetier where the following problem didn't show up.

    If two following G-Code lines have the same E value (Simplify outputs 4 digits after the comma) the print stalls for a fraction of a second but this already produces a small blob within the print.

    I am sure the problem is a result of this, because I tried deleting these lines within the G-Code which solved the problem as well as manually changing the E values so they are not the same. Deleting the E value within the line of code did not solve the problem (which makes sense) as it doesn't really change anything.
    Decreasing print speeds, or insanely high acceleration or jerk settings also didn't solve the problem.
    I know the problem could be "solved" by different workarounds but in my experience workarounds only make things more complicated on a long term basis. So I hope to find a real solution to the problem here.

    Not sure if the problem is firmware or board based...

    I hope someone has a great idea about it 😉

  • sorry, using the duet 2 wifi and running 2.02 and 2.05 on two different printers

  • Moderator

    Can you post your config.g and an example of the gcode?

  • Sure I can:

    this one is the original code with the relevant E values uncommented:
    Bildschirmfoto 2020-03-11 um 09.05.49.png

    after changing the code to this, it works fine:
    Bildschirmfoto 2020-03-11 um 09.04.50.png

    and the config:

  • Moderator

    Interesting. Thanks for posting that. @dc42 would have to take a look to see why that would be causing a pause.

Log in to reply