24v duet with 12v heatbed



  • I have my 24v powering the duet. I have separate 12v psu to heat just my heatbed. I am using an external mosfet. The mosfet has a 2 wire connector input that goes to the heatbed output on the duet. It also as 4 screw terminals: 2 for heat bed and 2 for power in. The mosfet can handle either 12/24v.

    My question is, I tried to test it and it would give me a heater fault error because temp is rising much slower than 1.7degree/sec. I tried to do PID tuning and it saids I can't do it with the command m303 h0 s90.

    Is there something I am missing? I don't know if it has anything to do with feeding the mosfet 24v and it trying to heat the bed with 12v.


  • administrators

    @tekstyle said in 24v duet with 12v heatbed:

    I tried to do PID tuning and it saids I can't do it with the command m303 h0 s90.

    Heater tuning is what you need to do. What error message did it give when you sent that command?



  • IIRC, the bed PID tuning also considered the measured bed voltage. In this case, does it matter if the Duet measures the 24V rail but the bed is powered from a 12V rail? (I presume it's ok since this is what happens with AC bed anyway)



  • Does it heat at all?
    Has it been heating normally previously?
    How beefy is your 12V PSU?

    My first troubleshooting would be measuring the PSU output while heating. Does it hold up?


  • Moderator

    @tekstyle said in 24v duet with 12v heatbed:

    Please send M115 to the Duet and post the response. This will let us know what Duet you have, and what firmware version you are on.

    My question is, I tried to test it and it would give me a heater fault error because temp is rising much slower than 1.7degree/sec.

    That's usual if you haven't tuned the bed PID, as the firmware (I'm guessing RRF3) assumes all heaters to be hot ends, and your bed can't heat as fast as a hot end. From https://duet3d.dozuki.com/Wiki/Spurious_heater_faults_and_how_to_avoid_them#Section_Faults_when_heating_up

    The message in this case is "temperature rising much more slowly than the expected x.xC/sec". This fault occurs if the rate of temperature increase is less than 75% of the value expected from the heater model defined by M307 and this condition persists for more than 5 seconds.

    I tried to do PID tuning and it saids I can't do it with the command m303 h0 s90.

    I'm guessing the firmware knows that the bed can't reach 90C, as it was slow heating up. Or it was still in a fault/error condition. See this page for how to clear faults, and some other information/solutions: https://duet3d.dozuki.com/Wiki/Spurious_heater_faults_and_how_to_avoid_them

    Is there something I am missing? I don't know if it has anything to do with feeding the mosfet 24v and it trying to heat the bed with 12v.

    That should not be a problem.

    Ian



  • I'll test it when I get home. I tried doing a M303 H0 S90 this morning and it heated as normal. did take a while tho. much slower than the 1.7degree/sec that the firmware was reporting as a heater fault. however, this time there was no error reported. I didn't do make any changes. I will see if i can repeat the problem later.


  • Moderator

    @tekstyle After its run a successful M303, save the results with M500. This should create or update the config_override.g file in the sys folder of the SD card with the new heater settings. You can either copy the M307 H0 heater command from that file and put it into config.g, or add M501 to the end of config.g so that it loads the settings from config_override at the end of processing config.g. Though note if you have a Duet 3 with Raspberry Pi this won't work.

    Ian



  • @droftarts out of curiosity, I plan on running an external mosfet on one of the smaller heater Port on the duet2 to heat another bed. Do I need to do anything special?



  • I did M303 H0 s100. I got to auto tune phase 3. Peak temperature was 100.2.

    Warning: auto tune of heater 0 failed due to bad curve fit (A=92.9, C = 898.1, D=-0.7)

    Firmware duet 2 wifi/Ethernet v3.0. electronics duet wifi 1.02 or later + duex 5 V. 2020-01-03b3



  • For whatever reason. It's working fine now.


  • administrators

    @tekstyle, I'm glad it's working. FWIW this message:

    Warning: auto tune of heater 0 failed due to bad curve fit (A=92.9, C = 898.1, D=-0.7)

    was produced because the firmware failed to get a positive value for the dead time. Likely solutions would be to either to re-run tuning with a lower target temperature (100C is close to the maximum your bed heater can reach), or alternatively to use the A and C values from tuning but experiment with different D values, starting from around 10. When running in PID mode, if D is too low then the temperature will oscillate around the target temperature. If D is too high then the bed will take longer to settle at the target temperature.


Log in to reply