Duet3D 2 not responding in any way



  • Hello,

    I am using a Duet Wifi 2 (V1.04b) on my self built coreXY.

    Today when I turned it on I have noticed that wifi connectivity was not working. I tried the USB, but it does not work as well. I have measured that all the voltages are there, VIN is 24 V, and both the +5 V and the +3V3 voltages are present.

    Upon further investigation I have noticed that the 3V3 regulator and the microcontroller get unusually hot.

    I have tried the firmware reset procedure to no avail, I am afraid that the micro is fried.

    Are there any further debug steps you suggest? I have bought the board on reprapworld and they have asked to check on you guys before we can proceed with the warranty; board is barely one year old.

    Thanks for your help!

    Ciao,
    V



  • Sounds like you've been through https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond ?

    Didn't specify if you tried removing the SD card?


  • Moderator

    @wilcomir Please run through this troubleshooting guide, and post if anything there helps: https://duet3d.dozuki.com/Wiki/What_to_do_if_your_Duet_won't_respond

    If that doesn't help (and if the processor is heating up, it's unlikely it will) please post a good, in focus, high resolution image of your Duet board. We'll be looking for failed components, usually the voltage regulators U2 and/or U3. However, it's also possible a short from 24/12V to 5 or 3.3V has caused this. So please check your wiring as much as possible, too.

    Ian



  • Hello guys,
    thanks for the quick reply.

    I have ran through the troubleshooting guide, the only remark I have is that the DIAG is always on, no matter the step I was at.
    I have checked all the wiring for dangling bits and so on, but it looks fine to me.

    Here is a picture of the board, I hope it is clear enough:

    IMG_8481.jpg

    I have also taken a picture with the board powered, with no flash:

    IMG_8477.jpg

    Thanks for your help and support!

    Ciao,
    V



  • @wilcomir said in Duet3D 2 not responding in any way:

    the only remark I have is that the DIAG is always on

    i'll ask again, did you try without the SD card? does disconnecting whatever is on z_probe_in make a difference (might not now if you have placed a jumper on the erase pins though)



  • I am sorry I did not specify this, the procedure you guys have linked mentions removing the SD card, I have tried that before the erase with no result, i.e. with or without SD card all the LEDs are on, including DIAG, and the microcontroller gets hot.

    Ciao,
    V



  • @droftarts perhaps you did not see my reply with pics above... I can take some more if you need them, just ask 🙂

    Thanks for your help.

    Ciao,
    V


  • Moderator

    @wilcomir I can't see any damage to U2 (3.3V) or U3 (5V) voltage regulators. The dot on the corner of U3 is normal. Is it U2 that is getting hot? If the microcontroller is getting hot, then I expect it has failed, but taken the processor with it. Sorry.

    Regarding warranty, please see our warranty terms here: https://www.duet3d.com/warranty

    Limited warranty cover
    This warranty covers any defects in material and workmanship in products purchased from www.duet3d.com for a period of 6 months from purchase.

    Unfortunately, if your board is around a year old, it will not be covered by warranty. It's up to RepRapWorld if they are happy to replace it.

    Ian



  • Hello @droftarts, thanks for your reply.

    U2 is getting hot, as well as the microcontroller...

    I will point the RepRapworld guys here, and we'll see what they say.

    Thanks for your assistance in this issue! You have been very helpful.

    Ciao,
    V


Log in to reply