Duet 2 Very Slow Motion



  • I hope I put this in the right place, I'm a noob here.

    So I recently got a Duet 2, and wired it up to my Ender 5 printer. This thing is great! Print quality is better than the original board for sure. The issue I'm having is that it moves REALLY slowly while printing.

    When you tell it to "home" from the web ui, it does so pretty quickly. However, when you start a print, the "home" process and everything else is in slooooow motion.

    I've been reading stuff on the net and fiddling with it for a few days now, with no progress at all.

    One thing I notice is that when it is idle before a print, it shows this:
    Before print.PNG

    Once the print begins, you get this:
    During print.png

    Max speed 8.3mm/s? Yep, that's about what I see. It's really moving that slowly.

    Here's the content of the config.g file:

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Wed Apr 22 2020 04:55:33 GMT-0500 (Central Daylight Time)
    
    ; General preferences
    G90                                       ; send absolute coordinates...
    M83                                       ; ...but relative extruder moves
    M550 P"Ender 5 Pro"                       ; set printer name
    M918 P1 E4 F2000000                       ; configure direct-connect display
    
    ; Network
    M552 S1                                   ; enable network
    M586 P0 S1                                ; enable HTTP
    M586 P1 S0                                ; disable FTP
    M586 P2 S0                                ; disable Telnet
    
    ; Drives
    M569 P0 S1                                ; physical drive 0 goes forwards
    M569 P1 S1                                ; physical drive 1 goes forwards
    M569 P2 S0                                ; physical drive 2 goes backwards
    M569 P3 S0                                ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3                          ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                   ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z1600.00 E97.80         ; set steps per mm
    M566 X1500.00 Y1500.00 Z240.00 E300.00    ; set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z480.00 E1500.00 ; set maximum speeds (mm/min)
    M201 X900.00 Y900.00 Z500.00 E5000.00     ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E1000 I50             ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                   ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                          ; set axis minima
    M208 X220 Y220 Z300 S0                    ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 S1                             ; set active high endstops
    M574 Z1 S2                                ; set endstops controlled by probe
    
    ; Z-Probe
    M307 H3 A-1 C-1 D-1                       ; disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000                     ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X44 Y7 Z3.286                    ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S38                  ; define mesh grid
    
    ; Heaters
    M305 P0 T100000 B4092 R4700               ; set thermistor + ADC parameters for heater 0
    M143 H0 S70                               ; set temperature limit for heater 0 to 70C
    M305 P1 T100000 B4092 R4700               ; set thermistor + ADC parameters for heater 1
    M143 H1 S240                              ; set temperature limit for heater 1 to 240C
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                    ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1:0 T45               ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 S"HotEnd" D0 H1 F0                ; define tool 0
    G10 P0 X0 Y0 Z0                           ; set tool 0 axis offsets
    G10 P0 R0 S0                              ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    
    

    Can anyone assist? I've tried all I can think of and I'm stuck. 😕

    Thanks!
    Tim



  • @tjobrien21 It must be the that the slicer is overriding the settings you have in your config.g. Search the gcode file for any M203 commands (which is the maximum speed). You've set it to 30,000 mm/min which the machine properties tab correctly displays as being 500mm/sec. for the machine properties tab to show 8.33 mm/sec, there must be an M203 X500 Y500 or some such in the slicer gcode file.


  • administrators

    Looks like your slicer is putting M203 commands in the GCode files it generates. Slicers shouldn't do that and can normally be configured not to.

    The reason the speeds are so slow is that M203 was defined way back as taking the speed parameters in mm/minute, which is the standard speed unit in GCode. Years later, the Marlin devs (or it may possibly have been Prusa) decided to implement M203, but in an incompatible manner by requiring the speeds to be quoted in mm/sec. So slicers that generate M203 commands often use mm/sec speeds, which when interpreted as mm/min are of course very slow.

    So I suggest you take a look at your slicer config and change it so as not to generate M203 commands. There is a separate command (M204) for use by slicers that want to change maximum speeds.

    EDIT: Ian beat me to it.


  • Moderator

    @tjobrien21 If you're using Cura as your slicer, set 'G-code flavor' to RepRap, and also check the Start and End Gcode for any M203 (and, less likely, any M350, M92, M566, M201 or M906) commands and delete those lines, or comment them out with ';' at the start of the line.

    e727e24a-e038-4d2f-bfb6-9a88b4082f36-image.png

    If you're using Slicer/PrusaSlicer, it's a similar thing; on 'Printer Settings > General' tab select 'RepRap/Sprinter', and on the 'Printer Settings > Custom Gcode' tab, check there are no M203 commands in the Start and End gcode sections.

    Ian



  • Woohoo! I had set the slicer (Cura) to use Reprap Gcode, but those codes limiting speed were the culprit. 🙂

    Now I have it going too fast, and need to tune things back a bit. But hey, it's progress forward.

    Thanks for the fast, accurate help!



  • @tjobrien21

    What interface is that from your first post?



  • This post is deleted!


  • @jay_s_uk I screenshotted the Duet interface, under "Settings->Machine Properties".



  • @droftarts So it seems like Cura is putting things I specifiy in mm/s straight into the Gcode, which is looking for mm/min. Hmm. 😐

    The good part is I can fix it in the Gcode file, so the printer is usable. 🙂


  • Moderator

    Are you sure you have Cura set to RepRap Gcode flavor as shown in Ian's screen shot above?

    Where exactly are you seeing it use mm/s instead of mm/min?



  • @Phaedrux I think I was mistaken. Once I fixed those Gcode issues by commenting in the "beginning" section of the printer config, now things are working like they're supposed to. I'm just climbing the learning curve. 🙂 Luckily computers and electronics are what I do, so I'm not very far outside my comfort zone.


Log in to reply