Duet Wifi - Ender 3 - Motor cable



  • Hi Everyone,

    Sorry if this problem was already posted but I didn't find any specific thread regarding this problem.

    The problem is as followed:

    I have an Ender 3 and installed the Duet 2 Wifi board. All my motors were installed (X, Y, Z, E0).
    I used 2 of the black Ender cables, and changed the connector that fits the board with the delivered connectors.
    I used 2 other cables (the colored ones) and also changed those connectors with the board connectors.

    I checked the polarity of all the cable which were the same and fine.
    On my first start up, the motors with the Black Ender 3 cables worked fine, all smooth.
    the motors with the other cables didn't move, and made a lot of noise.

    I checked the wiring, the motors, but that wasn't the problem.

    I switched the cables, and tried the black Ender 3 cables on the motors that made the noise.
    Now the motors did work just fine, and smooth.

    So I know that the problem is somehow with the cables. Polarity is fine, the only thing I thought was that the cables were maybe a bit to small. So I had the other 2 Ender 3 black cables lying around, I wanted a bit longer cables, so I cut off the cable in the middle, and soldered some wires, with a much larger diameter on them, to make them longer.

    I tested those cables, and again the same problem. The original, unmoddified cables work just fine, the other ones, even with a bigger diameter don't work.

    I've checked the resistance, I even dit send a High frequency signal on every cable, and checked the response on a oscilloscope. They are all fine.

    I don't know if anyone has this problem, if so does anyone have a solution?

    Regards,

    AlexDeb.


  • administrators

    Please check the phasing of the cable/motor combination. See https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors#Section_Using_the_internal_drivers and the following section of the same wiki page.


Log in to reply