Heaters turn off while auto-leveling

  • The brain on my still-somewhat-an-A8 gave out, so I replaced it with the Duet Wifi 2. I've been very slowly working through most of the issues I've come across, but I don't see the reason for this. My bed and hotend will both heat up as expected, and then during the G29, they will shutoff for the duration of the probe. They turn back on afterward, but it's halfway through the first layer before it's hot enough to extrude anything.

    I've read the Duet documentation on the commands, but don't see anything that should be doing this. I suppose I could just put another M109 after the G29? Or is there something someone sees that's wonky with my start up code (It's all from the previous Marlin code)?

    Appreciate any thoughts anyone has it... Thanks

    ;Filament used: 1.35124m
    ;Layer height: 0.2
    ;Generated with Cura_SteamEngine 4.5.0
    M190 S60
    M104 S190
    M109 S190
    ; Begin "Start G-code section" in Cura...
    M82 ;absolute extrusion mode
    G21 ;metric values
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28 X0 Y0 ;move X/Y to min endstops
    G28 Z0 ;move Z to min endstops
    M117 Autoleveling...
    G29 ;perform autoleveling
    G1 Z15.0 F9000 ;move the platform down 15mm
    G92 E0 ;zero the extruded length
    G1 F200 E3 ;extrude 3mm of feed stock
    G92 E0 ;zero the extruded length again
    G1 F9000
    M117 Printing...
    ; End "Start G-code section" in Cura...

  • Moderator

    Do you happen to have a B1 in your M558 command to configure the probe?


    Bn If 1, turn off all heaters while probing, default (B0) leaves heaters on.

    The reason this exists is that some heated beds can create a magnetic field strong enough to interfere with some probes.

  • @Phaedrux I sure do!

    M558 P9 H5 F100 T6000 R0.2 A5 B1    

    It never occurred to me to look at the "global" setup commands. I assumed it had to be right around the code being executed at the moment.

    Thank you!

Log in to reply