When G32 is run, Heater stops working



  • Hello!
    I recently redid my CoreXY and replaced the wheels for motion with rails.
    Since then, I have noticed that when I run G32, the heater turns off. It appears to turn off ONLY when the Z/Bed moves. When the hotend moves to a new location, the heaters start to work again for that 1 or 2 seconds. Any idea why this happens? I am not sure what I may have done to cause this.

    3f99f862-e864-4819-b097-78deae29739a-image.png

    I haven't upgraded to Duet 3.x yet because it was still in beta (until this week?), but would like to fix this before I upgrade.

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.05 running on Duet Ethernet 1.02 or later + DueX5
    Board ID: 08DGM-9T6BU-FG3S0-7JTDL-3SN6N-TS6VG
    Used output buffers: 3 of 24 (12 max)
    === RTOS ===
    Static ram: 25712
    Dynamic ram: 93836 of which 0 recycled
    Exception stack ram used: 544
    Never used ram: 10980
    Tasks: NETWORK(ready,628) HEAT(blocked,1232) DUEX(suspended,160) MAIN(running,1300) IDLE(ready,160)
    Owned mutexes:
    === Platform ===
    Last reset 38:58:21 ago, cause: software
    Last software reset at 2020-05-11 18:43, reason: User, spinning module GCodes, available RAM 10892 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 8
    Free file entries: 8
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 72.0ms, max retries 0
    MCU temperature: min 35.4, current 38.8, max 39.5
    Supply voltage: min 23.6, current 24.1, max 24.5, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max 0/243
    Driver 1: standstill, SG min/max 0/232
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max 0/1023
    Driver 4: standstill, SG min/max not available
    Driver 5: standstill, SG min/max not available
    Driver 6: standstill, SG min/max not available
    Driver 7: ok, SG min/max 0/1023
    Driver 8: ok, SG min/max 0/169
    Driver 9: ok, SG min/max 0/1023
    Date/time: 2020-05-13 09:42:22
    Cache data hit count 4294967295
    Slowest loop: 146.58ms; fastest: 0.07ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Move ===
    Hiccups: 0, FreeDm: 159, MinFreeDm: 97, MaxWait: 33108433ms
    Bed compensation in use: none, comp offset 0.000
    === DDARing ===
    Scheduled moves: 128, completed moves: 127, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.2
    Heater 1 is on, I-accum = 0.3
    === GCodes ===
    Segments left: 0
    Stack records: 3 allocated, 1 in use
    Movement lock held by http
    http is idle in state(s) 45 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 220.49ms; fastest: 0.02ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    Interface state 5, link 100Mbps full duplex
    === Filament sensors ===
    Extruder 0: pos 222.54, errs: frame 0 parity 0 ovrun 0 pol 0 ovdue 0

    Thanks for your help!



  • Do you have a "B1" in your M558 by any chance?



  • @jay_s_uk said in When G32 is run, Heater stops working:

    M558

    Wow!
    Yes, I had B1 on my M558 command.
    I didn't know that was even an option!

    When trying to troubleshoot my BLTouch a few weeks ago, just before I upgraded to rails (it had a bad head crash and ended up having to replace it...), I must have copied example text from somewhere, as my previous M558 commands didn't have it.

    Awesome! Thanks for your help!


Log in to reply