Ender 5 Plus Endstop Help



  • I just completed my ender 5 plus upgrade to duet 2 wifi. I have everything working except the x and y endstops. It seems that the duet wifi does not see that there are endstops. when I do an M119 it says X and Y are not stopped even if I press them manually. I thought I might have plugged them in backwards so I switched the plugs but it did not make a difference. Does anyone know what could be the issue.



  • On mine, I have it configured with the following code:

    M574 X2 S1 P"xstop"                                    ; configure active-high endstop for high end on X via pin xstop
    M574 Y2 S1 P"ystop"                                    ; configure active-high endstop for high end on Y via pin ystop
    

    As you can see, they are active High (in other words, they are normally closed between ground and signal). The signal is not being inverted (which would have required a "!" before the pin name).

    If yours are configured like this, but not being detected, try prefixing the pin name with the "!" to invert the action (according to the docs: https://duet3d.dozuki.com/Wiki/Gcode#Section_M574_RepRapFirmware_Num_3). Also make sure which pins are used on the connector (I believe mine is the outer 2 of the 3 - can't look right now).



  • @Jacotheron
    I had them wired wrong but now when ever my printer homes it hits the endstops then touches them again then slams into the x and y endstops. Could you share your set up so I can see what I had done wrong?


  • administrators

    @tootison said in Ender 5 Plus Endstop Help:

    @Jacotheron
    I had them wired wrong but now when ever my printer homes it hits the endstops then touches them again then slams into the x and y endstops. Could you share your set up so I can see what I had done wrong?

    Please post your config.g and homeall.g files.



  • here they are. so homing works now but the individual homing are reversed.
    config.g homeall.g homex.g homey.g homez.g



  • @dc42

    The endstops on the ender 5 plus are on the back right corner. How do I get it to use the front left as 0,0. Right now I have it mostly working as in not crashing but the 0,0 is the back left. Also I put the offset for my bltouch in but I think i might have to reverse the neg and pos direction of the 0,0 is to the back right.



  • My endstops are in the back right position, in the code I posted above, that is what the X2 and Y2 means (at trigger of an endstop of either axis, it will use the maximum that was set for that axis). That said, further configuration place the XY origin at the front left (like slicers typically use).

    Using the M208, we set the minimum and maximum values for both axis:

    M208 X0 Y0 Z0 S1                                       ; set axis minima
    M208 X310 Y355 Z425 S0                                 ; set axis maxima
    

    Above you would see that my X is only 310, with Y being 355 - this is due to the E3D Volcano hotend I added onto my configuration (endstops was moved); you would typically use 350 for both.

    Here is my HomeAll.g file:

    G91                   ; relative positioning
    G1 H2 Z5 F6000        ; lift Z relative to current position
    G1 H1 X355 Y355 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X-5 Y-5 F6000   ; go back a few mm
    G1 H1 X355 Y355 F360  ; move slowly to X and Y axis endstops once more (second pass)
    G90                   ; absolute positioning
    G1 X155 Y177 F6000    ; go to first bed probe point and home Z
    G30                   ; home Z by probing the bed
    G91                  ; relative positioning
    G1 Z5 F100           ; lift Z relative to current position
    G90                  ; absolute positioning
    

    I hope this helps



  • @Jacotheron
    I made those changes and not my print head moves to the front left when homing


  • administrators

    @tootison said in Ender 5 Plus Endstop Help:

    @Jacotheron
    I made those changes and not my print head moves to the front left when homing

    If you send G91 followed by G1 H2 X10 does the carriage move 10mm in the +X direction (normally to the right) or in the -X direction (normally left)?



  • Okay I just had to reverse the motor directions and everything is moves alright. Now the only thing I am having issues is with printing files. I use ideamaker and it prints fine when going in a straight line but slows down to almost a crawl and extrudes a lot of plastic then speeds up again. Also the travel speed during the print is real slow. I think i might have something to do with the Print Start gcode. Could you share what it should look like for reprap firmware. This is my first time using anything other than marlin. I attached the gcode i tried to print

    22Flow_rate_calibration_cube_double_wall.gcode


  • Moderator

    M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
    M220 S100 ;Reset Feedrate
    M221 S100 ;Reset Flowrate
    G28 ;Home
    M376 S1 Z2 ;Enable ABL using saved Mesh and Fade Height
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
    G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
    G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
    G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    ;end of Start GCode
    

    If you look at the comments in your start gcode you can see where it is over writing your speed settings from config.g. Remove those lines from the start gcode.



  • @Phaedrux
    Do I need to put the command to use abl in the start gcode? I ran mesh compensation from duetweb so does the load it automatically when prints start


  • Moderator

    The syntax for M376 in RRF is a bit different. It only sets the taper height. See here: https://duet3d.dozuki.com/Wiki/Gcode#Section_M376_Set_bed_compensation_taper

    To enable the mesh bed compensation you would want to use G29 to run it fresh, or G29 S1 to load a saved heightmap.

    https://duet3d.dozuki.com/Wiki/Using_mesh_bed_compensation



  • @Phaedrux

    So no matter how many times I adjust the Z offset everytime I do a print the first layer comes out to 0.26 instead of 0.2. I have calibrated my esteps and flow rate is calibrated so I think it might have to do with slicer start code


  • Moderator

    @tootison said in Ender 5 Plus Endstop Help:

    everytime I do a print the first layer comes out to 0.26 instead of 0.2.

    What do you mean by that? You're measuring the thickness of the first layer or what?



  • @Phaedrux
    I was measuring the thickness but I got that sorted out. The only thing I am stuck on now is trying to get ideamaker to work. It always over extrudes way too much around the corners. With my other printers I use a mix of S3D, Cura, and ideamaker. I have only got Cura working so far.


  • Moderator

    Have you tuned pressure advance?

    I'm not familiar with ideamaker.



  • @Phaedrux
    I don't have it on yet. I was going to try that after I get everything working. I am going to try S3D today


Log in to reply