No temperature control for Tool 1



  • Hi, I'm new to the Duet and the Paneldue, I've set up a delta printer using the online configurator and due to some wires being a bit short I'm using the output for the heated bed for the nozzle (Heater 0 I believe) and output for the nozzle to drive an external FET to drive the heated bed (using Heater 1) the bed is showing up just fine on the Paneldue but for Tool1 I see the icon but no temperatures or controls for it, I've tried a few different things, including updating the firmware but nothing seems to have fixed it so now I hope any of you smart people can help me out!



  • Start by posting your config.g and the version of the firmware you are running. You can get this using M115



  • FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.05.1 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-02-09b1

    for the firmware

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Thu May 21 2020 19:32:39 GMT+0200 (Midden-Europese zomertijd)
    
    ; General preferences
    G90                                         ; send absolute coordinates...
    M83                                         ; ...but relative extruder moves
    M550 P"Predator"                            ; set printer name
    M665 R227 L440 B185 H456                    ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0                               ; put your endstop adjustments here, or let auto calibration find them
    
    ; Network
    M552 S1                                     ; enable network
    M586 P0 S1                                  ; enable HTTP
    M586 P1 S0                                  ; disable FTP
    M586 P2 S0                                  ; disable Telnet
    
    ; Drives
    M569 P0 S1                                  ; physical drive 0 goes forwards
    M569 P1 S1                                  ; physical drive 1 goes forwards
    M569 P2 S1                                  ; physical drive 2 goes forwards
    M569 P3 S1                                  ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                            ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                     ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E436.54            ; set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00    ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00    ; set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30             ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                     ; Set idle timeout
    
    ; Axis Limits
    M208 Z0 S1                                  ; set minimum Z
    
    ; Endstops
    M574 X2 Y2 Z2 S1                            ; set active high endstops
    
    ; Z-Probe
    M558 P4 H5 F120 T6000                       ; set Z probe type to switch and the dive height + speeds
    G31 P500 X0 Y0 Z16                          ; set Z probe trigger value, offset and trigger height
    M557 R115 S20                               ; define mesh grid
    
    ; Heaters
    M140 H1                                     ; remap heated bed to heater 1
    M307 H1 B0 S1.00                            ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4300 R4700                 ; set thermistor + ADC parameters for heater 0
    M143 H0 S240                                ; set temperature limit for heater 0 to 240C
    M305 P1 T100000 B4300 R4700                 ; set thermistor + ADC parameters for heater 1
    M143 H1 S120                                ; set temperature limit for heater 1 to 120C
    
    ;PID tuning
    
    M307 H1 A124.8 C434.8 D1.1 S1 B0	    ; Heated Bed
    M307 H0 A490.0 C126.2 D6.4 S1.00 V24.7 B0   ; Hotend	
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                      ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H0 T45                   ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 S"Extruder" D0 H0 F0                ; define tool 1
    G10 P0 X0 Y0 Z0                             ; set tool 1 axis offsets
    G10 P0 R0 S0                                ; set initial tool 1 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    T1                                          ; select first tool
    

    for the config file



  • Your tool is defined as Tool 0, but you activate Tool 1 at the end of config. So change that T1 to T0 and try again.



  • I think that was left in there form some testing, changed it back to 0 but that wasn't it.



  • did you restarted your printer after changing tool number to 0 ?



  • @aidar Yeah, powered it down and back up again so the Paneldue resets as well.



  • It's working fine in the web interface, just not on the Paneldue, a new config where the bed heater is mapped to the bed etc but I keep having the same issue, no controls or temperatures on the paneldue, I have the 4.3inch version, maybe there's some kinda bug?



  • found this old post:
    dc42 ADMINISTRATORS 2 Aug 2018, 00:58
    It's a limitation of the current PanelDue firmware that it doesn't know the tool-to-heater mappings, so it assumes that tool 0 uses heater 1, tool 1 uses heater 2 and so on.



  • So if its still so, paneldue just doesnt know you use heater 0 for tool 0



  • This seems to be the case, I remapped them the way they are suposed to be and now it's working fine, guess not many people remap their heaters! anyway, thanks for the help, off to lengthen some wires 😉


Log in to reply