how to disable a drive and it's monitoring?



  • I had the y-axis stepper driver fail on one of my duet boards. I'm going to replace it but I have some prints I need to get done in the meantime. I've removed the burnt out driver completely from the board and remapped the y-axis to the E1 drive. This seems to work but I still have a short to ground and overtemp fault on drive one (the y-axis). I looked at the G-code reference and found M569 with the R param set to -1 I put this in my config.g along with an M584 to remap the drives but I still get those errors reported on drive one. What am I doing wrong? How can I ignore drive one completely? Thanks for taking the time to read this and help out a random stranger 🙂 .

    Board and firmware info - RepRapFirmware for Duet WiFi version 1.19 running on Duet WiFi 1.0

    config.g


  • Moderator

    You may need to update the firmware. 1.19 is rather old and perhaps the driver disable wasn't implemented or working? Just speculating, but others have recently been able to use M569 with R-1 successfully. You

    Regardless, probably a good idea to try updating to 2.05.1. There will be some work involved in that big of a jump.

    https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware



  • @Phaedrux First off thanks for helping out so fast I was able to upgrade firmware up to 2.05.1 and my original error went away. However as errors do a new on popped up, "Error: Temperature reading fault on heater 1: unknown temperature sensor channel".

    I think this means my M308 command has the wrong channel in it but I couldn't find the right channel here's the command from the config.g " M308 S1 P"spi.cs1" Y"rtd-max31856" " this is from the RRF configurator as I'm using a MAX31856-based daughter board.


  • Moderator

    It looks like you had the configurator set to generate a config set for reprapfirmware v3 but you're still using 2.05.1.

    Either redo the config for v2, or update to v3. Depends how comfortable you are with the changes.



  • That worked thank you so much for all your help. I was using the v3 config because my endstops didn't work with the v2 config but everything works now thanks again!!!!


Log in to reply