Z-Probe Problems after Update from 3.0 to 3.1.1



  • @Phaedrux said in Z-Probe Problems after Update from 3.0 to 3.1.1:
    To invert the probe signal you need to use !. The ^ is used to enable the pullup resistor.

    Thank You that was it 🙂
    M115 reports Firmware 3.1.1

    M98 P"config.g" reports:

    M98 P"config.g"
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C
    Error: Can't change sensor number of existing heater
    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 208C
    

    It looks like i must change the Heater Configs!?

    Regards Manuel


  • Moderator

    @Twister said in Z-Probe Problems after Update from 3.0 to 3.1.1:

    Error: Can't change sensor number of existing heater

    Please post your entire config.g



  • Here my config.g:

    ; Configuration file for Duet Maestro (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Tue Nov 26 2019 11:04:32 GMT+0100 (Mitteleuropäische Normalzeit)
    
    ; General preferences
    G90                                                     ; send absolute coordinates...
    M83                                                     ; ...but relative extruder moves
    M550 P"CorEssentials"                                   ; set printer name
    M667 S1                                                 ; select CoreXY mode
    
    ; Network
    M552 P0.0.0.0 S1                                       ; enable network and acquire dynamic address via DHCP
    M586 P0 S1                                             ; enable HTTP
    M586 P1 S0                                             ; disable FTP
    M586 P2 S0                                             ; disable Telnet
    
    ; Drives
    M569 P0 S1                                              ; physical drive 0 goes backwards in stealthchop mode
    M569 P1 S0                                              ; physical drive 1 goes backwards in stealthchop mode
    M569 P2 S1                                              ; physical drive 2 goes forwards in stealthchop mode
    M569 P3 S0                                              ; physical drive 3 goes forwards in stealthchop mode
    M569 P4 S1                                              ; physical drive 4 goes forwards in stealthchop mode
    M569 P5 S0 D2                                           ; physical drive 5 goes backwards in spreadcycle mode
    M569 P6 S0 D2                                           ; physical drive 6 goes backwards in spreadcycle mode
    
    M584 X5 Y6 Z0:1:2:3 E4                                  ; set drive mapping
    M671 X-35:-35:275:275 Y40:203:203:40 S10		        ; position of z belts
    M350 X16 Y16 Z16 E16 I0                                 ; configure microstepping with interpolation for X Y Z E
    M92 X80 Y80 Z400 E415                                   ; set steps per mm
    M566 X300 Y300 Z60 E120                                 ; set maximum instantaneous speed changes (mm/min)
    ;M566 X900 Y900 Z60 E120                                ; set maximum instantaneous speed changes (mm/min)
    M203 X24000 Y24000 Z6000 E6000                          ; set maximum speeds (mm/min)
    M201 X3000 Y3000 Z1000 E1500                            ; set accelerations (mm/s^2)
    ;M201 X9000 Y9000 Z1000 E1500				            ; set accelerations (mm/s^2)
    M906 X1000 Y1000 Z800 E900 I30                          ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                                 ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                        ; set axis minima
    M208 X240 Y256 Z270 S0                                  ; set axis maxima
    
    ; Endstops
    M574 X1 S1 P"xstop"                                     ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop"                                     ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S1 P"zstop"                                     ; configure active-high endstop for low end on Z via pin zstop
    
    ; Z-Probe
    M558 P5 C"!zprobe.in" H8 F60 B0 T12000                  ; set Z probe type to switch and the dive height + speeds
    G31 P500 X5 Y35 Z3.15                                   ; set Z probe trigger value, offset and trigger height
    M557 X12.5:230 Y40:225 P3:3                             ; define mesh grid
    
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B3950          ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                                   ; create bed heater output on bedheat and map it to sensor 0
    M140 H0   											    ; map heated bed to heater 0
    M143 H0 S120                                            ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S1.00                                        ; disable bang-bang mode for the nozzle heater and set PWM limit
    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.06e-8  ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                                    ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280                                            ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00                                        ; disable bang-bang mode for the nozzle heater and set PWM limit
    M308 S2 P"ctemp" Y"thermistor" A"Chamber" T100000 B3950 ; configure sensor 2 as thermistor on pin ctemp
    M950 H2 T2
    
    ; Fans
    M950 F0 C"fan0" Q1000                                   ; create fan 0 on pin fan0 and set its frequency
    M106 P0 C"Coldend" S1 H1 T45                   	        ; set fan 0 value. Thermostatic control is turned on
    M950 F1 C"fan1" Q1000                                   ; create fan 1 on pin fan1 and set its frequency
    M106 P1 C"Part" S0 H-1                                  ; set fan 1 value. Thermostatic control is turned off
    M950 F2 C"fan2" Q1000                                   ; create fan 2 on pin fan2 and set its frequency
    M106 P2 C"Chamber" S0 I0 F1000 H2 T45                   ; set fan 2 value. Thermostatic control is turned on
    
    ; LED
    M950 P0 C"e1heat" Q1000
    
    ; Tools
    M563 P0 D0 H1 F1                                        ; define tool 0
    G10 P0 X0 Y0 Z0                                         ; set tool 0 axis offsets
    G10 P0 R0 S0                                            ; set initial tool 0 active and standby temperatures to 0C
    M572 D0 S0.15 					                        ; set extruder 0 pressure advance to 0.15 seconds
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    M575 P1 S1 B57600                                       ; enable support for PanelDue
    M501                                                    ; load saved parameters from non-volatile memory
    T0                                                      ; select first tool
    
    
    

  • Moderator

    How about config-override.g as well.


  • Moderator

    Compare your heater block to the one I just generated in the configurator.

    Yours:

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B3950          ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                                   ; create bed heater output on bedheat and map it to sensor 0
    M140 H0   											    ; map heated bed to heater 0
    M143 H0 S120                                            ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S1.00                                        ; disable bang-bang mode for the nozzle heater and set PWM limit
    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.06e-8  ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                                    ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280                                            ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00                                        ; disable bang-bang mode for the nozzle heater and set PWM limit
    M308 S2 P"ctemp" Y"thermistor" A"Chamber" T100000 B3950 ; configure sensor 2 as thermistor on pin ctemp
    M950 H2 T2
    

    Generated:

    
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                          ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.00                               ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                        ; map heated bed to heater 0
    M143 H0 S120                                   ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138  ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                           ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00                               ; disable bang-bang mode for heater  and set PWM limit
    M308 S2 P"ctemp" Y"thermistor" T100000 B4138   ; configure sensor 2 as thermistor on pin ctemp
    M950 H2 C"e1heat" T2                           ; create chamber heater output on e1heat and map it to sensor 2
    M307 H2 B0 S1.00                               ; disable bang-bang mode for the chamber heater and set PWM limit
    M141 H2                                        ; map chamber to heater 2
    

    Note the extra values for the chamber heater. Do you have an active heater for the chamber or is it just to monitor.



  • I think to invert the probe you need an ! rather than the ^. I think that ^ just enables a pull up resistor.

    Edit: I see I'm late to the game.



  • @Phaedrux here is my config-override.g :

    ; config-override.g file generated in response to M500 at 2019-12-06 17:11
    ; This is a system-generated file - do not edit
    ; Heater model parameters
    M307 H0 A183.1 C296.0 D2.1 S1.00 V24.2 B0
    M307 H1 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    ; Workplace coordinates
    G10 L2 P1 X0.00 Y0.00 Z0.00
    G10 L2 P2 X0.00 Y0.00 Z0.00
    G10 L2 P3 X0.00 Y0.00 Z0.00
    G10 L2 P4 X0.00 Y0.00 Z0.00
    G10 L2 P5 X0.00 Y0.00 Z0.00
    G10 L2 P6 X0.00 Y0.00 Z0.00
    G10 L2 P7 X0.00 Y0.00 Z0.00
    G10 L2 P8 X0.00 Y0.00 Z0.00
    G10 L2 P9 X0.00 Y0.00 Z0.00
    
    

    With your generated Heater config the M98 output this:

    M98 P"config.g"
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C
    Warning: Heater 2 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C
    Error: Pin 'e1heat' is not free
    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 208C
    

    I have no Chamber Heater (Heat up with Heatbed), only a Temperature Sensor and 2 Macros to power on the Chamber Fans:

    Macro Chamber ABS:

    M106 P2 C"Chamber" S0 I0 F1000 H2 T45   
    

    Macro Chamber PLA:

    M106 P2 C"Chamber" S0 I0 F1000 H2 T20   
    

  • Moderator

    @Twister said in Z-Probe Problems after Update from 3.0 to 3.1.1:

    I have no Chamber Heater

    In that case you could remove this part

    M950 H2 C"e1heat" T2                           ; create chamber heater output on e1heat and map it to sensor 2
    M307 H2 B0 S1.00                               ; disable bang-bang mode for the chamber heater and set PWM limit
    M141 H2                                        ; map chamber to heater 2
    


  • Thx 🙂 so i see the Chamber Temp. in the Extra Tab in the WebIF. Is it possible to show up the Chamber Temp. in the Display?


  • Moderator

    @Twister said in Z-Probe Problems after Update from 3.0 to 3.1.1:

    Is it possible to show up the Chamber Temp. in the Display?

    Where do you mean? A screen shot says a thousand words.



  • Hello again,

    here in the Webinterface i see under Extras the Chamber Temperature Sensor (Sensor 2):

    WEBIF.PNG

    Can i rename it, so that appears "Champer Temperature" in the WebInterface?

    And is it possible to show up the Temperature in the PanelDue Display?
    IMG_6862.jpg


  • Moderator

    @Twister said in Z-Probe Problems after Update from 3.0 to 3.1.1:

    Can i rename it, so that appears "Champer Temperature" in the WebInterface?

    Are you using the code snip I posted? I did not include a name like yours did. So add an A"Chamber Temperature" to the M308.

    M308 S2 P"ctemp" Y"thermistor" A"Chamber"

    @Twister said in Z-Probe Problems after Update from 3.0 to 3.1.1:

    And is it possible to show up the Temperature in the PanelDue Display?

    Unfortunately not at this time.

    https://duet3d.dozuki.com/Wiki/Connecting_an_LCD_control_panel#Section_Limitations



  • Thank You! It works now fine 🙂


Log in to reply