Z Probe Error



  • Hi Team,

    The other day I ran a print successfully before trying to print again.

    I ran M502 M500 G32 commands before attempting to run the next print.

    I get the following Errors

    G32
    Error: Z probe was not triggered during probing move
    Error: Z probe already triggered at start of probing move

    Is anyone able to help me understand what the issue might be?

    Here are my Gcode settings:

    M503
    M111 S0
    M550 PT1250
    M551 P

    M540 P0x02:0x80:0xC2:0x02:0x00:0x3E

    M552 P192.168.20.5
    M554 P192.168.20.1
    M553 P255.255.255.0
    M552 S1

    M555 P2
    G21
    G90
    M83

    M106 P0 H-1
    M106 I0
    M106 S0
    M106 P1 T50 H1 S255
    M106 P2 T30 H100 S0.5

    M569 P0 S1
    M569 P1 S0
    M569 P2 S0
    M569 P3 S0
    M569 P4 S0
    M574 X2 Y2 Z2 S1

    M665 L457.6 R266.6 H677 B175
    M666 X0 Y0 Z0
    M584 X2 Y4 Z3 E0

    M92 X160 Y160 Z160
    M350 X16 Y16 Z16 E16 I1
    M906 X1700 Y1700 Z1700 E1300 I40
    M201 X4000 Y4000 Z4000 E4000
    M203 X36000 Y36000 Z36000 E18000
    M566 X500 Y500 Z500 E500

    M305 P0 T100000 B4267 R4700 H30 L0
    M305 P1 B4725 C7.060000e-8

    M307 H0 A119.9 C608.9 D1.4 S1.00 B1

    M570 H0 P20 T60
    M570 H1 P15 T10

    M563 P0 D0 H1
    G10 P0 S0 R0
    M92 E308

    M558 P4 X0 Y0 Z0 F120 T18000
    G31 X0 Y0 Z-0.1 P500

    M556 S78 X0 Y0 Z0
    M208 S1 Z-0.5

    M143 S301
    M143 H0 S101

    M911 S20.5 R23.0 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000"
    M579 X1.0068 Y1.0127
    M912 P0 S-2

    M307 H3 A-1 C-1 D-1
    M42 P3 S0

    M581 E1 S1 T1 C0
    M557 R150 S20
    M501
    G28



  • @oneearthtech since G32 calls your bed.g you should also post that. There might be something in it that causes the issue. Also you called M500 so you saved some setting in the config-override.g can you post that too?

    Also you are calling your config-override.g and then homing all. So does it home okay?



  • hey @baird1fa

    Yes the Printer home ok from what I can tell.

    Sure here they are below:

    bed.g

    G28
    G30 P0 X0.00 Y165.00 Z-99999 H0
    G30 P1 X106.06 Y126.40 Z-99999 H0
    G30 P2 X162.49 Y28.65 Z-99999 H0
    G30 P3 X142.89 Y-82.50 Z-99999 H0
    G30 P4 X56.43 Y-155.05 Z-99999 H0
    G30 P5 X-56.43 Y-155.05 Z-99999 H0
    G30 P6 X-142.89 Y-82.50 Z-99999 H0
    G30 P7 X-162.49 Y28.65 Z-99999 H0
    G30 P8 X-106.06 Y126.40 Z-99999 H0
    G30 P9 X0.00 Y82.50 Z-99999 H0
    G30 P10 X71.45 Y41.25 Z-99999 H0
    G30 P11 X71.45 Y-41.25 Z-99999 H0
    G30 P12 X0.00 Y-82.50 Z-99999 H0
    G30 P13 X-71.45 Y-41.25 Z-99999 H0
    G30 P14 X-71.45 Y41.25 Z-99999 H0
    G30 P15 X0 Y0 Z-99999 S9
    G28

    config-override.g

    ; This is a system-generated file - do not edit
    ; Delta parameters
    M665 L457.600 R266.600 H677.000 B175.0 X0.000 Y0.000 Z0.000
    M666 X0.000 Y0.000 Z0.000 A0.00 B0.00
    ; Heater model parameters
    M307 H0 A119.9 C608.9 D1.4 S1.00 V0.0 B1
    M307 H1 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 V0.0 B0



  • @oneearthtech okay. So did everything work before you saved the config-override.g for the first time. Then after that it stopped working? Perhaps erase the data I. The config-override.g and see if things work again. That will tell you if there is something in the config-override.g that is the issue.

    Looking through your config.g it seems like some parameters are missing when setting up the probe. The M558 P4 F120 T18000 is okay but where are you telling it which pin to use? If you have recently updated your firmware that could be your issue. In the new firmware you have to define the input for the sensor. It looks like you are setup for old firmware that just assumes you are using z end stop input.

    Try using
    M558 P4 C”zstop” H5 F120 T18000.

    It could also be that you are missing the H parameter too. The Hparameter is the probe height, but without it, it should default to 5 anyway.



  • Hey @baird1fa

    Ok I will try erasing the config override info and see what happens.

    I am using very old firmware as the manufacturer of my printer has advise me not to upgrade as they will provide a firmware for me. I assume there is good reason for this.



  • @baird1fa

    Unfortunately erasing the config override files has no affect.

    adding C"zstop" made things worse.



  • @oneearthtech the C parameter is only for newer firmware so that shouldn’t be your issue.

    I guess I’m not much help. Sorry.



  • @baird1fa thanks so much for trying to help.


  • Moderator

    What firmware version? What Duet board? What probe type?



  • Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet Ethernet 1.02 or later
    Firmware Version: 2.0(RTOS) (2018-06-05b3)
    Web Interface Version: 1.21.1

    Z-Probe
    Type:
    E0 Switch (4)
    Trigger Height:
    -0.1 mm
    Trigger Value:
    500

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.0(RTOS) running on Duet Ethernet 1.02 or later
    Board ID: 08DDM-9FAM2-LW4SD-6J1F0-3SJ6T-TLZ7Z
    Used output buffers: 3 of 20 (6 max)
    === RTOS ===
    Static ram: 28380
    Dynamic ram: 95568 of which 60 recycled
    Exception stack ram used: 396
    Never used ram: 6668
    Task NETWORK ready, free stack 908
    Task HEAT blocked, free stack 1256
    Task MAIN running, free stack 3548
    === Platform ===
    Last reset 00:06:34 ago, cause: power up
    Last software reset time unknown, reason: User, spinning module GCodes, available RAM 6632 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000, CFSR 0x00000000, ICSR 0x0041f000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 12.2ms
    MCU temperature: min 32.8, current 35.6, max 36.1
    Supply voltage: min 24.0, current 24.3, max 24.9, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max 0/0
    Driver 2: standstill, SG min/max 0/1023
    Driver 3: standstill, SG min/max 0/1023
    Driver 4: standstill, SG min/max 0/287
    Date/time: 1970-01-01 00:00:00
    Slowest loop: 76.11ms; fastest: 0.07ms
    === Move ===
    Hiccups: 8, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm 237, MaxWait: 1680913463ms, Underruns: 0, 0
    Scheduled moves: 121, completed moves: 121
    Bed compensation in use: none
    Bed probe heights: -3.242 -2.990 -3.276 -4.084 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 7.75ms; fastest: 0.01ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    Interface state: 5




  • Moderator

    @oneearthtech said in Z Probe Error:

    Error: Z probe was not triggered during probing move
    Error: Z probe already triggered at start of probing move
    Is anyone able to help me understand what the issue might be?

    Well if your probe is a simple switch I would start to look at the switch hardware and wiring. Has anything changed recently with it?

    If you send a simple G30 do you get the same errors?


Log in to reply