Fans in firmware v3.x



  • Hi,

    next step get the fans going.

    Its a Delta printer, with 4 fans:

    • 1 Fan in always on shocket for Duet board
    • 1 Heatskin fan, termostatically, at 50º C, power on
    • 2 Layer fans

    In first place, post the config of fans for Firmware v2.x

    ; Fans	
    M106 P0 S0 I0 H-1 C"Capa 1"             ;Capa
    M106 P1 S0 I0 H1 T50 C"HeatSkin"        ;Heatskin
    M106 P2 S0 I0 H-1 C"Capa 2"             ;Capa
    

    Second place, the config.g for Firmware v3, generated by Web configurator:

    ; Fans
    M950 F0 C"Capa Izq" Q500                      	; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                	; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                         	; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45                             	; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"Capa Der" Q500                      	; create fan 2 on pin fan2 and set its frequency
    M106 P2 S0 H-1                                 	; set fan 2 value. Thermostatic control is turned off
    

    Not working, only works fan in always on shocket...-
    What can i try?


  • administrators

    @peirof said in Fans in firmware v3.x:

    M950 F0 C"Capa Izq" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off

    Those lines should be:

    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 C"Capa Izq" S0 H-1 ; set fan 0 name and value. Thermostatic control is turned off

    Similarly the lines for fan 2 are wrong.



  • This works....

    one more...

    Can remap one of the always on fan.... as termostaticaly controled fan? or other kind

    Where i live, in summer temperatures reach 35/40º C...

    The idea its mount a second fan over duet, and power on only in summer days....



  • In this moment.... Fan that connect to duet Shocket FAN1, dont works.

    I have configured all 3 fans as layer fans, for have the possibility of power on by DWC, as follows:

    ; Fans
    M950 F0 C"fan0" Q500                   ; create fan 0 on pin fan0 and set its frequency
    M106 P0 C"Capa Izq" S0 H-1             ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                   ; create fan 1 on pin fan1 and set its frequency
    M106 P1 C"Heatskin" S0 H-1             ; set fan 1 value. Thermostatic control is turned on-- M106 P1 S1 H1 
    M950 F2 C"fan2" Q500                   ; create fan 2 on pin fan2 and set its frequency
    M106 P2 C"Capa Der" S0 H-1             ; set fan 2 value. Thermostatic control is turned off
    

    Its not wiring issue or fan issue, i have changed to other shocket (FAN0) and fan turn.... and i have connected other fan, a layer fan that works, to this shocket, and works...

    I do not think, I am not 100% sure, that it is a problem of the board, since before updating to this firmware, in fan connected to FAN1, it worked, it was that of the Heatskin.

    I don't think it's the fuse either ... if it were, no fan would go. Not? the fuse protects all fans. Not?

    What can be?



  • @peirof said in Fan1 don't works after update to FW3.1.1:

    As I had commented in previous post, after updating to Firmware 3.x, one of the fans, the one connected to the FAN1 shocket has stopped working ...

    surely one thread is sufficient?

    @peirof said in Fan1 don't works after update to FW3.1.1:

    On FAN2, the voltage was 20.80 ... I guess insufficient to spin the fan

    20.8v is more than likely enough to spin a fan 24v fan; but odds are its not 20.8v when you connect a fan to it.

    google "mosfet multimeter" and test the mosfet properly (when the power is off)


Log in to reply