Strange Behavior At End of Print Job

  • Hi Guys! New member here!

    I recently heavily upgraded a Creality CR-10 to an official Duet 2 Wifi board, among other things. I upgraded everything to 24v from the stock 12v config, and I'm using a BLTouch mounted on a Bondtech DDS hotend system.

    My setup all seems to work well, I got a perfectly printed 48 hour print from the machine yesterday...... but....

    The print ended at about 5am while I was sleeping. When I awoke, I found the print was finished, but my Z Gantry had risen all the way to the top of the Z frame, and was a little stuck there. My X and Y were homed to the stop switches, and the hot end and bed heaters were deactivated as they should be.

    Luckily, I have the machined flexible Z-Motor lead screw connectors, so the connectors had separated themselves, probably when the machine tried to pull the Z gantry back down from the top.......since it was a bit stuck up there for some reason.....probably from the force of the motors.

    Is there any way to see a log/report of what happened?

    I've read that the problem may be within my homing config files. When my printer tried to "home" at the end of the print, and my home file tells the Z axis to move (the default?) of 240mm to search for the end stop or probe activation point.......if the Z was already higher than that at the end of the print, would it move down the 240mm, and then start moving back up when it didn't find it's home point?

    Hopefully that all makes sense lol! I'm at work, and not infront of my machine right now, so I can't provide log or anything at the moment. I just want to see if my thinking is in the right direction so I can tackle the issue once I get home.

    Thanks in advance for any/all input!

  • Moderator

    Well the behaviour at the end of the print would be dictated by your slicer end gcode script. So please post the contents of that as well as your homeall.g and config.g files. It would also be good to know your firmware version (M115 to check).

    Welcome to the forum.

  • I figured it out......dumb mistake on my part. I had a G28 in my end G-Code in my slicer. The Z gantry tried to home to Z, and the gantry impacted my print.....which was very large and solid. I'm guessing that after the Z-motor connectors separated, and the probe hadn't found home yet, the gantry then moved up to the top and the machine gave-up at some point.

    I fixed it so that Z raises 5mm (relatively), X homes, and Y presents the print by going to absolute Y300.

    Test several times, and works as expected. Sorry if I wasted anyone's time.

  • Moderator

    Glad you got it sorted out. I suspected it might be something like that.

Log in to reply