Initial Motor Setup Driver Issues



  • Hello. I am new using a Duet3, but have done numerous other builds with Azteeg and other drivers. So, bear with me please.

    I did an initial setup with a new Duet3 I received from Matterhackers. It has a 600 watt power supply feeding 24.2 volts and is connected to a RPi4 (4GB). I loaded the latest full GUI image to the Pi. I used the raprap config tool to create my initial config files.

    I checked that the phases on my motors were lined up with two wires of a phase on two pins on one side of the connector and two on the other two pins. I verified each with a meter. I also verified that my limit switches are on and active high and have verified output.

    I set up the initial config to use the X tower on driver 0, Y tower on driver 1 and Z tower on driver 2. When I first powered on and tried I dont seem to be able to move any of the axes even if using G1 H2 Xn. I then tried to home and it looks like only driver 3 (Y tower) seems to vibrate. I also got an error that there was a ground short for driver 1. But, again, after verifying the motor with a meter, it seems fine. I evern tried a different motor. If I swapped motors from x or y towers to Z, it seemed to be fine, thus following the driver not the motor.

    I moved X and Y motors to drivers 3 and 4 respectively, and got some movement but mostly vibration and not linear movement.

    I looked at my old settings for these motors from my old setup using an Azteeg, and my stepper motors were each set up to use 32x with microstepping for the towers with 200 steps per mm and 16x for extruder with 2600 steps per mm.

    I havent had much luck so far,so I stripped the board down to just power in and one motor. Nothing else. I pulled another stepper I have that is new and unused. I am trying to test each driver one by one and will see how that goes.

    My questions are:

    1. what is the error that states that there is a short of driver 1?
    2. On printer drivers I have used before, simple vibration but no movement of a motor is likely a current or reversed phase issue. I have tried bumping current to 1200 mA and swapped phase wires with no change .
    3. If I am getting no activity from driver 0 and driver 1, what is the liklihood that they are damaged? Is there a diagnostic or test that I can perform that would let me know the status of those drivers?

    Thanks,
    Paul


  • Moderator

    @Diverp01 see this thread https://forum.duet3d.com/topic/18011/duet-3-6hc-short-to-ground-issue
    There is a batch of Duet 3 boards that show a short to ground error due to faulty components. Please check if your board is one of them. If so, please email info@duet3d.com with the information requested in that thread, and a the Duet will be replaced under warranty.

    Ian



  • Thanks for looping me in to that issue. I did submit the requested information. It does look like I have one of the affected boards. I did swap out a 12v supply temporarily instead of the 24v supply and motors behave properly. I will wait to hear back as to what I need to do next from the email I sent in for support.

    Thanks


Log in to reply