Strange and undesirable pressure advance behaviour

  • administrators

    Yes, there is a bug fix to pressure advance in beta 8. I thought the bug didn't change anything except cause a step error to be logged, but it looks like it does.

  • @dc42:

    Yes, there is a bug fix to pressure advance in beta 8. I thought the bug didn't change anything except cause a step error to be logged, but it looks like it does.

    I have not upgraded to the new firmware yet but here is a side by side photo with the only difference in settings being pressure advance is off on the evenly spaced infill (top) and it is on in the oddly spaced infill (bottom). As you can see it is a repeated spacing error in the pattern when it is on.

  • administrators

    I find that very odd. Is it reproducible? Does M122 report and step errors?

  • For info, I was printing cubes with 10% infill so they look very similar to the pictures above. Infill spacing looks fine. That's with 1.91.beta8. Unfortunately I never got to printing infill with 1.18.1 so can't say if the problem existed with that version of firmware on my printer.

  • Yes it is reproducable, both prints are 25% rectilinear infill. each print with pressure advance turned on has that odd spacing. I will rerun the prints again today and check for missed steps. Odd that it only occurs with pressure advance on so i doubt it is missed steps.

  • @Whitewolf. The other Odd behaviour I had with 1.18 didn't show any missed steps but went away when I upgraded to 1.19.beta8

  • Yeah, I plan to upgrade just running some prints right now so I have something to compare to…. my kids ran off with my prints as usual lol

  • Bad picture but something strange with the infill…


  • Errr. What are we looking at? Are we comparing one with another or what?

  • Rightclick the image and view in window… Look at the infill... Before I had nice infill almost straight lines... now the are doubled up... But it might be stronger infill like this... But I do not like it at all...

    also now have a strange outside:

    I only had a crappy mobile phone to photo this time…

    OK lets try again:
    Pressure Advance ON:

    Preasure Advance off: (better camera)

  • administrators

    Pressure advance should not affect infill except at the ends, unless it is an indirect effect of reducing acceleration to stay within the configured extruder jerk. Looks like a layer registration issue. Are you also getting Z banding?

  • No, not that I can see.

    Do not consider this banding issues.

    Once the part currently printing is done I'll check that part…
    So far the part seem to print OK... Some issues like I do not get a good corner, I still do not know what to tune...

    I do think I under extrude some but the result om the part is so good except the infill since it prints every second layer I assume the gap is from there

    What makes me supriced is the triangles the infill has when I have this uncommented:
    ;M572 D1 S0.05

    This makes no sense BUT the only difference between the above prints is this semicolon.

    Same machine, same plastic.

  • Hmm… investigation on Jerk...

    Saw that M566 E setting was low... looking into this I set it to E300:300... And hope for the best.

    Turn on pressure advance and see it my trouble disappears...

    At least point out the M-codes would be nice here so I can find the information here in the forum easier...,_jerk,_and_maximum_speeds

    And some hint that pressure advance need an acceleration that is bigger than X (I found 200) and a pointer to the page that should say how to set that acceleration.

    Also I thought that a M122 during print would be smart to see the CPU/RAM usage… And maybe stepping... Well I actually tried M112.. and that had an effect on the print... So just to ask before I try again... Can I sen an M122 during print?

  • administrators

    M122 shouldn't affect the print if you use firmware 1.18 or later.

  • OK, So far I now have the same result with pressure advance on. So it seems you are absolutely correct in the analysis and identification of the problem. Will add photos when the printer has printed more…

    But you ALSO cut 2 hours of the print time. (estimate of course...)

    This is the setting so far:

    M201 X800 Y800 Z15 E1000            		; Accelerations (mm/s^2)
    M203 X15000 Y15000 Z100 E3600       		; Maximum speeds (mm/min) 
    M566 X600 Y600 Z30 E300:300            		; Minimum speeds mm/minute

    I see many extremely higher numbers… like;

    M201 X9000 Y9000 Z150 E6000 ; Set accelerations (mm/s^2)
    M203 X12000 Y12000 Z375 E12000 ; Set maximum speeds (mm/min)
    M566 X9000 Y9000 Z12 E9000 ; Set maximum instantaneous speed changes (mm/min)

    Are these sensible and I'm a chicken or are these just extreme…

  • those are extreme but so far in my testing they dont hurt. I am currently running at the other end with very low settings (but before with high settings) no reason other than learning how the settings make my machine work.

    There are two ways you can approach things…. open those settings all the way up with high values so they dont interfere with slicer settings or open the slicer settings all the way up so they dont interfere with the printer settings.

    I prefer to have my slicer settings opened up so i can see direct affect of changing the printer settings. I see a number of people running with very low accell and jerk settings then printing at 120mm/s but reality is they are being limited by their accell and jerk.

    I should warn though that this is printer specific, if you have a heavy xy carriage then high jerk settings could sound pretty loud and nasty 🙂 my carriage is really light and some settings can make it pretty loud.

    But by all means play around and find the best mix of speed and quality that matches your printers abilities. You wont know what it can do until you push it.

  • Your Z maximum speed seems really low to me? Have you tried moving that up then jogging z up and down with the controls to see what the best speed it can achieve is?

  • administrators

    Z settings for speed and acceleration vary a lot between printers depending on screw pitch and hence steps/mm. My Cartesian printer has 4000 steps/mm and similar low maximum speed and acceleration values.

  • @dc42:

    Ian, please can you:

    1. Run M122 after or during this print and see whether the Step Error count is nonzero after you observe that behaviour. That count gets reset to zero after each time you run M122.

    2. Upgrade to 1.19beta8 and see if the problem goes away. Caution: the board MAC address will change, so if the Duet is getting its IP address via DHCP then the IP address will change.

    never heard of MAC changing via firmware change, Are you sure on that? I know you can spoof a MAC but did not think you could actually change them. all but last octet is for manufacturer ID if i recall correctly, thought that was hard coded like serialized CPU's?

  • @dc42:

    Z settings for speed and acceleration vary a lot between printers depending on screw pitch and hence steps/mm. My Cartesian printer has 4000 steps/mm and similar low maximum speed and acceleration values.

    Interesting, on my setup I have an 1.8 degree stepper with M8 1.25 pitch lead screw… the max speed is 400 it does not matter what I set the acceleration to it can be 10 or it can be 400 there does not appear to be any effect on achievable speed. I have played around with it alot trying to get faster speeds.

    But as far as the other portion of your comment, currently I have 2560 steps per mm, if I was to change out to a 0.9 degree stepper which would become 5120.00 steps per mm, does that mean I would effectively have to cut my speed in half to 200?

    Right now as it is printing 64mm/s there is a slight pause for layer change printing a 40mm single wall cube, I would like to eliminate this if possible. What would you recommend stepper motor, lead screw size and pitch that would allow Z to keep up with the XandY axis?

Log in to reply