z axes moves wrong way while printing?



  • New to reprap firmware. My problem is that the z axis moves correctly from machine control. but when I try to start a print after the first layer it decreases the clearance of the nozzle instead of increasing. here is my config file. Any help will be greatly appreciated.
    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Thu Sep 10 2020 18:09:59 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name
    M669 K1 ; select CoreXY mode

    ; Network
    M552 P0.0.0.0 S1 ; enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X200.00 Y200.00 Z400.00 E400.00 ; set steps per mm
    M566 X1200.00 Y1200.00 Z3.6 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z2000.00 E6000.00 ; set maximum speeds (mm/min)
    M201 X2000.00 Y2000.00 Z100.00 E2000.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X316 Y300 Z350 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z2 S2 ; configure Z-probe endstop for high end on Z

    ; Z-Probe
    M558 P5 C"!^zprobe.in" H5 F120 T12000 ; set Z probe type to switch and the dive height + speeds
    G31 P100 X25 Y75 Z1.07 ; set Z probe trigger value, offset and trigger height
    M557 X20:285 Y20:265 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    ;TO DO use the following guide to PID tune the bed heater as every build will have different values
    ;https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control
    ;M307 H0 A191.5 C435.9 D4.3 V0 B0 ; disable bang-bang mode for bed heater and set PID autotune PWM values
    ; Extruder Heater
    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.06e-8 ; configure sensor 1 as Hemera thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    ;TO DO use the following guide to PID tune the hotend as every build will have different values
    ;https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control
    ;M307 H1 A566.5 C268.7 D4.5 V24.3 B0 ; disable bang-bang mode for heater and set PID autotune PWM values

    ; Fans
    ;Part cooling fan
    M950 F0 C"fan0" Q200 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off

    ;Hotend fan
    M950 F1 C"fan1" Q200 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 L120 X255 H1 T60:140 ; set fan 1 value. Thermostatic control is turned on. Min speed of 120 as 60 deg, and max speed for 190 at 140+degrees
    ;!!!Set X255 for full speed hotend fan, if you have heat creep issues

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z2.66 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M575 P1 S1 B57600 ; enable support for PanelDue
    M501 ; load saved parameters from non-volatile memory


  • Moderator

    Are you sure the Z axis is moving the correct direction when jogging? Does Z0 = the nozzle touching the bed and Z+ move the nozzle and bed farther apart?

    Can you post your homeall and homez files?

    Can you post your slicer start gcode section?



  • Thanks for the quick reply. here are the files.

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Sun Sep 27 2020 16:00:20 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-315 Y-315 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 H1 X-315 ; home X axis
    G1 H1 Y-315 ; home Y axis
    G1 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-315 F360 ; move slowly to X axis endstop once more (second pass)
    G1 H1 Y-315 ; then move slowly to Y axis endstop
    G90 ; absolute positioning
    G1 X150 Y150 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Sun Sep 27 2020 16:00:20 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 X0 Y5 F6000 ; go to first probe point
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning


  • administrators

    @carlkelly176 can you do these tests as well:

    @Phaedrux said:

    Are you sure the Z axis is moving the correct direction when jogging? Does Z0 = the nozzle touching the bed and Z+ move the nozzle and bed farther apart?


Log in to reply