Problems with configuring fans on Duet 2 Wifi



  • I'm having problems configuring my fans for my TeVo Little Monster.

    I'm using a Duet 2 Wifi v.1.02 (or later) and firmware version 3.1.1.

    My current wiring is like so:
    Always on = board fan

    fan0 = part cooling 1,
    fan1 = hot end fan,
    fan2 = part cooling 2

    My config is:

    M950 F0 C"fan0" Q500                               ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H1 T45                                  ; set fan 0 value. Thermostatic control is turned on
    M950 F1 C"fan2" Q500                               ; create fan 1 on pin fan1 and set its frequency
    M106 P2 S1 H-1                                     ; set fan 1 value. Thermostatic control is turned off
    

    With this configuration the fan0 (part cooling) and board fan is always on, but when I heat up the hotend nothing changes, and I can not control the fans either through commands or the interface.

    I'm an absolute noob to configuration, hopefully some of you smart people can help, apologies.😁

    Edit:
    I'm sure the wiring is as stated, as I've tested pluging it in different ports.



  • have you assigned the fan to a tool?

    i would suggest that you do the fan configuration using the config tool
    https://configtool.reprapfirmware.org


  • Moderator

    @TokeDK said in Problems with configuring fans on Duet 2 Wifi:

    My current wiring is like so:
    Always on = board fan
    fan0 = part cooling 1,
    fan1 = hot end fan,
    fan2 = part cooling 2
    My config is:
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency M106 P0 S0 H1 T45 ; set fan 0 value. Thermostatic control is turned on M950 F1 C"fan2" Q500 ; create fan 1 on pin fan1 and set its frequency M106 P2 S1 H-1 ; set fan 1 value. Thermostatic control is turned off

    Your config is not correct for what you want. If fan0 is to be the part cooling fan, except you have it thermostatically controlled based on the hotend temps. And Fan1 is configured as not being thermostatically controlled.

    Is the intention to have part cooling 2 be used on a separate tool or both fans on the same tool? You'll need to define that in your tool definition.

    Here's an example from the configurator that should work assuming you only have 1 tool.

    ; Fans
    M950 F0 C"fan0" Q500                               ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                     ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                               ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H0:1 T45                                ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan2" Q500                               ; create fan 2 on pin fan2 and set its frequency
    M106 P2 S1 H-1                                     ; set fan 2 value. Thermostatic control is turned off
    
    ; Tools
    M563 P0 S"tool" D0 H1 F0:2                         ; define tool 0
    G10 P0 X0 Y0 Z0                                    ; set tool 0 axis offsets
    G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
    


  • @Phaedrux
    Thanks. This is great, I didn't realize I'd have to configure a tool also.

    Yes it was my intention to have 2 part cooling fans on 1 tool.

    Your snippet helped me understand the configuration perfectly! Now I'm finally just about ready to do some test prints! 😊



  • @Phaedrux
    Altough now when I manually adjust the levels of the tool fan (fan1) all the other fans follow the same level... The only one that I can change independently is fan2??


  • Moderator

    Fan1 in my example is the heat sink fan and thermostatically controlled, are you sure that's the fan you're adjusting?

    In the DWC there are sliders for the tool fan, which is the fan f the currently selected tool, and the fan sliders for the fans themselves. If you have more than one tool the "tool fan" slider will control a different fan depending on what tool is selected. But if you have only 1 tool it will control the fan assigned to that 1 tool. In your case it would be fan0 and fan2 at least the way I have shown it configured.



  • @Phaedrux
    This video shows what I mean:
    https://youtu.be/Dt5jatG5b4M

    My config is:

    ; Fans
    M950 F0 C"fan0" Q500                               ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                     ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                               ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H0:1 T45                                ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan2" Q500                               ; create fan 2 on pin fan2 and set its frequency
    M106 P2 S1 H-1                                     ; set fan 2 value. Thermostatic control is turned off
     
    ; Tools
    M563 P0 S"tool" D0 H1 F0:2                         ; define tool 0
    G10 P0 X0 Y0 Z0                                    ; set tool 0 axis offsets
    G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
    

  • Moderator

    Yes that behaviour is exactly what I describe. You can click on the "change visibility" button to hide the redundant fan0 and fan2 if you wish.

    Unless I'm missing something, what exactly isn't working?


Log in to reply