RRF 3.1.1 Probe Issues



  • Hello Guys, I just can't seem to find an answer on my Issue. I was running 2.05.1 and everything was working well, so I decided to make my life difficult and move to 3.1.1 and now I am having some trouble with my Probe. Before there would always be a double probe action, it would probe once fast and once slow in each spot, now it only probes each point once? Has anyone else noticed this and how can I fix it?


  • administrators

    Most likely you do not have the correct M558 command in config.g. Please post your config.g file.



  • ; Configuration file for Duet WiFi (firmware version 3.1.1)
    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"BLV AM8" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M569 P4 S1 ; physical drive 4 goes forwards
    M584 X0 Y1 Z2:4 E3 ; set drive mapping
    M671 X0:220 Y110:110 S2 ; leadscrews left & right (Middle of the bed in the Y axis)
    M350 X16 Y16 Z16 E16 I0 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E400.00 ; set steps per mm
    M566 X1000.00 Y1000.00 Z40.00 E1000.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z1000.00 E6000.00 ; set maximum speeds (mm/min)
    M201 X2500.00 Y2500.00 Z100.00 E2500.00 ; set accelerations (mm/s^2)
    M906 X1500 Y1500 Z720 E1500 I45 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-4 Y-50 Z0 S1 ; set axis minima
    M208 X220 Y210 Z250 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"!xstop"
    M574 Y1 S1 P"!ystop" ; set active low and disabled endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M558 P5 C"zprobe.in" H5 F120 T6000 ; set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y37.5 Z0.70 ; set Z probe trigger value (was at P500, I am testing P1000), offset and trigger height (Higher is closer to the bed!)
    M557 X10:210 Y10:210 S10 ; define mesh grid

    ; Heaters

    ; Bed
    M308 S0 P"bed_temp" Y"thermistor" T100000 B4138 R4700 ; New Value for 3.1.1
    M950 H0 C"bed_heat" T0 ; New Value for 3.1.1
    M307 H0 A135.7 C683.7 D2.1 V11.8 B0 S1.00 ; Disable bang-bang mode and add PID Values for the bed heater and set PWM limit
    M140 H0 ; Map Heated Bed to Heater 0 on the GUI
    M143 H0 S120 ; Set the Bed Max Temp to 120 Degrees

    ; Hotend
    M308 S1 P"spi.cs1" Y"rtd-max31865" R395 F50 ; create sensor number 1 as a PT100 sensor in the first position on the Duet 2 daughter board connector
    M950 H1 C"e0_heat" T1 ; New Value for 3.1.1
    M307 H1 A636.2 C264.9 D5.8 V11.8 B0 S1.00 ; disable bang-bang mode and set PID Values for the Hotend heater and set PWM limit
    M143 H1 S270 ; Set the Hotend Max Temp to 270 Degrees

    ; Chamber
    M308 S2 P"e1_temp" Y"thermistor" T100000 B4138 C0 R4700 ; New Value for 3.1.1
    M950 H2 C"e1_heat" T2 ; New Value for 3.1.1
    M307 H2 A42.6 C3913.4 D5.0 V12.2 B0 S1.00 ; Chamber PID Values - Testing These!
    ;M307 H2 A11 C99000 D2000 B1 ; chamber heater operates in bang-bang mode
    M141 H2 ; Map Heated Bed to Heater 0 on the GUI
    M143 H2 S80 ; Set the Chamber Max Temp to 80 Degrees

    ; Fans

    ; Part Fan
    M950 F0 C"fan0" Q500 ; New Value for 3.1.1
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Hotend Fan
    M950 F1 C"fan1" Q500 ; New Value for 3.1.1
    M106 P1 S1 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0 ; select first tool



  • Dunno if this is considered the correct way to do it or not but what works for me is the following
    in my homeall.g files

    ; homeall.g
    ; called to home all axes
    ;
    G91                     ; Relative positioning
    G1 H2 Z5 F6000          ; Lift the Z axis
    G1 H1 X-320 Y-320 F7000 ; Move the X & Y axis's quickly towards their end stops (First Pass)
    G1 H2 X5 Y5 F8000       ; Then go back a few mm
    G1 H1 X-320 Y-320 F1000 ; Then Slowly approach the X & Y end stops (Second Pass)
    G1 X155 Y168 F7000      ; Go to the centre of the bed
    M558 A1 F600	        ; Set a single probe move at a faster feed rate to get the nozzle closer to the bed
    G30                     ; home Z by probing the bed
    M558 A1 F100	        ; Set the second probing at a slower feed rate
    G30	                ; Probe a second time to get a more accurate position
    G91                     ; Relative positioning
    G1 Z5 F1000             ; Lift the Z axis 
    G90                     ; Absolute positioning
    


  • @dc42 If you see anything else in my config that could be wrong, please let me know. The Probe is a Pinda 5v



  • @CaLviNx Thanks, I will give this a try. I would rather fix the M558 in config.g though as this also happens in my mesh levelling.



  • @MichaelMD1978 said in RRF 3.1.1 Probe Issues:

    @CaLviNx Thanks, I will give this a try. I would rather fix the M558 in config.g though as this also happens in my mesh levelling.

    in the config.g you can also specify the amount of times it carries out a probe A command



  • @CaLviNx Thanks



  • @CaLviNx how would that look in the config.g?



  • @CaLviNx This is my current M558:

    M558 P5 C"zprobe.in" H5 F120 T6000 ; set Z probe type to unmodulated and the dive height + speeds

    How do I edit that to probe twice?



  • @MichaelMD1978 said in RRF 3.1.1 Probe Issues:

    @CaLviNx how would that look in the config.g?

    To be honest in RRF-3 im not exactly sure how you go about getting any subsequent probe to be of a differing speed to the initial probe, I would surmise there is some young pup of a computer whizz out there who can whip up some conditional g-code to do what you are asking.

    Me myself and i would start by trying multiple copies of M558 both with A1 in the command but differing feed rates, the worst that can happen is that it doesn't work and you need to work out another solution.



  • @MichaelMD1978 said in RRF 3.1.1 Probe Issues:

    M558 P5 C"zprobe.in" H5 F120 T6000 ; set Z probe type to unmodulated and the dive height + speeds

    M558 P5 C"zprobe.in" H5 A1 F600 T6000 ; set Z probe type to unmodulated and the dive height + speeds
    
    M558 P5 C"zprobe.in" H5 A1 F120 T6000 ; set Z probe type to unmodulated and the dive height + speeds
    

    Thats what i would try first but as i said it might not be the right way to do it.



  • @CaLviNx Thanks for the help mate, I will give it a try.



  • @MichaelMD1978 said in RRF 3.1.1 Probe Issues:

    @CaLviNx This is my current M558:

    M558 P5 C"zprobe.in" H5 F120 T6000 ; set Z probe type to unmodulated and the dive height + speeds

    How do I edit that to probe twice?

    You need to add the A and S parameters.

    If you wish to force it to always probe twice use A2 S-1. It will average the 2 readings. If A was 5 it would average 5 readings, etc.

    If you wish to have it try to obtain two consecutive readings that are close in value you would use something like A5 S0.1

    With those values it would would probe up to 5 times until 2 readings were within 0.1.

    If it failed to obtain 2 readings within 0.1 it would average the 5 readings.

    Frederick



  • @fcwilt Thank you! That's perfect!



  • @fcwilt said in RRF 3.1.1 Probe Issues:

    @MichaelMD1978 said in RRF 3.1.1 Probe Issues:

    @CaLviNx This is my current M558:

    M558 P5 C"zprobe.in" H5 F120 T6000 ; set Z probe type to unmodulated and the dive height + speeds

    How do I edit that to probe twice?

    You need to add the A and S parameters.

    If you wish to force it to always probe twice use A2 S-1. It will average the 2 readings. If A was 5 it would average 5 readings, etc.

    If you wish to have it try to obtain two consecutive readings that are close in value you would use something like A5 S0.1

    With those values it would would probe up to 5 times until 2 readings were within 0.1.

    If it failed to obtain 2 readings within 0.1 it would average the 5 readings.

    Frederick

    Yes that works to do multiple same speed probes but doesn't answer his initial question

    it would probe once fast and once slow in each spot, now it only probes each point once? Has anyone else noticed this and how can I fix it?



  • @CaLviNx Thanks for all your help too mate, I don't really need them to probe at different speeds, just having it probe twice will also work for me.



  • @MichaelMD1978

    Even if this is not really required by you, the point it raises it would be interesting to find if there is a solution.



  • at the moment, I believe the solution you're using is the only one @CaLviNx
    I use the same thing. I think it's on the "list" to be looked at to allow different homing speeds i.e. fast and slow.



  • @CaLviNx said in RRF 3.1.1 Probe Issues:

    @MichaelMD1978

    Even if this is not really required by you, the point it raises it would be interesting to find if there is a solution.

    Well as you have determined the F parameter controls the probing speed.

    That would seem to qualify as a solution.

    When homing using endstop sensors the typical code has always include changes in the F parameter for the G1 commands.

    Frederick


Log in to reply