Twice as much filament is being extruded



  • Hello guys!
    I've just converted my FFCP machine to the Duet 2 wifi board. I've got most of the things set up, except of the extrusion ratio.
    I did the Esteps calibration and now got exactly 100mm being extruded, but now my machine is overextruding by a factor of 2! I had to drop extrusion multiplier to 0.52 in S3D.
    Mechanically printer is the same, only main board changed.

    where should I look for the solution?

    Here's my config.g file:

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Sun Oct 11 2020 21:41:36 GMT+0300 (Москва, стандартное время)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Duet_Creator" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M569 P4 S0 ; physical drive 4 goes backwards
    M584 X0 Y1 Z2 E3:4 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X94.12 Y94.12 Z400.00 E192.55:192.55 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00:120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X288000.00 Y288000.00 Z43200.00 E72000.00:72000.00 ; set maximum speeds (mm/min)
    M201 X560.00 Y560.00 Z200.00 E300.00:300.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z400 E1200:1200 I20 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X-113.5 Y-74 Z0 S1 ; set axis minima
    M208 X113.5 Y74 Z170 S0 ; set axis maxima

    ; Endstops
    M574 X2 S1 P"!xstop" ; configure active-high endstop for high end on X via pin !xstop
    M574 Y2 S1 P"!ystop" ; configure active-high endstop for high end on Y via pin !ystop
    M574 Z1 S1 P"!zstop" ; configure active-high endstop for low end on Z via pin !zstop

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X-113.5:113.5 Y-74:74 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T94573 B4230 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4144 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    M308 S2 P"e1temp" Y"thermistor" T100000 B4144 ; configure sensor 2 as thermistor on pin e1temp
    M950 H2 C"e1heat" T2 ; create nozzle heater output on e1heat and map it to sensor 2
    M307 H2 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q250 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan2" Q500 ; create fan 2 on pin fan2 and set its frequency
    M106 P2 S1 H2 T45 ; set fan 2 value. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Left Extruder" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"Right Extruder" D1 H2 F0 ; define tool 1
    G10 P1 X0 Y0 Z0 ; set tool 1 axis offsets
    G10 P1 R0 S0 ; set initial tool 1 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M575 P1 S1 B57600 ; enable support for PanelDue
    M501



  • @Viburnum said in Twice as much filament is being extruded:

    E192.55:192.55

    thats an unusual e step.
    do you have a 0.9 degree stepper motor on your extruder?

    with a 1.8 degree stepper which most people use you have
    around 100 normal ungeared extruders
    around 400 geared extruders



  • @Veti oh! I see!
    I have a 1.8 degree motor. I'll try to change it, but why it extrudes 100mm when comand comes from web interface? I thought that it should extrude 200mm...
    anyways, I'll try to change it and will report my results here.
    to be honest I took that number from another thread here about converting FFCP to Duet.



  • @Viburnum you're not using volumetric extrusion and accidentally set your filament to 2.85mm instead of 1.75mm have you?

    If extruding 100mm of filament in DWC pushes 100mm of filament into the extruder, then the machine is calibrated right. I'd double check your slicer settings and print start code.

    Final thought - what speeds are you extruding at (filament speed). Could be you calibrated at too high a speed and the extruder motor was slipping, but unlikely


  • Moderator

    How exactly are you doing the extruder calibration?

    Give this guide a look and see if it matches what you're doing.

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+4:+Calibration/40



  • @Phaedrux yep I did that procedure, except that I was pushing a button on thw LCD instead of entering commands directly.

    After all I've changed esteps and did a calibration with manually entering gcodes, now everything works fine.

    Thank you guys!!


Log in to reply