Question about auto-leveling results



  • Hi,

    I recently implemented auto-leveling on one of my printers.

    I included 3 Z endstop sensors so I can do a rough leveling when homing before running G32, which I run twice.

    The bed.g ends with a G30 to set the Z=0 datum.

    I haven't attempted to position the Z endstop sensors perfectly so the results of the first G32 run make sense:

    Leadscrew adjustments made: -0.812 -1.601 -0.985, points used 3, (mean, deviation) before (-1.029, 0.308) after (-0.000, 0.000)

    However I don't understand the results of the second run. As you can see they are all similar in value (-0.029 +/- 0.003) but all slightly negative.

    Leadscrew adjustments made: -0.026 -0.032 -0.028, points used 3, (mean, deviation) before (-0.028, 0.002) after (0.000, 0.000)

    Are these values referenced to the most recent setting of the Z=0 datum using G30 which is why they are -0.029 +/- 0.003 as opposed to 0.000 +/- 0.003?

    Thanks.

    Frederick



  • @fcwilt said in Question about auto-leveling results:

    Are these values referenced to the most recent setting of the Z=0 datum using G30 which is why they are -0.029 +/- 0.003 as opposed to 0.000 +/- 0.003?

    yes



  • @Veti said in Question about auto-leveling results:

    yes

    There is something you don't see everyday on this forum - a one word answer.

    👍

    Frederick


  • Moderator

    @fcwilt said in Question about auto-leveling results:

    There is something you don't see everyday on this forum - a one word answer.

    It's tricky because the forum software enforces at least 8 characters!


Log in to reply